<!DOCTYPE html>
<html lang="en-US" prefix="og: https://ogp.me/ns#">
<head><meta charset="UTF-8" /><script>if(navigator.userAgent.match(/MSIE|Internet Explorer/i)||navigator.userAgent.match(/Trident\/7\..*?rv:11/i)){var href=document.location.href;if(!href.match(/[?&]nowprocket/)){if(href.indexOf("?")==-1){if(href.indexOf("#")==-1){document.location.href=href+"?nowprocket=1"}else{document.location.href=href.replace("#","?nowprocket=1#")}}else{if(href.indexOf("#")==-1){document.location.href=href+"&nowprocket=1"}else{document.location.href=href.replace("#","&nowprocket=1#")}}}}</script><script>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</script>
<meta http-equiv="x-ua-compatible" content="ie=edge" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<link rel="profile" href="https://gmpg.org/xfn/11" />

<title>How to Install Ansible on Ubuntu 22.04 - Cloudbooklet</title><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Roboto%3A400%2C500%2C700%7CPT%20Serif%3A400%2C400i%2C600%7CIBM%20Plex%20Serif%3A500&#038;display=swap" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Roboto%3A400%2C500%2C700%7CPT%20Serif%3A400%2C400i%2C600%7CIBM%20Plex%20Serif%3A500&#038;display=swap" media="print" onload="this.media='all'" /><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Roboto%3A400%2C500%2C700%7CPT%20Serif%3A400%2C400i%2C600%7CIBM%20Plex%20Serif%3A500&#038;display=swap" /></noscript><link rel="stylesheet" href="https://www.cloudbooklet.com/wp-content/cache/min/1/10cda79634a3d24782209e8481bbaf66.css" media="all" data-minify="1" />
<meta name="description" content="How to Install and Setup Ansible on Ubuntu 20.04 Learn to configure Ansible to connect to different servers using SSH private keys" />
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large" />
<link rel="canonical" href="https://www.cloudbooklet.com/how-to-install-ansible-on-ubuntu-22-04/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to Install and Setup Ansible on Ubuntu 20.04" />
<meta property="og:description" content="How to Install and Setup Ansible on Ubuntu 20.04 Learn to configure Ansible to connect to different servers using SSH private keys" />
<meta property="og:url" content="https://www.cloudbooklet.com/how-to-install-ansible-on-ubuntu-22-04/" />
<meta property="og:site_name" content="Cloudbooklet" />
<meta property="article:tag" content="Ansible" />
<meta property="article:tag" content="Google Cloud Platform" />
<meta property="article:tag" content="Ubuntu" />
<meta property="article:tag" content="Ubuntu 20.04" />
<meta property="article:section" content="Google Cloud" />
<meta property="og:updated_time" content="2022-05-20T04:33:57+00:00" />
<meta property="og:image" content="https://media.cloudbooklet.com/wp-content/uploads/2022/05/20043104/How-to-Install-Ansible-on-Ubuntu-22.04.jpg" />
<meta property="og:image:secure_url" content="https://media.cloudbooklet.com/wp-content/uploads/2022/05/20043104/How-to-Install-Ansible-on-Ubuntu-22.04.jpg" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="720" />
<meta property="og:image:alt" content="How to Install Ansible on Ubuntu 22.04" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="article:published_time" content="2022-05-20T04:31:25+00:00" />
<meta property="article:modified_time" content="2022-05-20T04:33:57+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="How to Install and Setup Ansible on Ubuntu 20.04" />
<meta name="twitter:description" content="How to Install and Setup Ansible on Ubuntu 20.04 Learn to configure Ansible to connect to different servers using SSH private keys" />
<meta name="twitter:image" content="https://media.cloudbooklet.com/wp-content/uploads/2022/05/20043104/How-to-Install-Ansible-on-Ubuntu-22.04.jpg" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Cloudbooklet" />
<meta name="twitter:label2" content="Time to read" />
<meta name="twitter:data2" content="3 minutes" />
<script type="application/ld+json" class="rank-math-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.cloudbooklet.com/#organization","name":"Cloudbooklet"},{"@type":"WebSite","@id":"https://www.cloudbooklet.com/#website","url":"https://www.cloudbooklet.com","name":"Cloudbooklet","publisher":{"@id":"https://www.cloudbooklet.com/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://media.cloudbooklet.com/wp-content/uploads/2022/05/20043104/How-to-Install-Ansible-on-Ubuntu-22.04.jpg","url":"https://media.cloudbooklet.com/wp-content/uploads/2022/05/20043104/How-to-Install-Ansible-on-Ubuntu-22.04.jpg","width":"1280","height":"720","caption":"How to Install Ansible on Ubuntu 22.04","inLanguage":"en-US"},{"@type":"Person","@id":"https://www.cloudbooklet.com/articles","name":"Cloudbooklet","url":"https://www.cloudbooklet.com/articles","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/13236c0d65ef329d0755b254f9aa23fa?s=96&amp;d=mm&amp;r=g","url":"https://secure.gravatar.com/avatar/13236c0d65ef329d0755b254f9aa23fa?s=96&amp;d=mm&amp;r=g","caption":"Cloudbooklet","inLanguage":"en-US"},"sameAs":["https://www.cloudbooklet.com"],"worksFor":{"@id":"https://www.cloudbooklet.com/#organization"}},{"@type":"WebPage","@id":"https://www.cloudbooklet.com/how-to-install-ansible-on-ubuntu-22-04/#webpage","url":"https://www.cloudbooklet.com/how-to-install-ansible-on-ubuntu-22-04/","name":"How to Install Ansible on Ubuntu 22.04 - Cloudbooklet","datePublished":"2022-05-20T04:31:25+00:00","dateModified":"2022-05-20T04:33:57+00:00","author":{"@id":"https://www.cloudbooklet.com/articles"},"isPartOf":{"@id":"https://www.cloudbooklet.com/#website"},"primaryImageOfPage":{"@id":"https://media.cloudbooklet.com/wp-content/uploads/2022/05/20043104/How-to-Install-Ansible-on-Ubuntu-22.04.jpg"},"inLanguage":"en-US"},{"@type":"BlogPosting","headline":"How to Install Ansible on Ubuntu 22.04 - Cloudbooklet","datePublished":"2022-05-20T04:31:25+00:00","dateModified":"2022-05-20T04:33:57+00:00","author":{"@id":"https://www.cloudbooklet.com/articles"},"publisher":{"@id":"https://www.cloudbooklet.com/#organization"},"description":"How to Install and Setup Ansible on Ubuntu 20.04 Learn to configure Ansible to connect to different servers using SSH private keys","name":"How to Install Ansible on Ubuntu 22.04 - Cloudbooklet","@id":"https://www.cloudbooklet.com/how-to-install-ansible-on-ubuntu-22-04/#richSnippet","isPartOf":{"@id":"https://www.cloudbooklet.com/how-to-install-ansible-on-ubuntu-22-04/#webpage"},"image":{"@id":"https://media.cloudbooklet.com/wp-content/uploads/2022/05/20043104/How-to-Install-Ansible-on-Ubuntu-22.04.jpg"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://www.cloudbooklet.com/how-to-install-ansible-on-ubuntu-22-04/#webpage"}}]}</script>

<link rel='dns-prefetch' href='//www.cloudbooklet.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Cloudbooklet &raquo; Feed" href="https://www.cloudbooklet.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Cloudbooklet &raquo; Comments Feed" href="https://www.cloudbooklet.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Cloudbooklet &raquo; How to Install Ansible on Ubuntu 22.04 Comments Feed" href="https://www.cloudbooklet.com/how-to-install-ansible-on-ubuntu-22-04/feed/" />
<style id='global-styles-inline-css' type='text/css'>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</style>
<style id='contentberg-child-inline-css' type='text/css'>
.post-content, .entry-content { color: #000000; }

.entry-content { color: #000000; }

.navigation .menu > li:not(:hover) > a, .navigation.dark .menu > li:not(:hover) > a { color: #000000; }

.navigation .menu > li li a { color: #000000 !important; }

.main-footer .bg-wrap:before { opacity: 0.3; }

::selection { background: rgba(0,112,201, 0.7); }

::-moz-selection { background: rgba(0,112,201, 0.7); }

:root { --main-color: #0070c9; }

.cart-action .cart-link .counter,
.main-head.compact .posts-ticker .heading,
.single-cover .overlay .post-cat a,
.main-footer.bold-light .lower-footer .social-link,
.cat-label a:hover,
.cat-label.color a,
.post-thumb:hover .cat-label a,
.carousel-slider .category,
.grid-b-slider .category,
.page-links .current,
.page-links a:hover,
.page-links > span,
.post-content .read-more a:after,
.widget-posts .posts.full .counter:before,
.dark .widget_mc4wp_form_widget input[type="submit"],
.dark .widget-subscribe input[type="submit"],
.woocommerce span.onsale,
.woocommerce a.button,
.woocommerce button.button,
.woocommerce input.button,
.woocommerce #respond input#submit,
.woocommerce a.button.alt,
.woocommerce a.button.alt:hover,
.woocommerce button.button.alt,
.woocommerce button.button.alt:hover,
.woocommerce input.button.alt,
.woocommerce input.button.alt:hover,
.woocommerce #respond input#submit.alt,
.woocommerce #respond input#submit.alt:hover,
.woocommerce a.button:hover,
.woocommerce button.button:hover,
.woocommerce input.button:hover,
.woocommerce #respond input#submit:hover,
.woocommerce nav.woocommerce-pagination ul li span.current,
.woocommerce nav.woocommerce-pagination ul li a:hover,
.woocommerce .widget_price_filter .price_slider_amount .button { background: #0070c9; }

blockquote:before,
.modern-quote:before,
.wp-block-quote.is-style-large:before,
.main-color,
.top-bar .social-icons a:hover,
.navigation .menu > li:hover > a,
.navigation .menu > .current-menu-item > a,
.navigation .menu > .current-menu-parent > a,
.navigation .menu li li:hover > a,
.navigation .menu li li.current-menu-item > a,
.navigation.simple .menu > li:hover > a,
.navigation.simple .menu > .current-menu-item > a,
.navigation.simple .menu > .current-menu-parent > a,
.tag-share .post-tags a:hover,
.post-share-icons a:hover,
.post-share-icons .likes-count,
.author-box .author > span,
.comments-area .section-head .number,
.comments-list .comment-reply-link,
.comment-form input[type=checkbox],
.main-footer.dark .social-link:hover,
.lower-footer .social-icons .fa,
.archive-head .sub-title,
.social-share a:hover,
.social-icons a:hover,
.post-meta .post-cat > a,
.post-meta-c .post-author > a,
.large-post-b .post-footer .author a,
.main-pagination .next a:hover,
.main-pagination .previous a:hover,
.main-pagination.number .current,
.post-content a,
.textwidget a,
.widget-about .more,
.widget-about .social-icons .social-btn:hover,
.widget-social .social-link:hover,
.wp-block-pullquote blockquote:before,
.egcf-modal .checkbox,
.woocommerce .star-rating:before,
.woocommerce .star-rating span:before,
.woocommerce .amount,
.woocommerce .order-select .drop a:hover,
.woocommerce .order-select .drop li.active,
.woocommerce-page .order-select .drop a:hover,
.woocommerce-page .order-select .drop li.active,
.woocommerce .widget_price_filter .price_label .from,
.woocommerce .widget_price_filter .price_label .to,
.woocommerce div.product div.summary p.price,
.woocommerce div.product div.summary span.price,
.woocommerce #content div.product div.summary p.price,
.woocommerce #content div.product div.summary span.price,
.woocommerce .widget_price_filter .ui-slider .ui-slider-handle { color: #0070c9; }

.page-links .current,
.page-links a:hover,
.page-links > span,
.woocommerce nav.woocommerce-pagination ul li span.current,
.woocommerce nav.woocommerce-pagination ul li a:hover { border-color: #0070c9; }

.block-head-b .title { border-bottom: 1px solid #0070c9; }

.widget_categories a:before,
.widget_product_categories a:before,
.widget_archive a:before { border: 1px solid #0070c9; }



</style>
<style id='rocket-lazyload-inline-css' type='text/css'>
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player:focus-within{outline: 2px solid currentColor;outline-offset: 5px;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:100%;width:100%;left:0;top:0;position:absolute;background:url(https://www.cloudbooklet.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat center;background-color: transparent !important;cursor:pointer;border:none;}
</style>
<script data-minify="1" type='text/javascript' src='https://www.cloudbooklet.com/wp-content/cache/min/1/wp-content/themes/contentberg/js/lazysizes.js?ver=1647220742' id='lazysizes-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.cloudbooklet.com/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' id='cookie-notice-front-js-extra'>
/* <![CDATA[ */
var cnArgs = {"ajaxUrl":"https:\/\/www.cloudbooklet.com\/wp-admin\/admin-ajax.php","nonce":"0f33c8f199","hideEffect":"fade","position":"bottom","onScroll":"0","onScrollOffset":"100","onClick":"0","cookieName":"cookie_notice_accepted","cookieTime":"2592000","cookieTimeRejected":"2592000","cookiePath":"\/","cookieDomain":"","redirection":"0","cache":"1","refuse":"0","revokeCookies":"0","revokeCookiesOpt":"automatic","secure":"1"};
/* ]]> */
</script>
<script type="rocketlazyloadscript" async data-rocket-type='text/javascript' src='https://www.cloudbooklet.com/wp-content/plugins/cookie-notice/includes/../js/front.min.js' id='cookie-notice-front-js'></script>
<link rel="alternate" type="application/json+oembed" href="https://www.cloudbooklet.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.cloudbooklet.com%2Fhow-to-install-ansible-on-ubuntu-22-04%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.cloudbooklet.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.cloudbooklet.com%2Fhow-to-install-ansible-on-ubuntu-22-04%2F&#038;format=xml" />
<link rel="preload" as="font" href="https://www.cloudbooklet.com/wp-content/themes/contentberg/css/fontawesome/fonts/fontawesome-webfont.woff2" crossorigin><script type="rocketlazyloadscript" data-minify="1" async custom-element="amp-ad" src="https://www.cloudbooklet.com/wp-content/cache/min/1/v0/amp-ad-0.1.js?ver=1647220742"></script><script type="rocketlazyloadscript">var Sphere_Plugin = {"ajaxurl":"https:\/\/www.cloudbooklet.com\/wp-admin\/admin-ajax.php"};</script><link rel="amphtml" href="https://www.cloudbooklet.com/how-to-install-ansible-on-ubuntu-22-04/?amp=1"><script type="rocketlazyloadscript" id="google_gtagjs" src="https://www.googletagmanager.com/gtag/js?id=G-B7L8QK8YNT" async="async" data-rocket-type="text/javascript"></script>
<script type="rocketlazyloadscript" id="google_gtagjs-inline" data-rocket-type="text/javascript">
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}gtag('set', 'linker', {"domains":["www.cloudbooklet.com"]} );gtag('js', new Date());gtag('config', 'G-B7L8QK8YNT', {} );
</script>
<link rel="icon" href="https://media.cloudbooklet.com/wp-content/uploads/2019/08/05094722/favicon-150x150.png" sizes="32x32" />
<link rel="icon" href="https://media.cloudbooklet.com/wp-content/uploads/2019/08/05094722/favicon.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://media.cloudbooklet.com/wp-content/uploads/2019/08/05094722/favicon.png" />
<meta name="msapplication-TileImage" content="https://media.cloudbooklet.com/wp-content/uploads/2019/08/05094722/favicon.png" />
<style type="text/css" id="wp-custom-css">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</style>
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript>
</head>
<body class="post-template-default single single-post postid-2182 single-format-standard right-sidebar  lazy-smart layout-magazine has-lb cookies-not-set">
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg>
<div class="main-wrap">
<header id="main-head" class="main-head head-nav-below has-search-modal simple">
<div class="inner inner-head" data-sticky-bar="smart">
<div class="wrap cf wrap-head">
<div class="left-contain">
<span class="mobile-nav"><i class="fa fa-bars"></i></span>
<div class="title">
<a href="https://www.cloudbooklet.com/" title="Cloudbooklet" rel="home">
<img class="mobile-logo" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20326%2050'%3E%3C/svg%3E" width="326" height="50" alt="Cloudbooklet" data-lazy-src="https://media.cloudbooklet.com/wp-content/uploads/2019/08/05094936/cblt_logo1.png" /><noscript><img class="mobile-logo" src="https://media.cloudbooklet.com/wp-content/uploads/2019/08/05094936/cblt_logo1.png" width="326" height="50" 
			alt="Cloudbooklet" /></noscript>
<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="logo-image" alt="Cloudbooklet" data-lazy-src="https://media.cloudbooklet.com/wp-content/uploads/2019/08/05094936/cblt_logo1.png" /><noscript><img src="https://media.cloudbooklet.com/wp-content/uploads/2019/08/05094936/cblt_logo1.png" class="logo-image" alt="Cloudbooklet" /></noscript>
</a>
</div>
</div>
<div class="navigation-wrap inline">
<nav class="navigation inline simple light" data-sticky-bar="smart">
<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-1768" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-2637 menu-item-1768"><a href="https://www.cloudbooklet.com/linux/"><span>Linux</span></a></li>
<li id="menu-item-817" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-cat-3 menu-item-817"><a href="https://www.cloudbooklet.com/google-cloud/"><span>Google Cloud</span></a></li>
<li id="menu-item-1377" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-544 menu-item-1377"><a href="https://www.cloudbooklet.com/aws/"><span>AWS</span></a></li>
<li id="menu-item-836" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-836"><a href="https://www.cloudbooklet.com/about/"><span>About</span></a></li>
<li id="menu-item-837" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-837"><a href="https://www.cloudbooklet.com/contact/"><span>Contact</span></a></li>
</ul></div> </nav>
</div>
<div class="actions">
<ul class="social-icons cf">
<li><a href="https://www.facebook.com/cloudbooklet/" class="fa fa-facebook" target="_blank"><span class="visuallyhidden">Facebook</span></a></li>
<li><a href="https://www.youtube.com/channel/UCBWNRcvVx38glmATV5vBxJg" class="fa fa-youtube" target="_blank"><span class="visuallyhidden">YouTube</span></a></li>
<li><a href="https://www.linkedin.com/company/cloudbooklet/" class="fa fa-linkedin" target="_blank"><span class="visuallyhidden">LinkedIn</span></a></li>
</ul>
<a href="#" title="Search" class="search-link"><i class="fa fa-search"></i></a>
</div>
</div>
</div>
</header> 
<script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script type="rocketlazyloadscript">
		 (adsbygoogle = window.adsbygoogle || []).push({
			  google_ad_client: "ca-pub-8369449682999832",
			  enable_page_level_ads: true
		 });
	</script>
<div class="main wrap">
<div id="post-2182" class="single-magazine post-2182 post type-post status-publish format-standard has-post-thumbnail category-google-cloud category-compute-engine tag-ansible tag-google-cloud tag-ubuntu tag-ubuntu-20-04">
<div class="post-top cf">
<span class="cat-label cf color"><a href="https://www.cloudbooklet.com/google-cloud/" rel="category tag">Google Cloud</a> <a href="https://www.cloudbooklet.com/google-cloud/compute-engine/" rel="category tag">Compute Engine</a></span>
<h1 class="post-title">How to Install Ansible on Ubuntu 22.04</h1>
<p class="disclosure"><strong>Disclosure:</strong> This post may contain affiliate links, which means we may receive a commission if you click a link and purchase something that we recommended. </p>
<div class="post-meta post-meta-c the-post-meta">
<span class="post-author"><span class="by">By</span> <a href="https://www.cloudbooklet.com/articles" title="Posts by Cloudbooklet" rel="author">Cloudbooklet</a></span>
<span class="meta-sep"></span>
<a href="https://www.cloudbooklet.com/how-to-install-ansible-on-ubuntu-22-04/" class="date-link"><time class="post-date" datetime="2022-05-20T04:31:25+00:00">May 20, 2022</time></a>
</div>
</div>
<div class="ts-row cf">
<div class="col-8 main-content cf">
<article class="the-post">
<header class="post-header cf">
<div class="featured">
<a href="https://media.cloudbooklet.com/wp-content/uploads/2022/05/20043104/How-to-Install-Ansible-on-Ubuntu-22.04.jpg" class="image-link"><img width="770" height="433" src="https://media.cloudbooklet.com/wp-content/uploads/2022/05/20043104/How-to-Install-Ansible-on-Ubuntu-22.04-1024x576.jpg" class="attachment-large size-large lazyload wp-post-image" alt="How to Install Ansible on Ubuntu 22.04" title="How to Install Ansible on Ubuntu 22.04" data-srcset="https://media.cloudbooklet.com/wp-content/uploads/2022/05/20043104/How-to-Install-Ansible-on-Ubuntu-22.04-1024x576.jpg 1024w, https://media.cloudbooklet.com/wp-content/uploads/2022/05/20043104/How-to-Install-Ansible-on-Ubuntu-22.04-300x169.jpg 300w, https://media.cloudbooklet.com/wp-content/uploads/2022/05/20043104/How-to-Install-Ansible-on-Ubuntu-22.04-768x432.jpg 768w, https://media.cloudbooklet.com/wp-content/uploads/2022/05/20043104/How-to-Install-Ansible-on-Ubuntu-22.04.jpg 1280w" data-src="https://media.cloudbooklet.com/wp-content/uploads/2022/05/20043104/How-to-Install-Ansible-on-Ubuntu-22.04-1024x576.jpg" data-sizes="(max-width: 770px) 100vw, 770px" /> </a>
</div>
</header>
<div>
<div class="post-share-float share-float-a is-hidden cf">
<span class="share-text">Share</span>
<div class="services">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.cloudbooklet.com%2Fhow-to-install-ansible-on-ubuntu-22-04%2F" class="cf service facebook" target="_blank" title="Share on Facebook">
<i class="fa fa-facebook"></i>
<span class="label">Share on Facebook</span>
</a>
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.cloudbooklet.com%2Fhow-to-install-ansible-on-ubuntu-22-04%2F&text=How%20to%20Install%20Ansible%20on%20Ubuntu%2022.04" class="cf service twitter" target="_blank" title="Share on Twitter">
<i class="fa fa-twitter"></i>
<span class="label">Share on Twitter</span>
</a>
<a href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.cloudbooklet.com%2Fhow-to-install-ansible-on-ubuntu-22-04%2F&media=https%3A%2F%2Fmedia.cloudbooklet.com%2Fwp-content%2Fuploads%2F2022%2F05%2F20043104%2FHow-to-Install-Ansible-on-Ubuntu-22.04.jpg&description=How%20to%20Install%20Ansible%20on%20Ubuntu%2022.04" class="cf service pinterest" target="_blank" title="Pinterest">
<i class="fa fa-pinterest-p"></i>
<span class="label">Pinterest</span>
</a>
<a href="/cdn-cgi/l/email-protection#16296563747c7375622b5e796133242662793324265f786562777a7a3324265778657f747a7333242679783324264374637862633324262424382622307479726f2b7e6262666533255733245033245061616138757a7963727479797d7a73623875797b3324507e79613b62793b7f786562777a7a3b7778657f747a733b79783b6374637862633b24243b2622332450" class="cf service email" target="_blank" title="Email">
<i class="fa fa-envelope-o"></i>
<span class="label">Email</span>
</a>
</div>
</div>
</div>
<div class="post-content description cf entry-content has-share-float content-spacious">
<p>Install Ansible on Ubuntu 22.04 and configure it to connect to remote servers to automate several tasks. Ansible is a configuration management tool which offers an architecture that doesn’t require special software to be installed on nodes, using SSH to execute the automation tasks and YAML files to define provisioning details.</p>
<p>In this guide you are going to learn how to install Ansible on a Ubuntu 22.04 server and configure it to connect with remote servers on Google cloud and AWS instances.</p><div class="wp-block-file"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-8369449682999832" data-ad-slot="9245800364"></ins>
<script type="rocketlazyloadscript">
			 (adsbygoogle = window.adsbygoogle || []).push({});
		</script></div>
<div class="wp-block-columns are-vertically-aligned-center kinsta-banner has-background" style="background-color:#5333ed">
<div class="wp-block-column is-vertically-aligned-center" style="flex-basis:25%">
<figure class="wp-block-image size-full is-resized"><a href="/recommended/kinsta-hosting" target="_blank" rel="noopener"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20117%2090'%3E%3C/svg%3E" alt="kinda logo" class="wp-image-2058" width="117" height="90" data-lazy-srcset="https://media.cloudbooklet.com/wp-content/uploads/2022/03/09082859/kinda-logo.png 117w, https://media.cloudbooklet.com/wp-content/uploads/2022/03/09082859/kinda-logo-87x67.png 87w" data-lazy-sizes="(max-width: 117px) 100vw, 117px" title="How to Install Ansible on Ubuntu 22.04" data-lazy-src="https://media.cloudbooklet.com/wp-content/uploads/2022/03/09082859/kinda-logo.png"><noscript><img src="https://media.cloudbooklet.com/wp-content/uploads/2022/03/09082859/kinda-logo.png" alt="kinda logo" class="wp-image-2058" width="117" height="90" srcset="https://media.cloudbooklet.com/wp-content/uploads/2022/03/09082859/kinda-logo.png 117w, https://media.cloudbooklet.com/wp-content/uploads/2022/03/09082859/kinda-logo-87x67.png 87w" sizes="(max-width: 117px) 100vw, 117px" title="How to Install Ansible on Ubuntu 22.04"></noscript></a></figure>
</div>
<div class="wp-block-column is-vertically-aligned-center" style="flex-basis:50%">
<figure class="wp-block-image size-full"><a href="/recommended/kinsta-hosting" target="_blank" rel="noopener"><img width="337" height="90" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20337%2090'%3E%3C/svg%3E" alt="two months" class="wp-image-2057" data-lazy-srcset="https://media.cloudbooklet.com/wp-content/uploads/2022/03/09082802/two-months.png 337w, https://media.cloudbooklet.com/wp-content/uploads/2022/03/09082802/two-months-300x80.png 300w" data-lazy-sizes="(max-width: 337px) 100vw, 337px" title="How to Install Ansible on Ubuntu 22.04" data-lazy-src="https://media.cloudbooklet.com/wp-content/uploads/2022/03/09082802/two-months.png"><noscript><img width="337" height="90" src="https://media.cloudbooklet.com/wp-content/uploads/2022/03/09082802/two-months.png" alt="two months" class="wp-image-2057" srcset="https://media.cloudbooklet.com/wp-content/uploads/2022/03/09082802/two-months.png 337w, https://media.cloudbooklet.com/wp-content/uploads/2022/03/09082802/two-months-300x80.png 300w" sizes="(max-width: 337px) 100vw, 337px" title="How to Install Ansible on Ubuntu 22.04"></noscript></a></figure>
</div>
<div class="wp-block-column is-vertically-aligned-center" style="flex-basis:25%">
<div class="wp-container-1 wp-block-buttons">
<div class="wp-block-button kinsta-button"><a class="wp-block-button__link has-text-color has-background" href="/recommended/kinsta-hosting" style="border-radius:51px;background-color:#2cd4d9;color:#0021b6" target="_blank" rel="noreferrer noopener">GET STARTED</a></div>
</div>
</div>
</div>
<h3>Prerequisites</h3>
<p>Root access to your server or user access with sudo privileges</p>
<h3>Step 1: Initial server setup</h3>
<p>Start by updating the packages to the latest version available.</p>
<pre class="wp-block-preformatted">sudo apt update
sudo apt upgrade</pre>
<h3>Step 2: Install Ansible</h3>
<p>Once all packages are updated you can proceed to install Ansible.</p>
<pre class="wp-block-preformatted">sudo apt install ansible</pre>
<p>Once the installation is completed you can check the Ansible version installed using the following command.</p>
<pre class="wp-block-preformatted">ansible --version</pre>
<p>You will get an output similar to the one below.</p><div class="wp-block-file"><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-8369449682999832" data-ad-slot="9245800364"></ins>
<script type="rocketlazyloadscript">
			 (adsbygoogle = window.adsbygoogle || []).push({});
		</script></div>
<pre class="wp-block-preformatted"><span class="replace">Output</span>
ansible 2.10.8
  config file = None
  configured module search path = ['/home/pappinvijak/.ansible/plugins/modules', '/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python3/dist-packages/ansible
  executable location = /usr/bin/ansible
  python version = 3.10.4 (main, Apr  2 2022, 09:04:19) [GCC 11.2.0]</pre>
<h3>Step 3: Setup Inventory File</h3>
<p>The inventory file contains all information about the hosts that you will manage with Ansible.</p>
<p>To configure inventory file you can open the <code>/etc/ansible/hosts</code>&nbsp;file and adjust the configurations.</p>
<pre class="wp-block-preformatted">sudo nano /etc/ansible/hosts</pre>
<p>Here you can configure multiple groups and their own variables.</p>
<p>Provided a sample configuration of remote server connection details to connect to Google cloud and AWS instances.</p>
<pre class="wp-block-preformatted">[<span class="replace">google_cloud</span>]
gcp_instance_1 ansible_host=<span class="replace">EXTERNAL_IP</span>

[<span class="replace">google_cloud</span>:vars]
ansible_ssh_user=<span class="replace">username</span>
ansible_ssh_private_key_file=<span class="replace">path_to_private-key</span>

[<span class="replace">aws</span>]
aws_instance_1 ansible_host=<span class="replace">EXTERNAL_IP</span>

[<span class="replace">aws</span>:vars]
ansible_ssh_user=<span class="replace">username</span>
ansible_ssh_private_key_file=<span class="replace">path_to_private-key-or-pem-key</span>

[all:vars]
ansible_python_interpreter=/usr/bin/python3</pre>
<p>Here we have created two groups <code>google_cloud</code> and <code>aws</code> and there own corresponding variables with SSH username and the private keys.</p><div class="wp-block-file"><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-8369449682999832" data-ad-slot="9245800364"></ins>
<script type="rocketlazyloadscript">
			 (adsbygoogle = window.adsbygoogle || []).push({});
		</script></div>
<p>You can check the inventory using the following command.</p>
<pre class="wp-block-preformatted">ansible-inventory --list -y</pre>
<p>You will receive and output similar to the one below with the respective variables in the corresponding group.</p>
<pre class="wp-block-preformatted"><span class="replace">Output</span>
all:
  children:
    google_cloud:
      hosts:
        gcp_instance_1:
          ansible_host: EXTERNAL_IP
          ansible_python_interpreter: /usr/bin/python3
          ansible_ssh_user=username
          ansible_ssh_private_key_file=path_to_private-key
    aws:
      hosts:
        aws_instance_1:
          ansible_host: EXTERNAL_IP
          ansible_python_interpreter: /usr/bin/python3
          ansible_ssh_user=username
          ansible_ssh_private_key_file=path_to_private-key-or-pem-key
  <code>ungrouped: {}</code></pre>
<p>You need to add the public key to the remote host and configure the private key to make a successful connection.</p>
<p>Once you have configured all required details you can proceed to test the connection.</p>
<h3>Step 4: Test Connection</h3>
<p>Now Ansible should be able to connect to the servers listed in the inventory file using SSH.</p><div class="wp-block-file"><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-8369449682999832" data-ad-slot="9245800364"></ins>
<script type="rocketlazyloadscript">
			 (adsbygoogle = window.adsbygoogle || []).push({});
		</script></div>
<p>To check connection on all servers you can use the following command.</p>
<pre class="wp-block-preformatted">ansible all -m ping</pre>
<p>To check connection on a specific group you can use this command</p>
<pre class="wp-block-preformatted">ansible google_cloud -m ping</pre>
<p>The ping module will test</p>
<ul><li>if hosts are accessible;</li><li>if you have valid SSH credentials;</li><li>if hosts are able to run Ansible modules using Python.</li></ul>
<p>You will get an output similar to the one below.</p>
<pre class="wp-block-preformatted"><span class="replace">Output</span>
gcp_instance_1 | SUCCESS =&gt; {
  "changed": false,
  "ping": "pong"
}</pre>
<p>If the configuration is not made properly you will get this message.</p><div class="wp-block-file"><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-8369449682999832" data-ad-slot="9245800364"></ins>
<script type="rocketlazyloadscript">
			 (adsbygoogle = window.adsbygoogle || []).push({});
		</script></div>
<pre class="wp-block-preformatted"><span class="replace">Output</span>
gcp_instance_1 | UNREACHABLE! =&gt; {
  "changed": false,
  "msg": "Failed to connect to the host via ssh: <span class="replace"><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="64111701160a0509012457514a56575c4a5557544a555455">[email&#160;protected]</a></span>: Permission denied (publickey).",
  "unreachable": true
}</pre>
<p>If you have any connection problems you need to provide proper SSH credentials and make sure you can connect using that credentials.</p>
<h3>Conclusion</h3>
<p>Now you have learned how to install Ansible on Ubuntu 22.04 and configure it to connect to remote servers on Google cloud and AWS.</p>
<p>Thanks for your time. If you face any problem or any feedback, please leave a comment below. </p>
</div>
<div class="the-post-foot cf">
<div class="tag-share cf">
<div class="post-tags"><a href="https://www.cloudbooklet.com/tag/ansible/" rel="tag">Ansible</a><a href="https://www.cloudbooklet.com/tag/google-cloud/" rel="tag">Google Cloud Platform</a><a href="https://www.cloudbooklet.com/tag/ubuntu/" rel="tag">Ubuntu</a><a href="https://www.cloudbooklet.com/tag/ubuntu-20-04/" rel="tag">Ubuntu 20.04</a></div>
<div class="post-share">
</div>
</div>
</div>
<section class="related-posts grid-3">
<h4 class="section-head"><span class="title">Related Posts</span></h4>
<div class="ts-row posts cf">
<article class="post col-4">
<a href="https://www.cloudbooklet.com/how-to-install-node-js-with-nvm-and-nginx-on-ubuntu-22-04/" title="How to Install Node.js with NVM and Nginx on Ubuntu 22.04" class="image-link">
 <img width="270" height="180" src="https://media.cloudbooklet.com/wp-content/uploads/2022/05/03023509/How-to-Install-Node.js-with-NVM-and-Nginx-on-Ubuntu-22.04-270x180.jpg" class="image lazyload wp-post-image" alt="How to Install Node.js with NVM and Nginx on Ubuntu 22.04" title="How to Install Node.js with NVM and Nginx on Ubuntu 22.04" loading="lazy" data-srcset="https://media.cloudbooklet.com/wp-content/uploads/2022/05/03023509/How-to-Install-Node.js-with-NVM-and-Nginx-on-Ubuntu-22.04-270x180.jpg 270w, https://media.cloudbooklet.com/wp-content/uploads/2022/05/03023509/How-to-Install-Node.js-with-NVM-and-Nginx-on-Ubuntu-22.04-770x515.jpg 770w, https://media.cloudbooklet.com/wp-content/uploads/2022/05/03023509/How-to-Install-Node.js-with-NVM-and-Nginx-on-Ubuntu-22.04-370x245.jpg 370w" data-src="https://media.cloudbooklet.com/wp-content/uploads/2022/05/03023509/How-to-Install-Node.js-with-NVM-and-Nginx-on-Ubuntu-22.04-270x180.jpg" data-sizes="(max-width: 270px) 100vw, 270px" data-> </a>
<div class="content">
<h3 class="post-title"><a href="https://www.cloudbooklet.com/how-to-install-node-js-with-nvm-and-nginx-on-ubuntu-22-04/" class="post-link">How to Install Node.js with NVM and Nginx on Ubuntu 22.04</a></h3>
<div class="post-meta">
<time class="post-date" datetime="2022-05-03T02:35:26+00:00">May 3, 2022</time>
</div>
</div>
</article >
<article class="post col-4">
<a href="https://www.cloudbooklet.com/how-to-install-apache-tomcat-10-on-ubuntu-20-04-with-nginx/" title="How to Install Apache Tomcat 10 on Ubuntu 20.04 with Nginx" class="image-link">
<img width="270" height="180" src="https://media.cloudbooklet.com/wp-content/uploads/2022/04/20112829/How-to-Install-Apache-Tomcat-10-on-Ubuntu-20.04-with-Nginx-270x180.jpg" class="image lazyload wp-post-image" alt="How to Install Apache Tomcat 10 on Ubuntu 20.04 with Nginx" title="How to Install Apache Tomcat 10 on Ubuntu 20.04 with Nginx" loading="lazy" data-srcset="https://media.cloudbooklet.com/wp-content/uploads/2022/04/20112829/How-to-Install-Apache-Tomcat-10-on-Ubuntu-20.04-with-Nginx-270x180.jpg 270w, https://media.cloudbooklet.com/wp-content/uploads/2022/04/20112829/How-to-Install-Apache-Tomcat-10-on-Ubuntu-20.04-with-Nginx-770x515.jpg 770w, https://media.cloudbooklet.com/wp-content/uploads/2022/04/20112829/How-to-Install-Apache-Tomcat-10-on-Ubuntu-20.04-with-Nginx-370x245.jpg 370w" data-src="https://media.cloudbooklet.com/wp-content/uploads/2022/04/20112829/How-to-Install-Apache-Tomcat-10-on-Ubuntu-20.04-with-Nginx-270x180.jpg" data-sizes="(max-width: 270px) 100vw, 270px" /> </a>
<div class="content">
<h3 class="post-title"><a href="https://www.cloudbooklet.com/how-to-install-apache-tomcat-10-on-ubuntu-20-04-with-nginx/" class="post-link">How to Install Apache Tomcat 10 on Ubuntu 20.04 with Nginx</a></h3>
<div class="post-meta">
<time class="post-date" datetime="2022-04-20T11:28:50+00:00">April 20, 2022</time>
</div>
</div>
</article >
<article class="post col-4">
<a href="https://www.cloudbooklet.com/install-nopcommerce-on-ubuntu-20-04-mysql-nginx-ssl/" title="Install nopCommerce on Ubuntu 20.04, MySQL, Nginx, SSL" class="image-link">
<img width="270" height="180" src="https://media.cloudbooklet.com/wp-content/uploads/2022/04/06073703/Install-nopCommerce-on-Ubuntu-20.04-MySQL-Nginx-SSL-270x180.jpg" class="image lazyload wp-post-image" alt="Install nopCommerce on Ubuntu 20.04 MySQL Nginx SSL" title="Install nopCommerce on Ubuntu 20.04, MySQL, Nginx, SSL" loading="lazy" data-srcset="https://media.cloudbooklet.com/wp-content/uploads/2022/04/06073703/Install-nopCommerce-on-Ubuntu-20.04-MySQL-Nginx-SSL-270x180.jpg 270w, https://media.cloudbooklet.com/wp-content/uploads/2022/04/06073703/Install-nopCommerce-on-Ubuntu-20.04-MySQL-Nginx-SSL-770x515.jpg 770w, https://media.cloudbooklet.com/wp-content/uploads/2022/04/06073703/Install-nopCommerce-on-Ubuntu-20.04-MySQL-Nginx-SSL-370x245.jpg 370w" data-src="https://media.cloudbooklet.com/wp-content/uploads/2022/04/06073703/Install-nopCommerce-on-Ubuntu-20.04-MySQL-Nginx-SSL-270x180.jpg" data-sizes="(max-width: 270px) 100vw, 270px" /> </a>
<div class="content">
<h3 class="post-title"><a href="https://www.cloudbooklet.com/install-nopcommerce-on-ubuntu-20-04-mysql-nginx-ssl/" class="post-link">Install nopCommerce on Ubuntu 20.04, MySQL, Nginx, SSL</a></h3>
<div class="post-meta">
<time class="post-date" datetime="2022-04-06T07:37:33+00:00">April 6, 2022</time>
</div>
</div>
</article >
</div>
</section>
<div class="comments">
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title"><span class="section-head"><span class="title">Write A Comment</span></span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/how-to-install-ansible-on-ubuntu-22-04/#respond" style="display:none;">Cancel Reply</a></small></h3><form action="https://www.cloudbooklet.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
<div class="inline-field">
<input name="author" id="author" type="text" value="" aria-required="true" placeholder="Name" required />
</div>
<div class="inline-field">
<input name="email" id="email" type="text" value="" aria-required="true" placeholder="Email" required />
</div>
<div class="reply-field cf">
<textarea name="comment" id="comment" cols="45" rows="7" placeholder="Enter your comment here.." aria-required="true" required></textarea>
</div>
<p class="comment-form-cookies-consent">
<input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" />
<label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.
</label>
</p>
<div class="gglcptch gglcptch_invisible"><div class="google-captcha-notice">This site is protected by reCAPTCHA and the Google <a href="https://policies.google.com/privacy" target="_blank">Privacy Policy</a> and <a href="https://policies.google.com/terms" target="_blank">Terms of Service</a> apply.</div><div id="gglcptch_recaptcha_412979195" class="gglcptch_recaptcha"></div>
<noscript>
					<div style="width: 302px;">
						<div style="width: 302px; height: 422px; position: relative;">
							<div style="width: 302px; height: 422px; position: absolute;">
								<iframe src="https://www.google.com/recaptcha/api/fallback?k=6LcRq3oUAAAAAMgQwu9M_Xl_YfqYhB1JdQFlM0J9" frameborder="0" scrolling="no" style="width: 302px; height:422px; border-style: none;"></iframe>
							</div>
						</div>
						<div style="border-style: none; bottom: 12px; left: 25px; margin: 0px; padding: 0px; right: 25px; background: #f9f9f9; border: 1px solid #c1c1c1; border-radius: 3px; height: 60px; width: 300px;">
							<textarea id="g-recaptcha-response" name="g-recaptcha-response" class="g-recaptcha-response" style="width: 250px !important; height: 40px !important; border: 1px solid #c1c1c1 !important; margin: 10px 25px !important; padding: 0px !important; resize: none !important;"></textarea>
						</div>
					</div>
				</noscript></div><p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='2182' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="60e728bb56" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="228" /><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript">document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form> </div>
</div>
</div>
</article> 
</div>
<aside class="col-4 sidebar" data-sticky="1">
<div class="inner theiaStickySidebar">
<ul>
<li id="bunyad-widget-ads-2" class="widget widget-a-wrap">
<div class="the-wrap">
<script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-8369449682999832" crossorigin="anonymous"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-8369449682999832" data-ad-slot="6157125687" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script> </div>
</li>
<li id="bunyad-posts-widget-6" class="widget widget-posts">
<h5 class="widget-title"><span>Recent Tutorials</span></h5>
<ul class="posts cf meta-below">
<li class="post cf">
<a href="https://www.cloudbooklet.com/how-to-install-ansible-on-ubuntu-22-04/" class="image-link">
<img width="87" height="67" src="https://media.cloudbooklet.com/wp-content/uploads/2022/05/20043104/How-to-Install-Ansible-on-Ubuntu-22.04-87x67.jpg" class="attachment-contentberg-thumb size-contentberg-thumb lazyload wp-post-image" alt="How to Install Ansible on Ubuntu 22.04" title="How to Install Ansible on Ubuntu 22.04" loading="lazy" data-srcset="https://media.cloudbooklet.com/wp-content/uploads/2022/05/20043104/How-to-Install-Ansible-on-Ubuntu-22.04-87x67.jpg 87w, https://media.cloudbooklet.com/wp-content/uploads/2022/05/20043104/How-to-Install-Ansible-on-Ubuntu-22.04-260x200.jpg 260w" data-src="https://media.cloudbooklet.com/wp-content/uploads/2022/05/20043104/How-to-Install-Ansible-on-Ubuntu-22.04-87x67.jpg" data-sizes="(max-width: 87px) 100vw, 87px" /> </a>
<div class="content">
<a href="https://www.cloudbooklet.com/how-to-install-ansible-on-ubuntu-22-04/" class="post-title limit-line" title="How to Install Ansible on Ubuntu 22.04">How to Install Ansible on Ubuntu 22.04</a>
<div class="post-meta post-meta-a">
<a href="https://www.cloudbooklet.com/how-to-install-ansible-on-ubuntu-22-04/" class="date-link"><time class="post-date" datetime="2022-05-20T04:31:25+00:00">May 20, 2022</time></a>
</div>
<div class="excerpt"><p>Install Ansible on Ubuntu 22.04 and configure it to connect to remote servers to automate&hellip;</p>
</div>
</div>
</li>
<li class="post cf">
<a href="https://www.cloudbooklet.com/how-to-install-php-fpm-with-apache-on-ubuntu-22-04-2/" class="image-link">
<img width="87" height="67" src="https://media.cloudbooklet.com/wp-content/uploads/2022/05/18034038/How-to-Install-PHP-FPM-with-Apache-on-Ubuntu-22.04-1-87x67.jpg" class="attachment-contentberg-thumb size-contentberg-thumb lazyload wp-post-image" alt="How to Install PHP-FPM with Apache on Ubuntu 22.04" title="How to Install PHP-FPM with Apache on Ubuntu 22.04" loading="lazy" data-srcset="https://media.cloudbooklet.com/wp-content/uploads/2022/05/18034038/How-to-Install-PHP-FPM-with-Apache-on-Ubuntu-22.04-1-87x67.jpg 87w, https://media.cloudbooklet.com/wp-content/uploads/2022/05/18034038/How-to-Install-PHP-FPM-with-Apache-on-Ubuntu-22.04-1-260x200.jpg 260w" data-src="https://media.cloudbooklet.com/wp-content/uploads/2022/05/18034038/How-to-Install-PHP-FPM-with-Apache-on-Ubuntu-22.04-1-87x67.jpg" data-sizes="(max-width: 87px) 100vw, 87px" /> </a>
<div class="content">
<a href="https://www.cloudbooklet.com/how-to-install-php-fpm-with-apache-on-ubuntu-22-04-2/" class="post-title limit-line" title="How to Install PHP-FPM with Apache on Ubuntu 22.04">How to Install PHP-FPM with Apache on Ubuntu 22.04</a>
<div class="post-meta post-meta-a">
<a href="https://www.cloudbooklet.com/how-to-install-php-fpm-with-apache-on-ubuntu-22-04-2/" class="date-link"><time class="post-date" datetime="2022-05-18T03:41:01+00:00">May 18, 2022</time></a>
</div>
<div class="excerpt"><p>How to install PHP-FPM with Apache on Ubuntu 22.04. There are two distinct options to&hellip;</p>
</div>
</div>
</li>
<li class="post cf">
<a href="https://www.cloudbooklet.com/install-phpmyadmin-on-ubuntu-22-04-with-apache/" class="image-link">
<img width="87" height="67" src="https://media.cloudbooklet.com/wp-content/uploads/2022/05/16010155/Install-phpMyAdmin-on-Ubuntu-22.04-with-Apache-87x67.jpg" class="attachment-contentberg-thumb size-contentberg-thumb lazyload wp-post-image" alt="Install phpMyAdmin on Ubuntu 22.04 with Apache" title="Install phpMyAdmin on Ubuntu 22.04 with Apache" loading="lazy" data-srcset="https://media.cloudbooklet.com/wp-content/uploads/2022/05/16010155/Install-phpMyAdmin-on-Ubuntu-22.04-with-Apache-87x67.jpg 87w, https://media.cloudbooklet.com/wp-content/uploads/2022/05/16010155/Install-phpMyAdmin-on-Ubuntu-22.04-with-Apache-260x200.jpg 260w" data-src="https://media.cloudbooklet.com/wp-content/uploads/2022/05/16010155/Install-phpMyAdmin-on-Ubuntu-22.04-with-Apache-87x67.jpg" data-sizes="(max-width: 87px) 100vw, 87px" /> </a>
<div class="content">
<a href="https://www.cloudbooklet.com/install-phpmyadmin-on-ubuntu-22-04-with-apache/" class="post-title limit-line" title="Install phpMyAdmin on Ubuntu 22.04 with Apache">Install phpMyAdmin on Ubuntu 22.04 with Apache</a>
<div class="post-meta post-meta-a">
<a href="https://www.cloudbooklet.com/install-phpmyadmin-on-ubuntu-22-04-with-apache/" class="date-link"><time class="post-date" datetime="2022-05-16T01:02:12+00:00">May 16, 2022</time></a>
</div>
<div class="excerpt"><p>phpMyAdmin is a web-based application for interacting with MySQL database server. This tool provides you&hellip;</p>
</div>
</div>
</li>
<li class="post cf">
<a href="https://www.cloudbooklet.com/how-to-install-mariadb-on-ubuntu-22-04/" class="image-link">
<img width="87" height="67" src="https://media.cloudbooklet.com/wp-content/uploads/2022/05/13030710/How-to-Install-MariaDB-on-Ubuntu-22.04-87x67.jpg" class="attachment-contentberg-thumb size-contentberg-thumb lazyload wp-post-image" alt="How to Install MariaDB on Ubuntu 22.04" title="How to Install MariaDB on Ubuntu 22.04" loading="lazy" data-srcset="https://media.cloudbooklet.com/wp-content/uploads/2022/05/13030710/How-to-Install-MariaDB-on-Ubuntu-22.04-87x67.jpg 87w, https://media.cloudbooklet.com/wp-content/uploads/2022/05/13030710/How-to-Install-MariaDB-on-Ubuntu-22.04-260x200.jpg 260w" data-src="https://media.cloudbooklet.com/wp-content/uploads/2022/05/13030710/How-to-Install-MariaDB-on-Ubuntu-22.04-87x67.jpg" data-sizes="(max-width: 87px) 100vw, 87px" /> </a>
<div class="content">
<a href="https://www.cloudbooklet.com/how-to-install-mariadb-on-ubuntu-22-04/" class="post-title limit-line" title="How to Install MariaDB on Ubuntu 22.04">How to Install MariaDB on Ubuntu 22.04</a>
<div class="post-meta post-meta-a">
<a href="https://www.cloudbooklet.com/how-to-install-mariadb-on-ubuntu-22-04/" class="date-link"><time class="post-date" datetime="2022-05-13T03:07:40+00:00">May 13, 2022</time></a>
</div>
<div class="excerpt"><p>How to Install MariaDB on Ubuntu 22.04. MariaDB is one of the most widely used&hellip;</p>
</div>
</div>
</li>
</ul>
</li>
<li id="bunyad-widget-ads-3" class="widget widget-a-wrap">
<div class="the-wrap">
<script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-8369449682999832" crossorigin="anonymous"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-8369449682999832" data-ad-slot="6157125687" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script> </div>
</li>
</ul>
</div>
</aside>
</div> 
</div>
</div> 
<footer class="main-footer dark stylish">
<div class="social-strip">
<ul class="social-icons">
<li>
<a href="https://www.facebook.com/cloudbooklet/" class="social-link" target="_blank"><i class="fa fa-facebook"></i>
<span class="label">Facebook</span></a>
</li>
<li>
<a href="#" class="social-link" target="_blank"><i class="fa fa-twitter"></i>
<span class="label">Twitter</span></a>
</li>
<li>
<a href="https://www.youtube.com/channel/UCBWNRcvVx38glmATV5vBxJg" class="social-link" target="_blank"><i class="fa fa-youtube"></i>
<span class="label">YouTube</span></a>
</li>
<li>
<a href="https://www.linkedin.com/company/cloudbooklet/" class="social-link" target="_blank"><i class="fa fa-linkedin"></i>
<span class="label">LinkedIn</span></a>
</li>
</ul>
</div>
<div class="bg-wrap">
<section class="lower-footer cf">
<div class="wrap">
<div class="footer-logo">
<img class="logo lazyload" src="data:image/svg+xml,%3Csvg%20viewBox%3D%270%200%201%201%27%20xmlns%3D%27http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%27%3E%3C%2Fsvg%3E" alt="Cloudbooklet" data-src="https://media.cloudbooklet.com/wp-content/uploads/2020/08/11094912/logo-white.png" />
</div>
<div class="bottom cf">
<p class="copyright">© 2022 <a href="https://www.cloudbooklet.com">CloudBooklet</a>. All rights reserved. </p>
<div class="to-top">
<a href="#" class="back-to-top"><i class="fa fa-angle-up"></i> Top</a>
</div>
</div>
</div>
</section>
</div>
</footer>
</div> 
<div class="mobile-menu-container off-canvas" id="mobile-menu">
<a href="#" class="close"><i class="fa fa-times"></i></a>
<div class="logo">
<img class="mobile-logo lazyload" src="data:image/svg+xml,%3Csvg%20viewBox%3D%270%200%20326%2050%27%20xmlns%3D%27http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%27%3E%3C%2Fsvg%3E" width="326" height="50" alt="Cloudbooklet" data-src="https://media.cloudbooklet.com/wp-content/uploads/2019/08/05094936/cblt_logo1.png" />
</div>
<ul id="menu-main-menu-1" class="mobile-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1768"><a href="https://www.cloudbooklet.com/linux/">Linux</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-817"><a href="https://www.cloudbooklet.com/google-cloud/">Google Cloud</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1377"><a href="https://www.cloudbooklet.com/aws/">AWS</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-836"><a href="https://www.cloudbooklet.com/about/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-837"><a href="https://www.cloudbooklet.com/contact/">Contact</a></li>
</ul>
</div>
<div class="search-modal-wrap">
<div class="search-modal-box" role="dialog" aria-modal="true">
<form method="get" class="search-form" action="https://www.cloudbooklet.com/">
<input type="search" class="search-field" name="s" placeholder="Search..." value="" required />
<button type="submit" class="search-submit visuallyhidden">Submit</button>
<p class="message">
Type above and press <em>Enter</em> to search. Press <em>Esc</em> to cancel. </p>
</form>
</div>
</div>
<style>.wp-container-1 {display: flex;gap: 0.5em;flex-wrap: wrap;align-items: center;align-items: center;justify-content: center;}.wp-container-1 > * { margin: 0; }</style>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/(.+\/)?feed\/?.+\/?|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/control-panel\/|\/wp-admin\/|\/logout\/|\/control-panel\/","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/www.cloudbooklet.com","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://www.cloudbooklet.com/wp-content/cache/min/1/wp-content/themes/contentberg/js/magnific-popup.js?ver=1647220742' id='magnific-popup-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://www.cloudbooklet.com/wp-content/cache/min/1/wp-content/themes/contentberg/js/jquery.fitvids.js?ver=1647220742' id='jquery-fitvids-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.cloudbooklet.com/wp-includes/js/imagesloaded.min.js' id='imagesloaded-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://www.cloudbooklet.com/wp-content/cache/min/1/wp-content/themes/contentberg/js/object-fit-images.js?ver=1647220742' id='object-fit-images-js' defer></script>
<script type='text/javascript' id='contentberg-theme-js-extra'>
/* <![CDATA[ */
var Bunyad = {"custom_ajax_url":"\/how-to-install-ansible-on-ubuntu-22-04\/"};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://www.cloudbooklet.com/wp-content/cache/min/1/wp-content/themes/contentberg/js/theme.js?ver=1647220742' id='contentberg-theme-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://www.cloudbooklet.com/wp-content/cache/min/1/wp-content/themes/contentberg/js/theia-sticky-sidebar.js?ver=1647220742' id='theia-sticky-sidebar-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://www.cloudbooklet.com/wp-content/cache/min/1/wp-content/themes/contentberg/js/jquery.slick.js?ver=1647220742' id='jquery-slick-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://www.cloudbooklet.com/wp-content/cache/min/1/wp-content/themes/contentberg/js/jarallax.js?ver=1647220742' id='jarallax-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.cloudbooklet.com/wp-includes/js/comment-reply.min.js' id='comment-reply-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' data-cfasync="false" async="async" defer="defer" src='https://www.google.com/recaptcha/api.js?render=explicit' id='gglcptch_api-js'></script>
<script type='text/javascript' id='gglcptch_script-js-extra'>
/* <![CDATA[ */
var gglcptch = {"options":{"version":"invisible","sitekey":"6LcRq3oUAAAAAMgQwu9M_Xl_YfqYhB1JdQFlM0J9","error":"<strong>Warning<\/strong>:&nbsp;More than one reCAPTCHA has been found in the current form. Please remove all unnecessary reCAPTCHA fields to make it work properly.","disable":0},"vars":{"visibility":false}};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://www.cloudbooklet.com/wp-content/cache/min/1/wp-content/plugins/google-captcha/js/script.js?ver=1647220750' id='gglcptch_script-js' defer></script>

<div id="cookie-notice" role="dialog" class="cookie-notice-hidden cookie-revoke-hidden cn-position-bottom" aria-label="Cookie Notice" style="background-color: rgba(50,50,58,1);"><div class="cookie-notice-container" style="color: #ffffff;"><span id="cn-notice-text" class="cn-text-container">We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.</span><span id="cn-notice-buttons" class="cn-buttons-container"><a href="#" id="cn-accept-cookie" data-cookie-set="accept" class="cn-set-cookie cn-button" aria-label="Ok" style="background-color: #0070c9">Ok</a></span><span id="cn-close-notice" data-cookie-set="accept" class="cn-close-icon" title="No"></span></div>
</div>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(var i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.cloudbooklet.com/wp-content/plugins/wp-rocket/assets/js/lazyload/17.5/lazyload.min.js"></script><script>function lazyLoadThumb(e){var t='<img data-lazy-src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"><noscript><img src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"></noscript>',a='<button class="play" aria-label="play Youtube video"></button>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="ID?autoplay=1";t+=0===this.parentNode.dataset.query.length?'':'&'+this.parentNode.dataset.query;e.setAttribute("src",t.replace("ID",this.parentNode.dataset.src)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),e.setAttribute("allow", "accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"),this.parentNode.parentNode.replaceChild(e,this.parentNode)}document.addEventListener("DOMContentLoaded",function(){var e,t,p,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.setAttribute("data-src", a[t].dataset.src),e.innerHTML=lazyLoadThumb(a[t].dataset.id),a[t].appendChild(e),p=e.querySelector('.play'),p.onclick=lazyLoadYoutubeIframe});</script>
</body>
</html>
