<!DOCTYPE html>
<html lang="en-US">
<head><meta charset="UTF-8" /><script>if(navigator.userAgent.match(/MSIE|Internet Explorer/i)||navigator.userAgent.match(/Trident\/7\..*?rv:11/i)){var href=document.location.href;if(!href.match(/[?&]nowprocket/)){if(href.indexOf("?")==-1){if(href.indexOf("#")==-1){document.location.href=href+"?nowprocket=1"}else{document.location.href=href.replace("#","?nowprocket=1#")}}else{if(href.indexOf("#")==-1){document.location.href=href+"&nowprocket=1"}else{document.location.href=href.replace("#","&nowprocket=1#")}}}}</script><script>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</script>
<meta http-equiv="x-ua-compatible" content="ie=edge" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<title>How to Install or Upgrade PHP 8.1 on Ubuntu 20.04 - Cloudbooklet</title><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Roboto%3A400%2C500%2C700%7CPT%20Serif%3A400%2C400i%2C600%7CIBM%20Plex%20Serif%3A500&#038;display=swap" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Roboto%3A400%2C500%2C700%7CPT%20Serif%3A400%2C400i%2C600%7CIBM%20Plex%20Serif%3A500&#038;display=swap" media="print" onload="this.media='all'" /><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Roboto%3A400%2C500%2C700%7CPT%20Serif%3A400%2C400i%2C600%7CIBM%20Plex%20Serif%3A500&#038;display=swap" /></noscript><link rel="stylesheet" href="https://www.cloudbooklet.com/wp-content/cache/min/1/ccc3d0a548251011e0db412a1479693c.css" media="all" data-minify="1" />
<meta name="description" content="How to Install or Upgrade PHP 8.1 on Ubuntu 20.04 . Also learn how to configure PHP for Apache and Nginx web servers." />
<link rel="canonical" href="https://www.cloudbooklet.com/how-to-install-or-upgrade-php-8-1-on-ubuntu-20-04/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to Install or Upgrade PHP 8.1 on Ubuntu 20.04" />
<meta property="og:description" content="How to Install or Upgrade PHP 8.1 on Ubuntu 20.04 . Also learn how to configure PHP for Apache and Nginx web servers." />
<meta property="og:url" content="https://www.cloudbooklet.com/how-to-install-or-upgrade-php-8-1-on-ubuntu-20-04/" />
<meta property="og:site_name" content="Cloudbooklet" />
<meta property="article:published_time" content="2021-12-02T11:05:47+00:00" />
<meta property="article:modified_time" content="2021-12-02T11:05:49+00:00" />
<meta property="og:image" content="https://media.cloudbooklet.com/wp-content/uploads/2021/12/02110504/Install-PHP81-on-Ubuntu.png" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="720" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="How to Install or Upgrade PHP 8.1 on Ubuntu 20.04" />
<meta name="twitter:description" content="How to Install or Upgrade PHP 8.1 on Ubuntu 20.04 . Also learn how to configure PHP for Apache and Nginx web servers." />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Cloudbooklet" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="4 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.cloudbooklet.com/#website","url":"https://www.cloudbooklet.com/","name":"Cloudbooklet","description":"Installation and Set Up on Google Cloud, AWS","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.cloudbooklet.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.cloudbooklet.com/how-to-install-or-upgrade-php-8-1-on-ubuntu-20-04/#primaryimage","inLanguage":"en-US","url":"https://media.cloudbooklet.com/wp-content/uploads/2021/12/02110504/Install-PHP81-on-Ubuntu.png","contentUrl":"https://media.cloudbooklet.com/wp-content/uploads/2021/12/02110504/Install-PHP81-on-Ubuntu.png","width":1280,"height":720,"caption":"Install PHP 8.1 on Ubuntu"},{"@type":"WebPage","@id":"https://www.cloudbooklet.com/how-to-install-or-upgrade-php-8-1-on-ubuntu-20-04/#webpage","url":"https://www.cloudbooklet.com/how-to-install-or-upgrade-php-8-1-on-ubuntu-20-04/","name":"How to Install or Upgrade PHP 8.1 on Ubuntu 20.04 - Cloudbooklet","isPartOf":{"@id":"https://www.cloudbooklet.com/#website"},"primaryImageOfPage":{"@id":"https://www.cloudbooklet.com/how-to-install-or-upgrade-php-8-1-on-ubuntu-20-04/#primaryimage"},"datePublished":"2021-12-02T11:05:47+00:00","dateModified":"2021-12-02T11:05:49+00:00","author":{"@id":"https://www.cloudbooklet.com/#/schema/person/b895618ef766a19d0976cbbdeb3631d0"},"description":"How to Install or Upgrade PHP 8.1 on Ubuntu 20.04 . Also learn how to configure PHP for Apache and Nginx web servers.","breadcrumb":{"@id":"https://www.cloudbooklet.com/how-to-install-or-upgrade-php-8-1-on-ubuntu-20-04/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.cloudbooklet.com/how-to-install-or-upgrade-php-8-1-on-ubuntu-20-04/"]}]},{"@type":"BreadcrumbList","@id":"https://www.cloudbooklet.com/how-to-install-or-upgrade-php-8-1-on-ubuntu-20-04/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.cloudbooklet.com/"},{"@type":"ListItem","position":2,"name":"How to Install or Upgrade PHP 8.1 on Ubuntu 20.04"}]},{"@type":"Person","@id":"https://www.cloudbooklet.com/#/schema/person/b895618ef766a19d0976cbbdeb3631d0","name":"Cloudbooklet","image":{"@type":"ImageObject","@id":"https://www.cloudbooklet.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/13236c0d65ef329d0755b254f9aa23fa?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/13236c0d65ef329d0755b254f9aa23fa?s=96&d=mm&r=g","caption":"Cloudbooklet"},"description":"Cloudbooklet builds a large collection of Linux based guides and tutorials on Cloud platforms like Google Cloud, AWS, Azure, DigitalOcean and more","sameAs":["https://www.cloudbooklet.com"],"url":"https://www.cloudbooklet.com/articles"}]}</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Cloudbooklet &raquo; Feed" href="https://www.cloudbooklet.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Cloudbooklet &raquo; Comments Feed" href="https://www.cloudbooklet.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Cloudbooklet &raquo; How to Install or Upgrade PHP 8.1 on Ubuntu 20.04 Comments Feed" href="https://www.cloudbooklet.com/how-to-install-or-upgrade-php-8-1-on-ubuntu-20-04/feed/" />

<script type="rocketlazyloadscript" src="//www.googletagmanager.com/gtag/js?id=UA-102617346-3" data-rocket-type="text/javascript" data-cfasync="false" async></script>
<script type="rocketlazyloadscript" data-rocket-type="text/javascript" data-cfasync="false">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</script>

<style id='contentberg-child-inline-css' type='text/css'>
.post-content, .entry-content { color: #000000; }

.entry-content { color: #000000; }

.navigation .menu > li:not(:hover) > a, .navigation.dark .menu > li:not(:hover) > a { color: #000000; }

.navigation .menu > li li a { color: #000000 !important; }

body { background-color: #e9ebee; }

.main-footer .bg-wrap:before { opacity: 0.3; }

::selection { background: rgba(0,112,201, 0.7); }

::-moz-selection { background: rgba(0,112,201, 0.7); }

:root { --main-color: #0070c9; }

.cart-action .cart-link .counter,
.main-head.compact .posts-ticker .heading,
.single-cover .overlay .post-cat a,
.main-footer.bold-light .lower-footer .social-link,
.cat-label a:hover,
.cat-label.color a,
.post-thumb:hover .cat-label a,
.carousel-slider .category,
.grid-b-slider .category,
.page-links .current,
.page-links a:hover,
.page-links > span,
.post-content .read-more a:after,
.widget-posts .posts.full .counter:before,
.dark .widget_mc4wp_form_widget input[type="submit"],
.dark .widget-subscribe input[type="submit"],
.woocommerce span.onsale,
.woocommerce a.button,
.woocommerce button.button,
.woocommerce input.button,
.woocommerce #respond input#submit,
.woocommerce a.button.alt,
.woocommerce a.button.alt:hover,
.woocommerce button.button.alt,
.woocommerce button.button.alt:hover,
.woocommerce input.button.alt,
.woocommerce input.button.alt:hover,
.woocommerce #respond input#submit.alt,
.woocommerce #respond input#submit.alt:hover,
.woocommerce a.button:hover,
.woocommerce button.button:hover,
.woocommerce input.button:hover,
.woocommerce #respond input#submit:hover,
.woocommerce nav.woocommerce-pagination ul li span.current,
.woocommerce nav.woocommerce-pagination ul li a:hover,
.woocommerce .widget_price_filter .price_slider_amount .button { background: #0070c9; }

blockquote:before,
.modern-quote:before,
.wp-block-quote.is-style-large:before,
.main-color,
.top-bar .social-icons a:hover,
.navigation .menu > li:hover > a,
.navigation .menu > .current-menu-item > a,
.navigation .menu > .current-menu-parent > a,
.navigation .menu li li:hover > a,
.navigation .menu li li.current-menu-item > a,
.navigation.simple .menu > li:hover > a,
.navigation.simple .menu > .current-menu-item > a,
.navigation.simple .menu > .current-menu-parent > a,
.tag-share .post-tags a:hover,
.post-share-icons a:hover,
.post-share-icons .likes-count,
.author-box .author > span,
.comments-area .section-head .number,
.comments-list .comment-reply-link,
.comment-form input[type=checkbox],
.main-footer.dark .social-link:hover,
.lower-footer .social-icons .fa,
.archive-head .sub-title,
.social-share a:hover,
.social-icons a:hover,
.post-meta .post-cat > a,
.post-meta-c .post-author > a,
.large-post-b .post-footer .author a,
.main-pagination .next a:hover,
.main-pagination .previous a:hover,
.main-pagination.number .current,
.post-content a,
.textwidget a,
.widget-about .more,
.widget-about .social-icons .social-btn:hover,
.widget-social .social-link:hover,
.wp-block-pullquote blockquote:before,
.egcf-modal .checkbox,
.woocommerce .star-rating:before,
.woocommerce .star-rating span:before,
.woocommerce .amount,
.woocommerce .order-select .drop a:hover,
.woocommerce .order-select .drop li.active,
.woocommerce-page .order-select .drop a:hover,
.woocommerce-page .order-select .drop li.active,
.woocommerce .widget_price_filter .price_label .from,
.woocommerce .widget_price_filter .price_label .to,
.woocommerce div.product div.summary p.price,
.woocommerce div.product div.summary span.price,
.woocommerce #content div.product div.summary p.price,
.woocommerce #content div.product div.summary span.price,
.woocommerce .widget_price_filter .ui-slider .ui-slider-handle { color: #0070c9; }

.page-links .current,
.page-links a:hover,
.page-links > span,
.woocommerce nav.woocommerce-pagination ul li span.current,
.woocommerce nav.woocommerce-pagination ul li a:hover { border-color: #0070c9; }

.block-head-b .title { border-bottom: 1px solid #0070c9; }

.widget_categories a:before,
.widget_product_categories a:before,
.widget_archive a:before { border: 1px solid #0070c9; }



</style>
<style id='rocket-lazyload-inline-css' type='text/css'>
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player:focus-within{outline: 2px solid currentColor;outline-offset: 5px;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:100%;width:100%;left:0;top:0;position:absolute;background:url(https://www.cloudbooklet.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat center;background-color: transparent !important;cursor:pointer;border:none;}
</style>
<script type='text/javascript' id='exactmetrics-frontend-script-js-extra'>
/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/www.cloudbooklet.com","hash_tracking":"false","ua":"UA-102617346-3","v4_id":""};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.cloudbooklet.com/wp-content/plugins/google-analytics-dashboard-for-wp/assets/js/frontend-gtag.min.js' id='exactmetrics-frontend-script-js' defer></script>
<script data-minify="1" type='text/javascript' src='https://www.cloudbooklet.com/wp-content/cache/min/1/wp-content/themes/contentberg/js/lazysizes.js?ver=1627899533' id='lazysizes-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.cloudbooklet.com/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' id='cookie-notice-front-js-extra'>
/* <![CDATA[ */
var cnArgs = {"ajaxUrl":"https:\/\/www.cloudbooklet.com\/wp-admin\/admin-ajax.php","nonce":"dc99f6e9a0","hideEffect":"fade","position":"bottom","onScroll":"0","onScrollOffset":"100","onClick":"0","cookieName":"cookie_notice_accepted","cookieTime":"2592000","cookieTimeRejected":"2592000","cookiePath":"\/","cookieDomain":"","redirection":"0","cache":"1","refuse":"0","revokeCookies":"0","revokeCookiesOpt":"automatic","secure":"1"};
/* ]]> */
</script>
<script type="rocketlazyloadscript" async data-rocket-type='text/javascript' src='https://www.cloudbooklet.com/wp-content/plugins/cookie-notice/includes/../js/front.min.js' id='cookie-notice-front-js'></script>
<link rel="alternate" type="application/json+oembed" href="https://www.cloudbooklet.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.cloudbooklet.com%2Fhow-to-install-or-upgrade-php-8-1-on-ubuntu-20-04%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.cloudbooklet.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.cloudbooklet.com%2Fhow-to-install-or-upgrade-php-8-1-on-ubuntu-20-04%2F&#038;format=xml" />
<link rel="preload" as="font" href="https://www.cloudbooklet.com/wp-content/themes/contentberg/css/fontawesome/fonts/fontawesome-webfont.woff2" crossorigin><script type="rocketlazyloadscript" data-minify="1" async custom-element="amp-ad" src="https://www.cloudbooklet.com/wp-content/cache/min/1/v0/amp-ad-0.1.js?ver=1627899533"></script><script type="rocketlazyloadscript">var Sphere_Plugin = {"ajaxurl":"https:\/\/www.cloudbooklet.com\/wp-admin\/admin-ajax.php"};</script><link rel="amphtml" href="https://www.cloudbooklet.com/how-to-install-or-upgrade-php-8-1-on-ubuntu-20-04/?amp=1"><link rel="icon" href="https://media.cloudbooklet.com/wp-content/uploads/2019/08/05094722/favicon-150x150.png" sizes="32x32" />
<link rel="icon" href="https://media.cloudbooklet.com/wp-content/uploads/2019/08/05094722/favicon.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://media.cloudbooklet.com/wp-content/uploads/2019/08/05094722/favicon.png" />
<meta name="msapplication-TileImage" content="https://media.cloudbooklet.com/wp-content/uploads/2019/08/05094722/favicon.png" />
<style type="text/css" id="wp-custom-css">
			.main-head.simple .title .logo-image {
    max-height: 40px;
}
.main-head.compact .title .logo-image {
	max-height: 45px;
}
.main-head.compact .inner.sticky-bar .logo-image {
  max-height: 35px;
}
.main-head.compact .posts-ticker a {
	color: #000000;
}
pre {
	color: #333;
}
.highlight a span {
	border: 2px solid #2d53fe;
    padding: 10px 15px;
	color: #2d53fe;
	transition: all .25s ease-in-out;
}
.highlight a span:hover {
	border: 2px solid #2d53fe;
    padding: 10px 15px;
	background-color: #2d53fe;
	color: #fff;
	opacity: 1;
	box-shadow: 0 15px 45px -5px rgba(7, 10, 25, 0.25);
	-webkit-filter: brightness(1.07);
    filter: brightness(1.07);
    transform: translate(0, -2px);
}
.catboxmodule {
    min-height: 100px;
}
.cb-cartbox {
    overflow: hidden;
    box-shadow: rgba(0,0,0,0.15) 0px 1px 2px;
    background: white;
    padding: 20px;
    position: relative;
    transition: all .35s cubic-bezier(0.39, 0.58, 0.57, 1);
    border-top: 1px solid #efefef;
}
.cb-flex-center-align {
    display: -webkit-flex;
    -webkit-align-items: center;
    align-items: center;
    display: -ms-flexbox;
    display: flex;
    -ms-flex-align: center;
    -webkit-box-align: center;
    flex-direction: row;
}
.cb-cbox-left {
    min-width: 50px;
}
.mr20 {
    margin-right: 20px !important;
}
.floatleft {
    float: left;
}
.mb10 {
    margin-bottom: 10px !important;
}
.lineheight20 {
    line-height: 20px;
}
.font80, .font80 h4 {
    font-size: 80%;
}
.lineheight15 {
    line-height: 15px;
}
.font85 {
    font-size: 85%;
}
.fontbold {
    font-weight: bold;
}
.cb-flex-right-align {
    margin-left: auto;
}
.cb-cbox-right img {
    max-height: 100px;
}
.card-box .vc_column_container {
	padding-left: 0 !important;
	padding-right: 0 !important;
}
.uppercase {
	text-transform: uppercase;
}
.card-img {
	display: block;
}
.url-link a {
	font-weight: 500;
	letter-spacing: 0.1em;
	color: #2d53fe;
	opacity: initial;
    text-decoration: none;
    transition: all .25s ease-in-out;
}
.url-link a:hover {
	opacity: 0.8;
}
code {
	color: #ff2b8c;
}
span.replace {
	color: #ff2b8c;
}
span.output:before {
	color: #c5c7c7;
	content: "Output";
	display: block;
	margin-bottom: 10px;
}
span.mute {
	color: #8a8b8b;
}
.nomargin {
    margin: 0 !important;
}
.different-os-list {
    padding: 10px 20px 0;
    border: 1px solid #c2c2c2;
    border-width: 0 1px 1px 1px;
    margin-bottom: 1.65em;
}
.different-os-list .code-block {
    margin: 0 !important;
}
.support {
    width: 100%;
    padding: 0;
}

.widget_custom_html {
    padding: 0 !important;
}
.support .post-link {
    color: #000000;
}
.post-content a, .textwidget a {
	color: #2d53fe !important;
}
.wp-block-table {
	border: 1px solid #b9b7b7 !important;
}
.affiliate-head {
	padding: 10px 30px !important;
}
.affiliate-body table {
	margin: 10px 0;
}
.affiliate-body table tbody tr td {
	padding: 5px 15px !important;
}
.affiliate-body table tbody tr td:nth-child(2){
	color: #ff3d00;
	font-size: 23px;
    letter-spacing: 5px;
}
.widget, article.the-post {
	background-color: #fff;
    border: 1px solid #e1e1e1;
    padding: 20px !important;
}
.post-share-float .services {
    background: transparent;
}
.main .sidebar {
    padding-left: 15px;
}
.sidebar .widget {
    margin-bottom: 20px;
}
.mobile-logo {
	display: none;
}
#cbl-donation-app {
    pointer-events: none;
    box-sizing: border-box;
    top: auto;
    bottom: 0;
    left: auto;
    right: 0;
    position: fixed;
    z-index: 9999999;
    display: block;
}
#cbl-donation-app .cbl-link {
    margin-right: 20px;
    border-radius: 50px;
    white-space: nowrap;
    padding: 15px 24px 5px 24px;
    background-color: #ff7e00;
    color: #000;
    outline: 0;
    text-decoration: none;
    pointer-events: all;
    cursor: pointer;
    box-shadow: 0 1px 6px 0 rgba(0,0,0,.06), 0 2px 32px 0 rgba(0,0,0,.16);
    margin-bottom: 24px;
    position: relative;
    text-decoration: none;
    display: block
}
#cbl-donation-app .cbl-image {
    margin: 0 12px 0 0;
    height: 30px;
    width: 22.5px;
}
#cbl-donation-app .cbl-small-text {
    font-size: 10px;
    text-transform: uppercase;
    position: absolute;
    z-index: 9;
    left: 63px;
    top: 11px;
    color: #fff;
}
#cbl-donation-app .cbl-text {
    font-size: 16px;
    text-transform: uppercase;
    font-weight: bold;
}
p.disclosure {
	text-transform: none;
	margin-top: 10px;
	color: #000;
	font-size: 14px;
	font-style: italic;
}		</style>
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript>
</head>
<body class="post-template-default single single-post postid-1904 single-format-standard right-sidebar  lazy-smart layout-magazine has-lb cookies-not-set wpb-js-composer js-comp-ver-6.7.0 vc_responsive">
<div class="main-wrap">
<header id="main-head" class="main-head head-nav-below has-search-overlay compact">
<div class="top-bar top-bar-b cf">
<div class="top-bar-content" data-sticky-bar="smart">
<div class="wrap cf">
<span class="mobile-nav"><i class="fa fa-bars"></i></span>
<div class="posts-ticker">
<span class="heading">Latest Post</span>
<ul>
<li><a href="https://www.cloudbooklet.com/how-to-install-or-upgrade-php-8-1-on-ubuntu-20-04/" title="How to Install or Upgrade PHP 8.1 on Ubuntu 20.04">How to Install or Upgrade PHP 8.1 on Ubuntu 20.04</a></li>
<li><a href="https://www.cloudbooklet.com/how-to-configure-google-cloud-cdn-for-external-websites/" title="How to configure Google Cloud CDN for External Websites">How to configure Google Cloud CDN for External Websites</a></li>
<li><a href="https://www.cloudbooklet.com/how-to-set-up-ssh-keys-on-debian/" title="How to Set Up SSH Keys on Debian">How to Set Up SSH Keys on Debian</a></li>
<li><a href="https://www.cloudbooklet.com/how-to-check-your-linux-os-version/" title="How to Check your Linux OS Version">How to Check your Linux OS Version</a></li>
<li><a href="https://www.cloudbooklet.com/how-to-rename-git-branch-local-and-remote/" title="How to Rename Git Branch Local and Remote">How to Rename Git Branch Local and Remote</a></li>
<li><a href="https://www.cloudbooklet.com/install-phpmyadmin-on-ubuntu-20-04-with-nginx/" title="Install phpMyAdmin on Ubuntu 20.04 with Nginx">Install phpMyAdmin on Ubuntu 20.04 with Nginx</a></li>
<li><a href="https://www.cloudbooklet.com/install-phpmyadmin-on-ubuntu-20-04-with-apache/" title="Install phpMyAdmin on Ubuntu 20.04 with Apache">Install phpMyAdmin on Ubuntu 20.04 with Apache</a></li>
<li><a href="https://www.cloudbooklet.com/file-permissions-in-linux-read-write-execute/" title="File Permissions in Linux &#8211; Read/Write/Execute">File Permissions in Linux &#8211; Read/Write/Execute</a></li>
</ul>
</div>
<div class="actions">
<div class="search-action cf">
<form method="get" class="search-form" action="https://www.cloudbooklet.com/">
<span class="screen-reader-text">Search for:</span>
<button type="submit" class="search-submit"><i class="fa fa-search"></i></button>
<input type="search" class="search-field" name="s" placeholder="Search" value="" required />
</form>
</div>
</div>
<ul class="social-icons cf">
<li><a href="https://www.facebook.com/cloudbooklet/" class="fa fa-facebook" target="_blank"><span class="visuallyhidden">Facebook</span></a></li>
<li><a href="https://www.youtube.com/channel/UCBWNRcvVx38glmATV5vBxJg" class="fa fa-youtube" target="_blank"><span class="visuallyhidden">YouTube</span></a></li>
<li><a href="https://www.linkedin.com/company/cloudbooklet/" class="fa fa-linkedin" target="_blank"><span class="visuallyhidden">LinkedIn</span></a></li>
</ul>
</div>
</div>
</div>
<div class="inner inner-head" data-sticky-bar="smart">
<div class="wrap cf">
<div class="title">
<a href="https://www.cloudbooklet.com/" title="Cloudbooklet" rel="home">
<img class="mobile-logo" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20326%2050'%3E%3C/svg%3E" width="326" height="50" alt="Cloudbooklet" data-lazy-src="https://media.cloudbooklet.com/wp-content/uploads/2019/08/05094936/cblt_logo1.png" /><noscript><img class="mobile-logo" src="https://media.cloudbooklet.com/wp-content/uploads/2019/08/05094936/cblt_logo1.png" width="326" height="50" 
			alt="Cloudbooklet" /></noscript>
<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="logo-image" alt="Cloudbooklet" data-lazy-src="https://media.cloudbooklet.com/wp-content/uploads/2019/08/05094936/cblt_logo1.png" /><noscript><img src="https://media.cloudbooklet.com/wp-content/uploads/2019/08/05094936/cblt_logo1.png" class="logo-image" alt="Cloudbooklet" /></noscript>
</a>
</div>
<div class="navigation-wrap inline">
<nav class="navigation inline light" data-sticky-bar="smart">
<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-1768" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-cat-2637 menu-item-1768"><a href="https://www.cloudbooklet.com/category/linux/">Linux</a></li>
<li id="menu-item-817" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-cat-3 menu-item-817"><a href="https://www.cloudbooklet.com/category/google-cloud/">Google Cloud</a></li>
<li id="menu-item-1377" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-544 menu-item-1377"><a href="https://www.cloudbooklet.com/category/aws/">AWS</a></li>
<li id="menu-item-836" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-836"><a href="https://www.cloudbooklet.com/about/">About</a></li>
<li id="menu-item-837" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-837"><a href="https://www.cloudbooklet.com/contact/">Contact</a></li>
<li class="nav-icons">
<a href="#" title="Search" class="search-link"><i class="fa fa-search"></i></a>
<div class="search-box-overlay">
<form method="get" class="search-form" action="https://www.cloudbooklet.com/">
<span class="screen-reader-text">Search for:</span>
<button type="submit" class="search-submit"><i class="fa fa-search"></i></button>
<input type="search" class="search-field" name="s" placeholder="Type and press enter" value="" required />
</form>
</div>
</li>
</ul></div> </nav>
</div>
</div>
</div>
</header> 
<script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script type="rocketlazyloadscript">
		 (adsbygoogle = window.adsbygoogle || []).push({
			  google_ad_client: "ca-pub-8369449682999832",
			  enable_page_level_ads: true
		 });
	</script>
<div class="main wrap">
<div id="post-1904" class="single-magazine post-1904 post type-post status-publish format-standard has-post-thumbnail category-google-cloud category-linux tag-apache tag-nginx tag-php">
<div class="post-top cf">
<span class="cat-label cf color"><a href="https://www.cloudbooklet.com/category/google-cloud/" rel="category tag">Google Cloud</a> <a href="https://www.cloudbooklet.com/category/linux/" rel="category tag">Linux</a></span>
<h1 class="post-title">How to Install or Upgrade PHP 8.1 on Ubuntu 20.04</h1>
<div class="post-meta post-meta-b the-post-meta">
<div class="below">
<a href="https://www.cloudbooklet.com/how-to-install-or-upgrade-php-8-1-on-ubuntu-20-04/" class="meta-item date-link"><time class="post-date" datetime="2021-12-02T11:05:47+00:00">December 2, 2021</time></a>
<span class="meta-sep"></span>
<span class="meta-item read-time">4 Mins Read</span>
</div>
<p class="disclosure">Since this post shares cloud strategies with awesome people like you, naturally this post may contain affiliate links for products I use and love. If you click on those links and make a purchase, I'll earn some coffee money which I promise to drink while creating more helpful content like this.</p>
</div>
</div>
<div class="ts-row cf">
<div class="col-8 main-content cf">
<article class="the-post">
<header class="post-header cf">
<div class="featured">
<a href="https://media.cloudbooklet.com/wp-content/uploads/2021/12/02110504/Install-PHP81-on-Ubuntu.png" class="image-link"><img width="770" height="433" src="https://media.cloudbooklet.com/wp-content/uploads/2021/12/02110504/Install-PHP81-on-Ubuntu-1024x576.png" class="attachment-large size-large lazyload wp-post-image" alt="Install PHP 8.1 on Ubuntu" title="How to Install or Upgrade PHP 8.1 on Ubuntu 20.04" data-srcset="https://media.cloudbooklet.com/wp-content/uploads/2021/12/02110504/Install-PHP81-on-Ubuntu-1024x576.png 1024w, https://media.cloudbooklet.com/wp-content/uploads/2021/12/02110504/Install-PHP81-on-Ubuntu-300x169.png 300w, https://media.cloudbooklet.com/wp-content/uploads/2021/12/02110504/Install-PHP81-on-Ubuntu-768x432.png 768w, https://media.cloudbooklet.com/wp-content/uploads/2021/12/02110504/Install-PHP81-on-Ubuntu.png 1280w" data-src="https://media.cloudbooklet.com/wp-content/uploads/2021/12/02110504/Install-PHP81-on-Ubuntu-1024x576.png" data-sizes="(max-width: 770px) 100vw, 770px" /> </a>
</div>
</header>
<div>
<div class="post-share-float share-float-a is-hidden cf">
<span class="share-text">Share</span>
<div class="services">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.cloudbooklet.com%2Fhow-to-install-or-upgrade-php-8-1-on-ubuntu-20-04%2F" class="cf service facebook" target="_blank" title="Share on Facebook">
<i class="fa fa-facebook"></i>
<span class="label">Share on Facebook</span>
</a>
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.cloudbooklet.com%2Fhow-to-install-or-upgrade-php-8-1-on-ubuntu-20-04%2F&text=How%20to%20Install%20or%20Upgrade%20PHP%208.1%20on%20Ubuntu%2020.04" class="cf service twitter" target="_blank" title="Share on Twitter">
<i class="fa fa-twitter"></i>
<span class="label">Share on Twitter</span>
</a>
<a href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.cloudbooklet.com%2Fhow-to-install-or-upgrade-php-8-1-on-ubuntu-20-04%2F&media=https%3A%2F%2Fmedia.cloudbooklet.com%2Fwp-content%2Fuploads%2F2021%2F12%2F02110504%2FInstall-PHP81-on-Ubuntu.png&description=How%20to%20Install%20or%20Upgrade%20PHP%208.1%20on%20Ubuntu%2020.04" class="cf service pinterest" target="_blank" title="Pinterest">
<i class="fa fa-pinterest-p"></i>
<span class="label">Pinterest</span>
</a>
<a href="/cdn-cgi/l/email-protection#340b4741565e515740097c5b43110604405b1106047d5a47405558581106045b4611060461445346555051110604647c641106040c1a051106045b5a1106046156415a404111060406041a040012565b504d095c404044471107751106721106724343431a57585b4150565b5b5f5851401a575b591106725c5b4319405b195d5a4740555858195b46194144534655505119445c44190c1905195b5a194156415a4041190604190400110672" class="cf service email" target="_blank" title="Email">
<i class="fa fa-envelope-o"></i>
<span class="label">Email</span>
</a>
</div>
</div>
</div>
<div class="post-content description cf entry-content has-share-float content-spacious">
<p>PHP 8.1 is the latest PHP version released on 2021. In this guide you are going to learn how to install the latest PHP version which is currently 8.1 on your Ubuntu 20.04 system or server and configure it with Apache and Nginx. You will also learn how to upgrade your PHP version to latest.</p>
<p>This tutorial guides you to configure PHP INI settings, FPM settings, Pools, etc which is more useful for your application to run smooth.</p><div class="wp-block-file"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-8369449682999832" data-ad-slot="9245800364"></ins>
<script type="rocketlazyloadscript">
			 (adsbygoogle = window.adsbygoogle || []).push({});
		</script></div>
<p>This installation is tested on Google Cloud Platform with a Compute Compute Engine VM Instance. This set up will work on all Linux servers.</p>
<div class="wp-block-group"><div class="wp-block-group__inner-container">
<p class="has-text-color has-text-align-center has-very-light-gray-color nomargin affiliate-head has-vivid-cyan-blue-background-color has-background">Best Hosting for your Business</p>
<figure class="wp-block-table is-style-stripes nomargin affiliate-body"><table class="has-fixed-layout"><thead><tr><th>Platform</th><th class="has-text-align-center" data-align="center">Reviews</th><th class="has-text-align-center" data-align="center">Pricing</th></tr></thead><tbody><tr><td><a href="https://www.cloudbooklet.com/recommended/cloudways" target="_blank" rel="noreferrer noopener">Cloudways</a></td><td class="has-text-align-center" data-align="center">★★★★★</td><td class="has-text-align-center" data-align="center">$10</td></tr><tr><td><a href="https://www.cloudbooklet.com/recommended/kinsta" target="_blank" rel="noreferrer noopener" aria-label=" (opens in a new tab)">Kinsta &#8211; Google Cloud</a></td><td class="has-text-align-center" data-align="center">★★★★★</td><td class="has-text-align-center" data-align="center">$30</td></tr></tbody></table></figure>
</div></div>
<h3>Prerequisites</h3>
<p>Basic knowledge of using SSH Terminal on Linux.</p>
<h3>Getting Started</h3>
<p>Make sure your Ubuntu server is having the latest packages by running the following command.</p>
<pre class="wp-block-preformatted">sudo apt update<br>sudo apt upgrade</pre>
<p>This will update the package index and update the installed packages to the latest version.</p><div class="wp-block-file"><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-8369449682999832" data-ad-slot="9245800364"></ins>
<script type="rocketlazyloadscript">
			 (adsbygoogle = window.adsbygoogle || []).push({});
		</script></div>
<h3>Add PPA for PHP 8.1</h3>
<p>Add the <code>ondrej/php</code> which has PHP 8.1 package and other required PHP extensions.</p>
<pre class="wp-block-preformatted">sudo apt install software-properties-common<br>sudo add-apt-repository ppa:ondrej/php<br>sudo apt update</pre>
<p>Once you have added the PPA you can install PHP 8.1.</p>
<h3>Install PHP 8.1 for Apache</h3>
<p>Execute the following command to install PHP 8.1</p>
<pre class="wp-block-preformatted">sudo apt install php8.1</pre>
<p>After the installation has completed, you can confirm the installation using the following command</p>
<pre class="wp-block-preformatted">php -v</pre>
<h3>Install PHP 8.1 FPM for Nginx</h3>
<p>For Nginx you need to install FPM. Execute the following command to install PHP 8.1 FPM</p><div class="wp-block-file"><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-8369449682999832" data-ad-slot="9245800364"></ins>
<script type="rocketlazyloadscript">
			 (adsbygoogle = window.adsbygoogle || []).push({});
		</script></div>
<pre class="wp-block-preformatted">sudo apt install php8.1-fpm</pre>
<p>After the installation has completed, confirm that PHP 8.1 FPM has installed correctly with this command</p>
<pre class="wp-block-preformatted">php-fpm8.1 -v</pre>
<h3>Install PHP 8.1 Extensions</h3>
<p>Installing PHP extensions are simple with the following syntax.</p>
<pre class="wp-block-preformatted">sudo apt install php8.1-<span class="replace">extension_name</span></pre>
<p>Now, install some commonly used <code>php-extensions</code> with the following command.</p>
<pre class="wp-block-preformatted">sudo apt install php8.1-common php8.1-mysql php8.1-xml php8.1-xmlrpc php8.1-curl php8.1-gd php8.1-imagick php8.1-cli php8.1-dev php8.1-imap php8.1-mbstring php8.1-opcache php8.1-soap php8.1-zip php8.1-redis php8.1-intl -y</pre>
<h3>Configure PHP 8.1</h3>
<p>Now we configure PHP for Web Applications by changing some values in <code>php.ini</code> file.</p>
<p>For PHP 8.1 with Apache the <code>php.ini</code> location will be in following directory.</p><div class="wp-block-file"><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-8369449682999832" data-ad-slot="9245800364"></ins>
<script type="rocketlazyloadscript">
			 (adsbygoogle = window.adsbygoogle || []).push({});
		</script></div>
<pre class="wp-block-preformatted">sudo nano /etc/php/8.1/apache2/php.ini</pre>
<p>For PHP 7.4 FPM with Nginx the <code>php.ini</code> location will be in following directory.</p>
<pre class="wp-block-preformatted">sudo nano /etc/php/8.1/fpm/php.ini</pre>
<p>Hit <code>F6</code> for search inside the editor and update the following values for better performance.</p>
<pre class="wp-block-preformatted">upload_max_filesize = 32M <br>post_max_size = 48M <br>memory_limit = 256M <br>max_execution_time = 600 <br>max_input_vars = 3000 <br>max_input_time = 1000</pre>
<p>Once you have modified your PHP settings you need to restart your Apache for the changes to take effect.</p>
<p>For users with Nginx to who use PHP-FPM, you need to restart PHP-FPM.</p>
<pre class="wp-block-preformatted">sudo php8.1-fpm restart</pre>
<h3>Configure PHP 8.1 FPM Pools</h3>
<p>PHP-FPM allows you to configure the <code>user</code> and <code>group</code> that the service will run under. You can modify these with these commands</p><div class="wp-block-file"><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-8369449682999832" data-ad-slot="9245800364"></ins>
<script type="rocketlazyloadscript">
			 (adsbygoogle = window.adsbygoogle || []).push({});
		</script></div>
<pre class="wp-block-preformatted">sudo nano /etc/php/8.1/fpm/pool.d/www.conf</pre>
<p>If you want to change the username name you can change the following lines by replacing the <strong>www-data</strong> with your <code>username</code>.</p>
<pre class="wp-block-preformatted">user = <span class="replace">username</span> 
group = <span class="replace">username</span> 
listen.owner = <span class="replace">username</span>
listen.group = <span class="replace">username</span></pre>
<p>
Hit <code>CTRL+X</code> and <code>Y</code> to save the configuration and check if the configuration is correct and restart PHP.
</p>
<h3>Restart PHP 8.1 FPM</h3>
<p>Once you have updated your PHP FPM settings you need to restart it to apply the changes.</p>
<pre class="wp-block-preformatted">sudo php-fpm8.1 -t 
sudo service php8.1-fpm restart</pre>
<p>Now you are having PHP 8.1 Installed and configured.</p>
<p class="has-text-align-center has-background">Become a <a rel="noreferrer noopener" aria-label=" (opens in a new tab)" href="https://www.cloudbooklet.com/recommended/linux-admin" target="_blank"><strong>Linux System Administrator</strong></a> and maintain virtual servers in a multi-user environment.</p><div class="wp-block-file"><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-8369449682999832" data-ad-slot="9245800364"></ins>
<script type="rocketlazyloadscript">
			 (adsbygoogle = window.adsbygoogle || []).push({});
		</script></div>
<h3>Upgrade to PHP 8.1 for Apache</h3>
<p>Once you have installed PHP 8.1 you need to upgrade to the latest installed version of PHP. </p>
<p>You need to tell Apache to use the PHP 8.1version we installed right now. Disable the old PHP module (<em>below I have mentioned php7.4, you need to use your current php version used by Apache</em>) and enable the new PHP module using the following command.</p>
<p>Replace the current enabled PHP version with your version.</p>
<pre class="wp-block-preformatted">sudo a2dismod php7.4
sudo a2enmod php8.1</pre>
<p>Restart Apache for the changes to take effect.</p>
<pre class="wp-block-preformatted">sudo service apache2 restart</pre>
<h3>Upgrade PHP 8.1 for Nginx</h3>
<p>For Nginx you need to update the PHP-FPM socket in your Nginx configration located inside the&nbsp;<code>sites-available</code>&nbsp;directory. This will be located inside the&nbsp;<code>location</code>&nbsp;block&nbsp;<code>location&nbsp;~&nbsp;\.php$</code></p><div class="wp-block-file"><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-8369449682999832" data-ad-slot="9245800364"></ins>
<script type="rocketlazyloadscript">
			 (adsbygoogle = window.adsbygoogle || []).push({});
		</script></div>
<p>Edit your configuration…</p>
<pre class="wp-block-preformatted">sudo nano /etc/nginx/sites-available/your.conf</pre>
<p>The line you need to modify will look like this…</p>
<pre class="wp-block-preformatted">fastcgi_pass&nbsp;unix:/run/php/php7.4-fpm.sock; </pre>
<p>You need to replace the old PHP version with the new version.</p>
<pre class="wp-block-preformatted">fastcgi_pass&nbsp;unix:/run/php/php8.1-fpm.sock; </pre>
<p>Test your configration.</p>
<pre class="wp-block-preformatted">sudo nginx -t</pre>
<p>Save the file and exit the editor and restart Nginx for the changes to take effect.</p><div class="wp-block-file"><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-8369449682999832" data-ad-slot="9245800364"></ins>
<script type="rocketlazyloadscript">
			 (adsbygoogle = window.adsbygoogle || []).push({});
		</script></div>
<pre class="wp-block-preformatted">sudo service nginx restart</pre>
<h3>Conclusion</h3>
<p>Now you have learned how to install PHP 8.1 on your Ubuntu server for Apache and Nginx and also how to upgrade to latest version.</p>
<p>Thanks for your time. If you face any problem or any feedback, please leave a comment below.</p>
</div>
<div class="the-post-foot cf">
<div class="tag-share cf">
<div class="post-tags"><a href="https://www.cloudbooklet.com/tag/apache/" rel="tag">Apache</a><a href="https://www.cloudbooklet.com/tag/nginx/" rel="tag">Nginx</a><a href="https://www.cloudbooklet.com/tag/php/" rel="tag">PHP</a></div>
<div class="post-share">
</div>
</div>
</div>
<div class="author-box author-box-b cf">
<div class="image"><img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2096%2096'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/13236c0d65ef329d0755b254f9aa23fa?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' data-lazy-src="https://secure.gravatar.com/avatar/13236c0d65ef329d0755b254f9aa23fa?s=96&#038;d=mm&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/13236c0d65ef329d0755b254f9aa23fa?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/13236c0d65ef329d0755b254f9aa23fa?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' /></noscript></div>
<div class="content">
<span class="author">
<a href="https://www.cloudbooklet.com/articles" title="Posts by Cloudbooklet" rel="author">Cloudbooklet</a> </span>
<p class="text author-bio">Cloudbooklet builds a large collection of Linux based guides and tutorials on Cloud platforms like Google Cloud, AWS, Azure, DigitalOcean and more</p>
<ul class="social-icons">
<li>
<a href="https://www.cloudbooklet.com" class="fa fa-home" title="Website">
<span class="visuallyhidden">Website</span></a>
</li>
<li>
<a href="https://www.facebook.com/cloudbooklet" class="fa fa-facebook" title="Facebook">
<span class="visuallyhidden">Facebook</span></a>
</li>
 </ul>
</div>
</div>
<section class="related-posts grid-3">
<h4 class="section-head"><span class="title">Related Posts</span></h4>
<div class="ts-row posts cf">
<article class="post col-4">
<a href="https://www.cloudbooklet.com/install-phpmyadmin-on-ubuntu-20-04-with-nginx/" title="Install phpMyAdmin on Ubuntu 20.04 with Nginx" class="image-link">
<img width="270" height="180" src="https://media.cloudbooklet.com/wp-content/uploads/2021/09/21041245/Install-phpMyAdmin-on-Ubuntu-with-Nginx-270x180.jpg" class="image lazyload wp-post-image" alt="Install phpMyAdmin on Ubuntu with Nginx" title="Install phpMyAdmin on Ubuntu 20.04 with Nginx" data-srcset="https://media.cloudbooklet.com/wp-content/uploads/2021/09/21041245/Install-phpMyAdmin-on-Ubuntu-with-Nginx-270x180.jpg 270w, https://media.cloudbooklet.com/wp-content/uploads/2021/09/21041245/Install-phpMyAdmin-on-Ubuntu-with-Nginx-770x515.jpg 770w, https://media.cloudbooklet.com/wp-content/uploads/2021/09/21041245/Install-phpMyAdmin-on-Ubuntu-with-Nginx-370x245.jpg 370w" data-src="https://media.cloudbooklet.com/wp-content/uploads/2021/09/21041245/Install-phpMyAdmin-on-Ubuntu-with-Nginx-270x180.jpg" data-sizes="(max-width: 270px) 100vw, 270px" /> </a>
<div class="content">
<h3 class="post-title"><a href="https://www.cloudbooklet.com/install-phpmyadmin-on-ubuntu-20-04-with-nginx/" class="post-link">Install phpMyAdmin on Ubuntu 20.04 with Nginx</a></h3>
<div class="post-meta">
<time class="post-date" datetime="2021-09-21T04:13:10+00:00">September 21, 2021</time>
</div>
</div>
</article >
<article class="post col-4">
<a href="https://www.cloudbooklet.com/install-phpmyadmin-on-ubuntu-20-04-with-apache/" title="Install phpMyAdmin on Ubuntu 20.04 with Apache" class="image-link">
<img width="270" height="180" src="https://media.cloudbooklet.com/wp-content/uploads/2021/09/17063939/Install-PhpMyAdmin-on-Ubuntu-270x180.png" class="image lazyload wp-post-image" alt="Install PhpMyAdmin on Ubuntu" title="Install phpMyAdmin on Ubuntu 20.04 with Apache" data-srcset="https://media.cloudbooklet.com/wp-content/uploads/2021/09/17063939/Install-PhpMyAdmin-on-Ubuntu-270x180.png 270w, https://media.cloudbooklet.com/wp-content/uploads/2021/09/17063939/Install-PhpMyAdmin-on-Ubuntu-770x515.png 770w, https://media.cloudbooklet.com/wp-content/uploads/2021/09/17063939/Install-PhpMyAdmin-on-Ubuntu-370x245.png 370w" data-src="https://media.cloudbooklet.com/wp-content/uploads/2021/09/17063939/Install-PhpMyAdmin-on-Ubuntu-270x180.png" data-sizes="(max-width: 270px) 100vw, 270px" /> </a>
<div class="content">
<h3 class="post-title"><a href="https://www.cloudbooklet.com/install-phpmyadmin-on-ubuntu-20-04-with-apache/" class="post-link">Install phpMyAdmin on Ubuntu 20.04 with Apache</a></h3>
<div class="post-meta">
<time class="post-date" datetime="2021-09-17T07:09:03+00:00">September 17, 2021</time>
</div>
</div>
</article >
<article class="post col-4">
<a href="https://www.cloudbooklet.com/how-to-redirect-using-htaccess-common-rules-for-301-302-https/" title="How to Redirect using Htaccess &#8211; Common Rules for 301, 302, HTTPS" class="image-link">
<img width="270" height="180" src="https://media.cloudbooklet.com/wp-content/uploads/2021/09/01052705/301-redirection-270x180.jpg" class="image lazyload wp-post-image" alt="How to Redirect using Htaccess" title="How to Redirect using Htaccess &#8211; Common Rules for 301, 302, HTTPS" data-srcset="https://media.cloudbooklet.com/wp-content/uploads/2021/09/01052705/301-redirection-270x180.jpg 270w, https://media.cloudbooklet.com/wp-content/uploads/2021/09/01052705/301-redirection-770x515.jpg 770w, https://media.cloudbooklet.com/wp-content/uploads/2021/09/01052705/301-redirection-370x245.jpg 370w" data-src="https://media.cloudbooklet.com/wp-content/uploads/2021/09/01052705/301-redirection-270x180.jpg" data-sizes="(max-width: 270px) 100vw, 270px" /> </a>
<div class="content">
<h3 class="post-title"><a href="https://www.cloudbooklet.com/how-to-redirect-using-htaccess-common-rules-for-301-302-https/" class="post-link">How to Redirect using Htaccess &#8211; Common Rules for 301, 302, HTTPS</a></h3>
<div class="post-meta">
<time class="post-date" datetime="2021-09-01T05:29:26+00:00">September 1, 2021</time>
</div>
</div>
</article >
</div>
</section>
<div class="comments">
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title"><span class="section-head"><span class="title">Write A Comment</span></span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/how-to-install-or-upgrade-php-8-1-on-ubuntu-20-04/#respond" style="display:none;">Cancel Reply</a></small></h3><form action="https://www.cloudbooklet.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
<div class="inline-field">
<input name="author" id="author" type="text" value="" aria-required="true" placeholder="Name" required />
</div>
<div class="inline-field">
<input name="email" id="email" type="text" value="" aria-required="true" placeholder="Email" required />
</div>
<div class="reply-field cf">
<textarea name="comment" id="comment" cols="45" rows="7" placeholder="Enter your comment here.." aria-required="true" required></textarea>
</div>
<p class="comment-form-cookies-consent">
<input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" />
<label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.
</label>
</p>
<div class="gglcptch gglcptch_invisible"><div class="google-captcha-notice">This site is protected by reCAPTCHA and the Google <a href="https://policies.google.com/privacy" target="_blank">Privacy Policy</a> and <a href="https://policies.google.com/terms" target="_blank">Terms of Service</a> apply.</div><div id="gglcptch_recaptcha_1448067314" class="gglcptch_recaptcha"></div>
<noscript>
					<div style="width: 302px;">
						<div style="width: 302px; height: 422px; position: relative;">
							<div style="width: 302px; height: 422px; position: absolute;">
								<iframe src="https://www.google.com/recaptcha/api/fallback?k=6LcRq3oUAAAAAMgQwu9M_Xl_YfqYhB1JdQFlM0J9" frameborder="0" scrolling="no" style="width: 302px; height:422px; border-style: none;"></iframe>
							</div>
						</div>
						<div style="border-style: none; bottom: 12px; left: 25px; margin: 0px; padding: 0px; right: 25px; background: #f9f9f9; border: 1px solid #c1c1c1; border-radius: 3px; height: 60px; width: 300px;">
							<textarea id="g-recaptcha-response" name="g-recaptcha-response" class="g-recaptcha-response" style="width: 250px !important; height: 40px !important; border: 1px solid #c1c1c1 !important; margin: 10px 25px !important; padding: 0px !important; resize: none !important;"></textarea>
						</div>
					</div>
				</noscript></div><p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='1904' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="6c83815122" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js" name="ak_js" value="92" /><script type="rocketlazyloadscript">document.getElementById( "ak_js" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form> </div>
</div>
</div>
</article> 
</div>
<aside class="col-4 sidebar" data-sticky="1">
<div class="inner theiaStickySidebar">
<ul>
<li id="custom_html-10" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-8369449682999832" data-ad-slot="6157125687" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
<amp-ad width="100vw" height="320" type="adsense" data-ad-client="ca-pub-8369449682999832" data-ad-slot="6157125687" data-auto-format="rspv" data-full-width="">
<div overflow=""></div>
</amp-ad></div></li>
<li id="bunyad-posts-widget-5" class="widget widget-posts">
<h5 class="widget-title"><span>Suggested Articles</span></h5>
<ul class="posts cf large">
<li class="post cf">
<a href="https://www.cloudbooklet.com/how-to-install-or-upgrade-php-8-1-on-ubuntu-20-04/" class="image-link">
<img width="150" height="150" src="https://media.cloudbooklet.com/wp-content/uploads/2021/12/02110504/Install-PHP81-on-Ubuntu-150x150.png" class="attachment-contentberg-thumb-alt size-contentberg-thumb-alt lazyload wp-post-image" alt="Install PHP 8.1 on Ubuntu" title="How to Install or Upgrade PHP 8.1 on Ubuntu 20.04" data-srcset="https://media.cloudbooklet.com/wp-content/uploads/2021/12/02110504/Install-PHP81-on-Ubuntu-150x150.png 150w, https://media.cloudbooklet.com/wp-content/uploads/2021/12/02110504/Install-PHP81-on-Ubuntu-370x370.png 370w" data-src="https://media.cloudbooklet.com/wp-content/uploads/2021/12/02110504/Install-PHP81-on-Ubuntu-150x150.png" data-sizes="(max-width: 150px) 100vw, 150px" /> </a>
<div class="content">
<a href="https://www.cloudbooklet.com/how-to-install-or-upgrade-php-8-1-on-ubuntu-20-04/" class="post-title" title="How to Install or Upgrade PHP 8.1 on Ubuntu 20.04">How to Install or Upgrade PHP 8.1 on Ubuntu 20.04</a>
<div class="post-meta post-meta-a">
</div>
<div class="excerpt"><p>PHP 8.1 is the latest PHP version released on 2021. In this guide you are&hellip;</p>
</div>
</div>
</li>
<li class="post cf">
<a href="https://www.cloudbooklet.com/how-to-configure-google-cloud-cdn-for-external-websites/" class="image-link">
<img width="150" height="150" src="https://media.cloudbooklet.com/wp-content/uploads/2021/11/23085450/Setup-Google-Cloud-CDN-for-External-website-150x150.jpg" class="attachment-contentberg-thumb-alt size-contentberg-thumb-alt lazyload wp-post-image" alt="Setup Google Cloud CDN for External website" title="How to configure Google Cloud CDN for External Websites" data-srcset="https://media.cloudbooklet.com/wp-content/uploads/2021/11/23085450/Setup-Google-Cloud-CDN-for-External-website-150x150.jpg 150w, https://media.cloudbooklet.com/wp-content/uploads/2021/11/23085450/Setup-Google-Cloud-CDN-for-External-website-370x370.jpg 370w" data-src="https://media.cloudbooklet.com/wp-content/uploads/2021/11/23085450/Setup-Google-Cloud-CDN-for-External-website-150x150.jpg" data-sizes="(max-width: 150px) 100vw, 150px" /> </a>
<div class="content">
<a href="https://www.cloudbooklet.com/how-to-configure-google-cloud-cdn-for-external-websites/" class="post-title" title="How to configure Google Cloud CDN for External Websites">How to configure Google Cloud CDN for External Websites</a>
<div class="post-meta post-meta-a">
</div>
<div class="excerpt"><p>In this guide you are going to learn how to configure Google Cloud CDN for&hellip;</p>
</div>
</div>
</li>
<li class="post cf">
<a href="https://www.cloudbooklet.com/how-to-set-up-ssh-keys-on-debian/" class="image-link">
<img width="150" height="150" src="https://media.cloudbooklet.com/wp-content/uploads/2021/10/08042509/How-to-Set-Up-SSH-Keys-on-Debian-150x150.jpg" class="attachment-contentberg-thumb-alt size-contentberg-thumb-alt lazyload wp-post-image" alt="How to Set Up SSH Keys on Debian" title="How to Set Up SSH Keys on Debian" data-srcset="https://media.cloudbooklet.com/wp-content/uploads/2021/10/08042509/How-to-Set-Up-SSH-Keys-on-Debian-150x150.jpg 150w, https://media.cloudbooklet.com/wp-content/uploads/2021/10/08042509/How-to-Set-Up-SSH-Keys-on-Debian-370x370.jpg 370w" data-src="https://media.cloudbooklet.com/wp-content/uploads/2021/10/08042509/How-to-Set-Up-SSH-Keys-on-Debian-150x150.jpg" data-sizes="(max-width: 150px) 100vw, 150px" /> </a>
<div class="content">
<a href="https://www.cloudbooklet.com/how-to-set-up-ssh-keys-on-debian/" class="post-title" title="How to Set Up SSH Keys on Debian">How to Set Up SSH Keys on Debian</a>
<div class="post-meta post-meta-a">
</div>
<div class="excerpt"><p>There are 2 methods to access the SSH, one is by password based and other&hellip;</p>
</div>
</div>
</li>
<li class="post cf">
<a href="https://www.cloudbooklet.com/how-to-check-your-linux-os-version/" class="image-link">
<img width="150" height="150" src="https://media.cloudbooklet.com/wp-content/uploads/2021/10/04104858/Check-Linux-OS-version-150x150.jpg" class="attachment-contentberg-thumb-alt size-contentberg-thumb-alt lazyload wp-post-image" alt="Check Linux OS version" title="How to Check your Linux OS Version" data-srcset="https://media.cloudbooklet.com/wp-content/uploads/2021/10/04104858/Check-Linux-OS-version-150x150.jpg 150w, https://media.cloudbooklet.com/wp-content/uploads/2021/10/04104858/Check-Linux-OS-version-370x370.jpg 370w" data-src="https://media.cloudbooklet.com/wp-content/uploads/2021/10/04104858/Check-Linux-OS-version-150x150.jpg" data-sizes="(max-width: 150px) 100vw, 150px" /> </a>
<div class="content">
<a href="https://www.cloudbooklet.com/how-to-check-your-linux-os-version/" class="post-title" title="How to Check your Linux OS Version">How to Check your Linux OS Version</a>
<div class="post-meta post-meta-a">
</div>
<div class="excerpt"><p>Linux is a most popular open source OS used widely on many systems, servers and&hellip;</p>
</div>
</div>
</li>
</ul>
</li>
<li id="custom_html-9" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-8369449682999832" data-ad-slot="6157125687" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
<amp-ad width="100vw" height="320" type="adsense" data-ad-client="ca-pub-8369449682999832" data-ad-slot="6157125687" data-auto-format="rspv" data-full-width="">
<div overflow=""></div>
</amp-ad></div></li>
</ul>
</div>
</aside>
</div> 
</div>
</div> 
<footer class="main-footer dark stylish">
<div class="social-strip">
<ul class="social-icons">
<li>
<a href="https://www.facebook.com/cloudbooklet/" class="social-link" target="_blank"><i class="fa fa-facebook"></i>
<span class="label">Facebook</span></a>
</li>
<li>
<a href="#" class="social-link" target="_blank"><i class="fa fa-twitter"></i>
<span class="label">Twitter</span></a>
</li>
<li>
<a href="https://www.youtube.com/channel/UCBWNRcvVx38glmATV5vBxJg" class="social-link" target="_blank"><i class="fa fa-youtube"></i>
<span class="label">YouTube</span></a>
</li>
<li>
<a href="https://www.linkedin.com/company/cloudbooklet/" class="social-link" target="_blank"><i class="fa fa-linkedin"></i>
<span class="label">LinkedIn</span></a>
</li>
</ul>
</div>
<div class="bg-wrap">
<section class="upper-footer">
<div class="wrap">
<ul class="widgets ts-row cf">
<li id="bunyad-widget-subscribe-2" class="widget column col-4 widget-subscribe">
<h5 class="widget-title">Subscribe for Newsletter</h5>
<form method="post" action="https://gmail.us20.list-manage.com/subscribe/post?u=1707eac2ab0e01f1166b2790f&#038;id=cb3191389b" class="form" target="_blank">
<div class="fields">
<p class="message">
Enter your email address below to subscribe to my newsletter </p>
<p>
<input type="email" name="EMAIL" placeholder="Your email address.." required>
</p>
<p>
<input type="submit" value="Join Now">
</p>
</div>
</form>
</li>
</ul>
</div>
</section>
<section class="lower-footer cf">
<div class="wrap">
<div class="footer-logo">
<img class="logo lazyload" src="data:image/svg+xml,%3Csvg%20viewBox%3D%270%200%201%201%27%20xmlns%3D%27http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%27%3E%3C%2Fsvg%3E" alt="Cloudbooklet" data-src="https://media.cloudbooklet.com/wp-content/uploads/2020/08/11094912/logo-white.png" />
</div>
<div class="bottom cf">
<p class="copyright">© 2020 <a href="https://www.cloudbooklet.com">CloudBooklet</a>. All rights reserved. </p>
<div class="to-top">
<a href="#" class="back-to-top"><i class="fa fa-angle-up"></i> Top</a>
</div>
</div>
</div>
</section>
</div>
</footer>
</div> 
<div class="mobile-menu-container off-canvas" id="mobile-menu">
<a href="#" class="close"><i class="fa fa-times"></i></a>
<div class="logo">
<img class="mobile-logo lazyload" src="data:image/svg+xml,%3Csvg%20viewBox%3D%270%200%20326%2050%27%20xmlns%3D%27http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%27%3E%3C%2Fsvg%3E" width="326" height="50" alt="Cloudbooklet" data-src="https://media.cloudbooklet.com/wp-content/uploads/2019/08/05094936/cblt_logo1.png" />
</div>
<ul id="menu-main-menu-1" class="mobile-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1768"><a href="https://www.cloudbooklet.com/category/linux/">Linux</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-817"><a href="https://www.cloudbooklet.com/category/google-cloud/">Google Cloud</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1377"><a href="https://www.cloudbooklet.com/category/aws/">AWS</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-836"><a href="https://www.cloudbooklet.com/about/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-837"><a href="https://www.cloudbooklet.com/contact/">Contact</a></li>
</ul>
</div>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/(.+\/)?feed\/?.+\/?|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/control-panel\/|\/wp-admin\/|\/logout\/|\/control-panel\/","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/www.cloudbooklet.com","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://www.cloudbooklet.com/wp-content/cache/min/1/wp-content/themes/contentberg/js/magnific-popup.js?ver=1627899533' id='magnific-popup-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://www.cloudbooklet.com/wp-content/cache/min/1/wp-content/themes/contentberg/js/jquery.fitvids.js?ver=1627899533' id='jquery-fitvids-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.cloudbooklet.com/wp-includes/js/imagesloaded.min.js' id='imagesloaded-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://www.cloudbooklet.com/wp-content/cache/min/1/wp-content/themes/contentberg/js/object-fit-images.js?ver=1627899533' id='object-fit-images-js' defer></script>
<script type='text/javascript' id='contentberg-theme-js-extra'>
/* <![CDATA[ */
var Bunyad = {"custom_ajax_url":"\/how-to-install-or-upgrade-php-8-1-on-ubuntu-20-04\/"};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://www.cloudbooklet.com/wp-content/cache/min/1/wp-content/themes/contentberg/js/theme.js?ver=1627899533' id='contentberg-theme-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://www.cloudbooklet.com/wp-content/cache/min/1/wp-content/themes/contentberg/js/theia-sticky-sidebar.js?ver=1627899533' id='theia-sticky-sidebar-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://www.cloudbooklet.com/wp-content/cache/min/1/wp-content/themes/contentberg/js/jquery.slick.js?ver=1627899533' id='jquery-slick-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://www.cloudbooklet.com/wp-content/cache/min/1/wp-content/themes/contentberg/js/jarallax.js?ver=1627899533' id='jarallax-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.cloudbooklet.com/wp-includes/js/comment-reply.min.js' id='comment-reply-js' defer></script>
<script type='text/javascript' src='https://www.cloudbooklet.com/wp-includes/js/wp-embed.min.js' id='wp-embed-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' data-cfasync="false" async="async" defer="defer" src='https://www.google.com/recaptcha/api.js?render=explicit' id='gglcptch_api-js'></script>
<script type='text/javascript' id='gglcptch_script-js-extra'>
/* <![CDATA[ */
var gglcptch = {"options":{"version":"invisible","sitekey":"6LcRq3oUAAAAAMgQwu9M_Xl_YfqYhB1JdQFlM0J9","error":"<strong>Warning<\/strong>:&nbsp;More than one reCAPTCHA has been found in the current form. Please remove all unnecessary reCAPTCHA fields to make it work properly.","disable":0},"vars":{"visibility":false}};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://www.cloudbooklet.com/wp-content/cache/min/1/wp-content/plugins/google-captcha/js/script.js?ver=1627899557' id='gglcptch_script-js' defer></script>

<div id="cookie-notice" role="dialog" class="cookie-notice-hidden cookie-revoke-hidden cn-position-bottom" aria-label="Cookie Notice" style="background-color: rgba(50,50,58,1);"><div class="cookie-notice-container" style="color: #fff;"><span id="cn-notice-text" class="cn-text-container">We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.</span><span id="cn-notice-buttons" class="cn-buttons-container"><a href="#" id="cn-accept-cookie" data-cookie-set="accept" class="cn-set-cookie cn-button bootstrap" aria-label="Ok">Ok</a></span><a href="javascript:void(0);" id="cn-close-notice" data-cookie-set="accept" class="cn-close-icon" aria-label="Ok"></a></div>
</div>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(var i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.cloudbooklet.com/wp-content/plugins/wp-rocket/assets/js/lazyload/17.5/lazyload.min.js"></script><script>function lazyLoadThumb(e){var t='<img data-lazy-src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"><noscript><img src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"></noscript>',a='<button class="play" aria-label="play Youtube video"></button>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="ID?autoplay=1";t+=0===this.parentNode.dataset.query.length?'':'&'+this.parentNode.dataset.query;e.setAttribute("src",t.replace("ID",this.parentNode.dataset.src)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),e.setAttribute("allow", "accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"),this.parentNode.parentNode.replaceChild(e,this.parentNode)}document.addEventListener("DOMContentLoaded",function(){var e,t,p,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.setAttribute("data-src", a[t].dataset.src),e.innerHTML=lazyLoadThumb(a[t].dataset.id),a[t].appendChild(e),p=e.querySelector('.play'),p.onclick=lazyLoadYoutubeIframe});</script>
</body>
</html>
