
<!DOCTYPE html>
<html lang="en-US">

<head>

	<meta charset="UTF-8" />
	<meta http-equiv="x-ua-compatible" content="ie=edge" />
	<meta name="viewport" content="width=device-width, initial-scale=1" />
	<link rel="profile" href="http://gmpg.org/xfn/11" />
	
	<title>How to Setup Jenkins with SSL with Apache Reverse Proxy on Ubuntu 18.04</title>

<!-- This site is optimized with the Yoast SEO plugin v11.5 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="How to Setup Jenkins with SSL with Apache Reverse Proxy on Ubuntu 18.04 . Learn how to configure Jenkins with Apache on subdirectory &amp; subdomain"/>
<link rel="canonical" href="https://www.cloudbooklet.com/how-to-setup-jenkins-with-ssl-with-apache-reverse-proxy-on-ubuntu/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to Setup Jenkins with SSL with Apache Reverse Proxy on Ubuntu 18.04" />
<meta property="og:description" content="How to Setup Jenkins with SSL with Apache Reverse Proxy on Ubuntu 18.04 . Learn how to configure Jenkins with Apache on subdirectory &amp; subdomain" />
<meta property="og:url" content="https://www.cloudbooklet.com/how-to-setup-jenkins-with-ssl-with-apache-reverse-proxy-on-ubuntu/" />
<meta property="og:site_name" content="Cloudbooklet" />
<meta property="article:tag" content="Compute Engine" />
<meta property="article:tag" content="Google Cloud Platform" />
<meta property="article:tag" content="Jenkins" />
<meta property="article:section" content="Google Cloud" />
<meta property="article:published_time" content="2019-07-02T03:44:11+00:00" />
<meta property="article:modified_time" content="2019-07-02T03:44:17+00:00" />
<meta property="og:updated_time" content="2019-07-02T03:44:17+00:00" />
<meta property="og:image" content="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/02034334/How-to-Setup-Jenkins-with-SSL-with-Apache-Reverse-Proxy-on-Ubuntu-18.04.jpg" />
<meta property="og:image:secure_url" content="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/02034334/How-to-Setup-Jenkins-with-SSL-with-Apache-Reverse-Proxy-on-Ubuntu-18.04.jpg" />
<meta property="og:image:width" content="1920" />
<meta property="og:image:height" content="1080" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="How to Setup Jenkins with SSL with Apache Reverse Proxy on Ubuntu 18.04 . Learn how to configure Jenkins with Apache on subdirectory &amp; subdomain" />
<meta name="twitter:title" content="How to Setup Jenkins with SSL with Apache Reverse Proxy on Ubuntu 18.04" />
<meta name="twitter:image" content="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/02034334/How-to-Setup-Jenkins-with-SSL-with-Apache-Reverse-Proxy-on-Ubuntu-18.04.jpg" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.cloudbooklet.com/#organization","name":"","url":"https://www.cloudbooklet.com/","sameAs":[]},{"@type":"WebSite","@id":"https://www.cloudbooklet.com/#website","url":"https://www.cloudbooklet.com/","name":"Cloudbooklet","publisher":{"@id":"https://www.cloudbooklet.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.cloudbooklet.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.cloudbooklet.com/how-to-setup-jenkins-with-ssl-with-apache-reverse-proxy-on-ubuntu/#primaryimage","url":"https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/02034334/How-to-Setup-Jenkins-with-SSL-with-Apache-Reverse-Proxy-on-Ubuntu-18.04.jpg","width":1920,"height":1080,"caption":"How to Setup Jenkins with SSL with Apache Reverse Proxy on Ubuntu 18.04"},{"@type":"WebPage","@id":"https://www.cloudbooklet.com/how-to-setup-jenkins-with-ssl-with-apache-reverse-proxy-on-ubuntu/#webpage","url":"https://www.cloudbooklet.com/how-to-setup-jenkins-with-ssl-with-apache-reverse-proxy-on-ubuntu/","inLanguage":"en-US","name":"How to Setup Jenkins with SSL with Apache Reverse Proxy on Ubuntu 18.04","isPartOf":{"@id":"https://www.cloudbooklet.com/#website"},"primaryImageOfPage":{"@id":"https://www.cloudbooklet.com/how-to-setup-jenkins-with-ssl-with-apache-reverse-proxy-on-ubuntu/#primaryimage"},"datePublished":"2019-07-02T03:44:11+00:00","dateModified":"2019-07-02T03:44:17+00:00","description":"How to Setup Jenkins with SSL with Apache Reverse Proxy on Ubuntu 18.04 . Learn how to configure Jenkins with Apache on subdirectory & subdomain"},{"@type":"Article","@id":"https://www.cloudbooklet.com/how-to-setup-jenkins-with-ssl-with-apache-reverse-proxy-on-ubuntu/#article","isPartOf":{"@id":"https://www.cloudbooklet.com/how-to-setup-jenkins-with-ssl-with-apache-reverse-proxy-on-ubuntu/#webpage"},"author":{"@id":"https://www.cloudbooklet.com/articles#author"},"headline":"How to Setup Jenkins with SSL with Apache Reverse Proxy on Ubuntu 18.04","datePublished":"2019-07-02T03:44:11+00:00","dateModified":"2019-07-02T03:44:17+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.cloudbooklet.com/how-to-setup-jenkins-with-ssl-with-apache-reverse-proxy-on-ubuntu/#webpage"},"publisher":{"@id":"https://www.cloudbooklet.com/#organization"},"image":{"@id":"https://www.cloudbooklet.com/how-to-setup-jenkins-with-ssl-with-apache-reverse-proxy-on-ubuntu/#primaryimage"},"keywords":"Compute Engine,Google Cloud Platform,Jenkins","articleSection":"Compute Engine,Google Cloud"},{"@type":["Person"],"@id":"https://www.cloudbooklet.com/articles#author","name":"Cloudbooklet","image":{"@type":"ImageObject","@id":"https://www.cloudbooklet.com/#authorlogo","url":"https://secure.gravatar.com/avatar/ebf9d20bc990a9eaa2c392f3194974c2?s=96&d=mm&r=g","caption":"Cloudbooklet"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="Cloudbooklet &raquo; Feed" href="https://www.cloudbooklet.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Cloudbooklet &raquo; Comments Feed" href="https://www.cloudbooklet.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Cloudbooklet &raquo; How to Setup Jenkins with SSL with Apache Reverse Proxy on Ubuntu 18.04 Comments Feed" href="https://www.cloudbooklet.com/how-to-setup-jenkins-with-ssl-with-apache-reverse-proxy-on-ubuntu/feed/" />
<link rel='stylesheet' id='contentberg-core-css'  href='https://www.cloudbooklet.com/wp-content/themes/contentberg/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.cloudbooklet.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='contentberg-fonts-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A400%2C500%2C700%7CPT+Serif%3A400%2C400i%2C600%7CIBM+Plex+Serif%3A500' type='text/css' media='all' />
<link rel='stylesheet' id='contentberg-lightbox-css'  href='https://www.cloudbooklet.com/wp-content/themes/contentberg/css/lightbox.css' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.cloudbooklet.com/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='contentberg-child-css'  href='https://www.cloudbooklet.com/wp-content/themes/contentberg-child/style.css' type='text/css' media='all' />
<style id='contentberg-child-inline-css' type='text/css'>
.post-content, .entry-content { color: #000000; }

.entry-content { color: #000000; }

.navigation .menu > li:not(:hover) > a, .navigation.dark .menu > li:not(:hover) > a { color: #000000; }

.navigation .menu > li li a { color: #000000 !important; }



</style>
<link rel='stylesheet' id='cp-module-main-style-css'  href='https://www.cloudbooklet.com/wp-content/plugins/convertplug/modules/assets/css/cp-module-main.css' type='text/css' media='all' />
<link rel='stylesheet' id='smile-modal-style-css'  href='https://www.cloudbooklet.com/wp-content/plugins/convertplug/modules/modal/assets/css/modal.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='smile-slide-in-style-css'  href='https://www.cloudbooklet.com/wp-content/plugins/convertplug/modules/slide_in/assets/css/slide_in.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='smile-info-bar-style-css'  href='https://www.cloudbooklet.com/wp-content/plugins/convertplug/modules/info_bar/assets/css/info_bar.min.css' type='text/css' media='all' />
<script type='text/javascript' src='https://www.cloudbooklet.com/wp-content/themes/contentberg/js/lazysizes.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var Sphere_Plugin = {"ajaxurl":"https:\/\/www.cloudbooklet.com\/wp-admin\/admin-ajax.php"};
var slide_in = {"demo_dir":"https:\/\/www.cloudbooklet.com\/wp-content\/plugins\/convertplug\/modules\/slide_in\/assets\/demos"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.cloudbooklet.com/wp-includes/js/jquery/jquery.js'></script>
<link rel="alternate" type="application/json+oembed" href="https://www.cloudbooklet.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.cloudbooklet.com%2Fhow-to-setup-jenkins-with-ssl-with-apache-reverse-proxy-on-ubuntu%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.cloudbooklet.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.cloudbooklet.com%2Fhow-to-setup-jenkins-with-ssl-with-apache-reverse-proxy-on-ubuntu%2F&#038;format=xml" />
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://www.cloudbooklet.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><link rel="amphtml" href="https://www.cloudbooklet.com/how-to-setup-jenkins-with-ssl-with-apache-reverse-proxy-on-ubuntu/?amp"><link rel="icon" href="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2018/11/03061204/cropped-fc7de09d-favicon-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2018/11/03061204/cropped-fc7de09d-favicon-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2018/11/03061204/cropped-fc7de09d-favicon-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2018/11/03061204/cropped-fc7de09d-favicon-1-270x270.png" />

<!-- BEGIN ExactMetrics v5.3.8 Universal Analytics - https://exactmetrics.com/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-102617346-3', 'auto', {'useAmpClientId': true});
  ga('send', 'pageview');
</script>
<!-- END ExactMetrics Universal Analytics -->
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>
</head>

<body class="post-template-default single single-post postid-920 single-format-standard  lazy-smart no-sidebar has-lb wpb-js-composer js-comp-ver-5.7 vc_responsive">


<div class="main-wrap">

	
		
		
<header id="main-head" class="main-head head-nav-below has-search-modal simple simple-boxed">

	<div class="inner inner-head" data-sticky-bar="smart">
	
		<div class="wrap cf wrap-head">
		
			<div class="left-contain">
				<span class="mobile-nav"><i class="fa fa-bars"></i></span>	
			
					<div class="title">
		
		<a href="https://www.cloudbooklet.com/" title="Cloudbooklet" rel="home">
		
					
								
		<img class="mobile-logo" src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2018/11/03053211/6130a887-logo.png" width="326" height="50" 
			alt="Cloudbooklet" />

					
			<img src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2018/11/03053211/6130a887-logo.png" class="logo-image" alt="Cloudbooklet" />

				
		</a>
	
	</div>			
			</div>
				
				
			<div class="navigation-wrap inline">
								
				<nav class="navigation inline simple light" data-sticky-bar="smart">
					<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-833" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-833"><a href="https://www.cloudbooklet.com/articles/"><span>Articles</span></a></li>
<li id="menu-item-817" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-cat-3 menu-item-817"><a href="https://www.cloudbooklet.com/category/google-cloud/"><span>Google Cloud</span></a>
<ul class="sub-menu">
	<li id="menu-item-821" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-cat-11 menu-item-821"><a href="https://www.cloudbooklet.com/category/google-cloud/compute-engine/"><span>Compute Engine</span></a></li>
	<li id="menu-item-819" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-9 menu-item-819"><a href="https://www.cloudbooklet.com/category/google-cloud/cloud-sql/"><span>Cloud SQL</span></a></li>
	<li id="menu-item-818" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-7 menu-item-818"><a href="https://www.cloudbooklet.com/category/google-cloud/bigquery/"><span>BigQuery</span></a></li>
	<li id="menu-item-822" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-8 menu-item-822"><a href="https://www.cloudbooklet.com/category/google-cloud/network-services/cloud-dns/"><span>Cloud DNS</span></a></li>
	<li id="menu-item-820" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-10 menu-item-820"><a href="https://www.cloudbooklet.com/category/google-cloud/google-cloud-storage/"><span>Cloud Storage</span></a></li>
</ul>
</li>
<li id="menu-item-836" class="menu-item menu-item-type-post_type menu-item-object-page current-post-parent menu-item-836"><a href="https://www.cloudbooklet.com/about/"><span>About</span></a></li>
<li id="menu-item-837" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-837"><a href="https://www.cloudbooklet.com/contact/"><span>Contact</span></a></li>
<li id="menu-item-834" class="highlight menu-item menu-item-type-custom menu-item-object-custom menu-item-834"><a href="https://www.cloudbooklet.com/tools/"><span>Tools</span></a></li>
</ul></div>				</nav>
				
							</div>
			
			<div class="actions">
			
				
	
		<ul class="social-icons cf">
		
					
			<li><a href="https://www.facebook.com/cloudbooklet/" class="fa fa-facebook" target="_blank"><span class="visuallyhidden">Facebook</span></a></li>
									
					
			<li><a href="https://www.youtube.com/channel/UCBWNRcvVx38glmATV5vBxJg" class="fa fa-youtube" target="_blank"><span class="visuallyhidden">YouTube</span></a></li>
									
					
			<li><a href="https://www.linkedin.com/company/cloudbooklet/" class="fa fa-linkedin" target="_blank"><span class="visuallyhidden">LinkedIn</span></a></li>
									
					
		</ul>
	
								
								
					<a href="#" title="Search" class="search-link"><i class="fa fa-search"></i></a>
									
				
							
			</div>

		</div>
	</div>

</header> <!-- .main-head -->	
		
	
<div class="main wrap">

	<div class="ts-row cf">
		<div class="col-8 main-content cf">
		
			
				
<article id="post-920" class="the-post-modern the-post post-920 post type-post status-publish format-standard has-post-thumbnail category-compute-engine category-google-cloud tag-compute-engine tag-google-cloud tag-jenkins">
	
	<header class="post-header the-post-header cf">
			
			<div class="post-meta post-meta-b the-post-meta">
		
				
			<span class="post-cat">	
				<span class="text-in">In</span> 
									
		<a href="https://www.cloudbooklet.com/category/google-cloud/compute-engine/" class="category">Compute Engine</a>

					</span>
			
			
		
					
			
			<h1 class="post-title-alt">
				How to Setup Jenkins with SSL with Apache Reverse Proxy on Ubuntu 18.04			</h1>
			
				
		<div class="below">
		
						
			
							<span class="meta-item read-time">4 Mins Read</span>
					
		</div>
		
	</div>
			
	<div class="featured">
	
				
					
			<a href="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/02034334/How-to-Setup-Jenkins-with-SSL-with-Apache-Reverse-Proxy-on-Ubuntu-18.04.jpg" class="image-link"><img width="1024" height="576" src="data:image/svg+xml,%3Csvg%20viewBox%3D%270%200%201024%20576%27%20xmlns%3D%27http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%27%3E%3C%2Fsvg%3E" class="attachment-large size-large lazyload wp-post-image" alt="How to Setup Jenkins with SSL with Apache Reverse Proxy on Ubuntu 18.04" title="How to Setup Jenkins with SSL with Apache Reverse Proxy on Ubuntu 18.04" data-srcset="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/02034334/How-to-Setup-Jenkins-with-SSL-with-Apache-Reverse-Proxy-on-Ubuntu-18.04-1024x576.jpg 1024w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/02034334/How-to-Setup-Jenkins-with-SSL-with-Apache-Reverse-Proxy-on-Ubuntu-18.04-300x169.jpg 300w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/02034334/How-to-Setup-Jenkins-with-SSL-with-Apache-Reverse-Proxy-on-Ubuntu-18.04-768x432.jpg 768w" data-src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/02034334/How-to-Setup-Jenkins-with-SSL-with-Apache-Reverse-Proxy-on-Ubuntu-18.04-1024x576.jpg" data-sizes="(max-width: 1024px) 100vw, 1024px" />			</a>
			
				
	</div>
		
	</header><!-- .post-header -->

				
					<div>
				
				
	
	<div class="post-share-float share-float-a is-hidden cf">
	
					<span class="share-text">Share</span>
		
		<div class="services">
		
				
			<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.cloudbooklet.com%2Fhow-to-setup-jenkins-with-ssl-with-apache-reverse-proxy-on-ubuntu%2F" class="cf service facebook" target="_blank" title="Share on Facebook">
				<i class="fa fa-facebook"></i>
				<span class="label">Share on Facebook</span>
			</a>
				
				
			<a href="http://twitter.com/home?status=https%3A%2F%2Fwww.cloudbooklet.com%2Fhow-to-setup-jenkins-with-ssl-with-apache-reverse-proxy-on-ubuntu%2F" class="cf service twitter" target="_blank" title="Share on Twitter">
				<i class="fa fa-twitter"></i>
				<span class="label">Share on Twitter</span>
			</a>
				
				
			<a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.cloudbooklet.com%2Fhow-to-setup-jenkins-with-ssl-with-apache-reverse-proxy-on-ubuntu%2F&#038;media=https%3A%2F%2Fstorage.googleapis.com%2Fcloudbooklet-new%2Fwp-content%2Fuploads%2F2019%2F07%2F02034334%2FHow-to-Setup-Jenkins-with-SSL-with-Apache-Reverse-Proxy-on-Ubuntu-18.04.jpg&#038;description=How+to+Setup+Jenkins+with+SSL+with+Apache+Reverse+Proxy+on+Ubuntu+18.04" class="cf service pinterest" target="_blank" title="Pinterest">
				<i class="fa fa-pinterest-p"></i>
				<span class="label">Pinterest</span>
			</a>
				
				
			<a href="mailto:?subject=How%2Bto%2BSetup%2BJenkins%2Bwith%2BSSL%2Bwith%2BApache%2BReverse%2BProxy%2Bon%2BUbuntu%2B18.04&#038;body=https%3A%2F%2Fwww.cloudbooklet.com%2Fhow-to-setup-jenkins-with-ssl-with-apache-reverse-proxy-on-ubuntu%2F" class="cf service email" target="_blank" title="Email">
				<i class="fa fa-envelope-o"></i>
				<span class="label">Email</span>
			</a>
				
				
		</div>
		
	</div>
	

			</div>
		
		<div class="post-content description cf entry-content has-share-float content-spacious-full">


			
<p>How to Setup Jenkins with SSL with Apache Reverse Proxy on Ubuntu 18.04. By default Jenkins listens on port 8080 with it&#8217;s in-built web server. But it is necessary to secure Jenkins with SSL for protecting the sensitive data.</p>



<p>In this tutorial you are going to learn how to setup Apache as a reverse proxy to Jenkins on Ubuntu 18.04 on Google Cloud.</p>



<p>This setup is tested on Google Cloud and it will pretty run the same on any Linux distributions.</p>



<div class="wp-block-columns has-3-columns">
<div class="wp-block-column">
<div class="wp-block-image"><figure class="aligncenter"><a href="https://www.patreon.com/cloudbooklet" target="_blank" rel="noreferrer noopener"><img src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112004/patreon-promo.jpg" alt="" class="wp-image-887" srcset="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112004/patreon-promo.jpg 440w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112004/patreon-promo-300x109.jpg 300w" sizes="(max-width: 440px) 100vw, 440px" /></a></figure></div>
</div>



<div class="wp-block-column">
<div class="wp-block-image"><figure class="aligncenter"><a href="https://www.fiverr.com/wordpress_vip" target="_blank" rel="noreferrer noopener"><img src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112018/Fiverr-promo.jpg" alt="" class="wp-image-888" srcset="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112018/Fiverr-promo.jpg 440w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112018/Fiverr-promo-300x109.jpg 300w" sizes="(max-width: 440px) 100vw, 440px" /></a></figure></div>
</div>



<div class="wp-block-column">
<div class="wp-block-image"><figure class="aligncenter"><img src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112315/Udemy-Promo.jpg" alt="" class="wp-image-889" srcset="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112315/Udemy-Promo.jpg 440w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112315/Udemy-Promo-300x109.jpg 300w" sizes="(max-width: 440px) 100vw, 440px" /></figure></div>
</div>
</div>



<h3>Prerequisites</h3>



<ul><li>A running Compute Engine, see the <a rel="noreferrer noopener" href="https://www.cloudbooklet.com/setting-up-google-cloud-compute-engine-instance/" target="_blank">Setting up Compute Engine Instance&nbsp;with&nbsp;Ubuntu&nbsp;18.04</a></li><li><a rel="noreferrer noopener" href="https://www.cloudbooklet.com/ubuntu-server-setup-on-google-cloud-platform/" target="_blank">Initial Ubuntu Server Set up</a>.</li><li>Jenkins installed with the steps listed on <a rel="noreferrer noopener" aria-label="How to install Jenkins on Ubuntu 18.04 (opens in a new tab)" href="https://www.cloudbooklet.com/how-to-install-jenkins-on-ubuntu-18-04/" target="_blank">How to install Jenkins on Ubuntu 18.04</a></li><li>DNS setup with the steps listed in <a href="https://www.cloudbooklet.com/how-to-install-jenkins-on-ubuntu-18-04/">Setting up Google Cloud DNS for your domain</a> </li></ul>



<h3>Install Apache</h3>



<p>Install Apache with the following command.</p>



<pre class="wp-block-preformatted">sudo apt install apache2</pre>



<p>This command will install Apache on your VM instance.</p>



<h3>Setup Firewall</h3>



<p>Once Apache is installed you can configure firewall, Apache registers itself with <code>ufw</code>. So, you can allow the necessary ports and enable ufw.</p>



<pre class="wp-block-preformatted">sudo ufw allow OpenSSH
sudo ufw allow 'Apache Full'</pre>



<p>Make sure you have added rules for SSH port 22, if you haven&#8217;t done this you cannot access the SSH. Once you have verified you can enable UFW.</p>



<pre class="wp-block-preformatted">sudo ufw enable</pre>



<h3>Configure Apache for Jenkins</h3>



<p>Enable Apache modules.</p>



<pre class="wp-block-preformatted">a2enmod proxy
a2enmod proxy_http
a2enmod headers</pre>



<p>Now it&#8217;s time to configure Apache as a reverse proxy for Jenkins.</p>



<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-8850056739273957" data-ad-slot="7377544641"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>



<p>Remove the default Apache configuration.</p>



<pre class="wp-block-preformatted">sudo a2dissite 000-default</pre>



<p>Create a new configuration for Jenkins.</p>



<pre class="wp-block-preformatted">sudo nano /etc/apache2/sites-available/jenkins.conf</pre>



<h4>Configuration for Jenkins on Subdomain</h4>



<pre class="wp-block-preformatted">&lt;VirtualHost *:80>
    ServerAdmin admin@jenkins.yourdomainname.com
    ServerName jenkins.yourdomainname.com
    ServerAlias jenkins.yourdomainnamecom

    &lt;Proxy http://127.0.0.1:8080/>
      Order deny,allow
      Allow from all
    &lt;/Proxy>

    ProxyPass         /  http://127.0.0.1:8080/ nocanon
    ProxyPassReverse  /  http://127.0.0.1:8080/
    ProxyPassReverse  /  http://jenkins.yourdomainname.com/

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined
&lt;/VirtualHost></pre>



<p>Paste this new configuration setting and hit Ctrl+X followed by Y to save the file.</p>



<h4>Configuration for Jenkins on Sub-directory</h4>



<p>Paste this new configuration setting and hit Ctrl+X followed by Y to save the file.</p>



<pre class="wp-block-preformatted">&lt;Virtualhost *:80>
    ServerName        yourdomainname.com

    ProxyRequests     Off
    ProxyPreserveHost On
    AllowEncodedSlashes NoDecode

    &lt;Proxy http://127.0.0.1:8080/jenkins*>
        Order deny,allow
        Allow from all
    &lt;/Proxy>

    ProxyPass         /jenkins  http://127.0.0.1:8080/jenkins nocanon
    ProxyPassReverse  /jenkins  http://127.0.0.1:8080/jenkins
    ProxyPassReverse  /jenkins  http://35.244.93.246/jenkins
&lt;/Virtualhost>
</pre>



<p>Hit <code>Ctrl + X</code> followed by <code>Y</code> and <code>Enter</code> to save and exit the file.</p>



<p>Enable the configuration.</p>



<pre class="wp-block-preformatted">sudo a2ensite jenkins.conf</pre>



<h3>Configure Jenkins for Apache</h3>



<p>In order to Jenkins work with Apache you need to make Jenkins to listen on <code>localhost</code></p>



<pre class="wp-block-preformatted">sudo nano /etc/default/jenkins</pre>



<p>Find the <code>JENKINS_ARGS</code> line and add <code>--httpListenAddress=127.0.0.1</code> to the existing arguments.</p>



<p>So, the line will look similar to the one below.</p>



<pre class="wp-block-preformatted">JENKINS_ARGS="--webroot=/var/cache/$NAME/war --httpPort=$HTTP_PORT <span class="replace">--httpListenAddress=127.0.0.1</span>"</pre>



<p>For <strong>sub-directory</strong> configuration you need to add additional argument with the directory name with <code>--prefix</code></p>



<pre class="wp-block-preformatted">JENKINS_ARGS="--webroot=/var/cache/$NAME/war --httpPort=$HTTP_PORT <span class="replace">--httpListenAddress=127.0.0.1</span> --prefix=/jenkins"</pre>



<p>Save and exit the file. Finally restart Jenkins.</p>



<pre class="wp-block-preformatted">sudo systemctl restart jenkins</pre>



<p>Check the configuration and restart Apache.</p>



<pre class="wp-block-preformatted">sudo apachectl configtest
sudo service apache2 restart</pre>



<p>Now Apache is setup as a reverse proxy for Jenkins.</p>



<h3>Install Free Let&#8217;s Encrypt SSL Certificate</h3>



<pre class="wp-block-preformatted">sudo add-apt-repository ppa:certbot/certbot
sudo apt update
sudo apt install python-certbot-apache</pre>



<pre class="wp-block-preformatted">sudo certbot --apache -m your-email -d yourdomainname.com -d www.yourdomainname.com</pre>



<p>That&#8217;s all now you can visit your domain name in your web browser. You can see your Jenkins login page with HTTPS.</p>



<h3>Conclusion</h3>



<p>In this tutorial you have installed Apache, configured UFW, setup new reverse proxy configuration for Jenkins and installed SSL and configured Jenkins for Apache.</p>
<span class="cp-load-after-post"></span>				
		</div><!-- .post-content -->
		
		<div class="the-post-foot cf">
		
						
			<div class="tag-share cf">
				
									<div class="post-tags"><a href="https://www.cloudbooklet.com/tag/compute-engine/" rel="tag">Compute Engine</a><a href="https://www.cloudbooklet.com/tag/google-cloud/" rel="tag">Google Cloud Platform</a><a href="https://www.cloudbooklet.com/tag/jenkins/" rel="tag">Jenkins</a></div>				
											<div class="post-share">
					
						
		</div>									
			</div>

			
		</div>
		
				
		
				
		

<section class="related-posts grid-3">

	<h4 class="section-head"><span class="title">Related Posts</span></h4> 
	
	<div class="ts-row posts cf">
	
			<article class="post col-4">
					
			<a href="https://www.cloudbooklet.com/install-metabase-on-google-cloud-with-docker-app-engine/" title="Install Metabase on Google Cloud with Docker &#8211; App Engine" class="image-link">
				<img width="770" height="515" src="data:image/svg+xml,%3Csvg%20viewBox%3D%270%200%20770%20515%27%20xmlns%3D%27http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%27%3E%3C%2Fsvg%3E" class="image lazyload wp-post-image" alt="Install Metabase on Google Cloud with Docker App Engine" title="Install Metabase on Google Cloud with Docker &#8211; App Engine" data-srcset="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/19101633/Install-Metabase-on-Google-Cloud-with-Docker-App-Engine1-770x515.jpg 770w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/19101633/Install-Metabase-on-Google-Cloud-with-Docker-App-Engine1-270x180.jpg 270w" data-src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/19101633/Install-Metabase-on-Google-Cloud-with-Docker-App-Engine1-770x515.jpg" data-sizes="(max-width: 770px) 100vw, 770px" />			</a>
			
			<div class="content">
				
				<h3 class="post-title"><a href="https://www.cloudbooklet.com/install-metabase-on-google-cloud-with-docker-app-engine/" class="post-link">Install Metabase on Google Cloud with Docker &#8211; App Engine</a></h3>

				<div class="post-meta">
					<time class="post-date" datetime="2019-06-19T10:17:45+00:00">June 19, 2019</time>
				</div>
			
			</div>

		</article >
		
			<article class="post col-4">
					
			<a href="https://www.cloudbooklet.com/how-to-setup-jenkins-with-ssl-with-nginx-reverse-proxy-on-ubuntu-18-04/" title="How to Setup Jenkins with SSL with Nginx Reverse Proxy on Ubuntu 18.04" class="image-link">
				<img width="770" height="515" src="data:image/svg+xml,%3Csvg%20viewBox%3D%270%200%20770%20515%27%20xmlns%3D%27http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%27%3E%3C%2Fsvg%3E" class="image lazyload wp-post-image" alt="How to Setup Jenkins with SSL with Nginx Reverse Proxy on Ubuntu 18.04" title="How to Setup Jenkins with SSL with Nginx Reverse Proxy on Ubuntu 18.04" data-srcset="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/10142253/How-to-Setup-Jenkins-with-SSL-with-Nginx-Reverse-Proxy-on-Ubuntu-18.04-770x515.jpg 770w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/10142253/How-to-Setup-Jenkins-with-SSL-with-Nginx-Reverse-Proxy-on-Ubuntu-18.04-270x180.jpg 270w" data-src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/10142253/How-to-Setup-Jenkins-with-SSL-with-Nginx-Reverse-Proxy-on-Ubuntu-18.04-770x515.jpg" data-sizes="(max-width: 770px) 100vw, 770px" />			</a>
			
			<div class="content">
				
				<h3 class="post-title"><a href="https://www.cloudbooklet.com/how-to-setup-jenkins-with-ssl-with-nginx-reverse-proxy-on-ubuntu-18-04/" class="post-link">How to Setup Jenkins with SSL with Nginx Reverse Proxy on Ubuntu 18.04</a></h3>

				<div class="post-meta">
					<time class="post-date" datetime="2019-06-10T14:23:20+00:00">June 10, 2019</time>
				</div>
			
			</div>

		</article >
		
			<article class="post col-4">
					
			<a href="https://www.cloudbooklet.com/how-to-install-jenkins-on-ubuntu-18-04/" title="How to Install Jenkins on Ubuntu 18.04" class="image-link">
				<img width="770" height="515" src="data:image/svg+xml,%3Csvg%20viewBox%3D%270%200%20770%20515%27%20xmlns%3D%27http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%27%3E%3C%2Fsvg%3E" class="image lazyload wp-post-image" alt="How to Install Jenkins on Ubuntu 18.04" title="How to Install Jenkins on Ubuntu 18.04" data-srcset="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06131142/How-to-Install-Jenkins-on-Ubuntu-18.04-770x515.jpg 770w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06131142/How-to-Install-Jenkins-on-Ubuntu-18.04-270x180.jpg 270w" data-src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06131142/How-to-Install-Jenkins-on-Ubuntu-18.04-770x515.jpg" data-sizes="(max-width: 770px) 100vw, 770px" />			</a>
			
			<div class="content">
				
				<h3 class="post-title"><a href="https://www.cloudbooklet.com/how-to-install-jenkins-on-ubuntu-18-04/" class="post-link">How to Install Jenkins on Ubuntu 18.04</a></h3>

				<div class="post-meta">
					<time class="post-date" datetime="2019-06-06T13:08:19+00:00">June 6, 2019</time>
				</div>
			
			</div>

		</article >
		
		
	</div>
	
</section>

		
		<div class="comments">
	<div id="comments" class="comments-area">

		
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><span class="section-head"><span class="title">Write A Comment</span></span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/how-to-setup-jenkins-with-ssl-with-apache-reverse-proxy-on-ubuntu/#respond" style="display:none;">Cancel Reply</a></small></h3>			<form action="https://www.cloudbooklet.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				
			<div class="inline-field"> 
				<input name="author" id="author" type="text" value="" aria-required="true" placeholder="Name" required />
			</div>

			<div class="inline-field"> 
				<input name="email" id="email" type="text" value="" aria-required="true" placeholder="Email" required />
			</div>
		

			<div class="reply-field cf">
				<textarea name="comment" id="comment" cols="45" rows="7" placeholder="Enter your comment here.." aria-required="true" required></textarea>
			</div>
	
			<p class="comment-form-cookies-consent">
				<input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" />
				<label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.
				</label>
			</p>
<div class="gglcptch gglcptch_invisible"><div>This site is protected by reCAPTCHA and the Google <a href="https://policies.google.com/privacy">Privacy Policy</a> and <a href="https://policies.google.com/terms">Terms of Service</a> apply.</div><div id="gglcptch_recaptcha_1131389945" class="gglcptch_recaptcha"></div>
				<noscript>
					<div style="width: 302px;">
						<div style="width: 302px; height: 422px; position: relative;">
							<div style="width: 302px; height: 422px; position: absolute;">
								<iframe src="https://www.google.com/recaptcha/api/fallback?k=6LcRq3oUAAAAAMgQwu9M_Xl_YfqYhB1JdQFlM0J9" frameborder="0" scrolling="no" style="width: 302px; height:422px; border-style: none;"></iframe>
							</div>
						</div>
						<div style="border-style: none; bottom: 12px; left: 25px; margin: 0px; padding: 0px; right: 25px; background: #f9f9f9; border: 1px solid #c1c1c1; border-radius: 3px; height: 60px; width: 300px;">
							<textarea id="g-recaptcha-response" name="g-recaptcha-response" class="g-recaptcha-response" style="width: 250px !important; height: 40px !important; border: 1px solid #c1c1c1 !important; margin: 10px 25px !important; padding: 0px !important; resize: none !important;"></textarea>
						</div>
					</div>
				</noscript></div><p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='920' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="74359092fc" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="101"/></p>			</form>
			</div><!-- #respond -->
	
	</div><!-- #comments -->
</div>		
</article> <!-- .the-post -->	
			
		</div>
		
				
	</div> <!-- .ts-row -->
</div> <!-- .main -->


	
	
	<footer class="main-footer bold bold-light">
		
				
		<section class="upper-footer">
		
			<div class="wrap">
				
				<ul class="widgets ts-row cf">
					<li id="custom_html-4" class="widget_text widget column col-4 widget_custom_html"><div class="textwidget custom-html-widget"><article class="support col-4">			
	<a href="https://www.patreon.com/cloudbooklet" title="Support us on Patreon" target="_blank" class="image-link" rel="noopener noreferrer">
		<img class=" lazyload" width="770" height="515" src="data:image/svg+xml,%3Csvg%20viewBox%3D%270%200%20770%20515%27%20xmlns%3D%27http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%27%3E%3C%2Fsvg%3E" alt="Support us on Patreon" data-src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/04083045/patreon.jpg" />			
	</a>
</article></div></li><li id="custom_html-5" class="widget_text widget column col-4 widget_custom_html"><div class="textwidget custom-html-widget"><article class="support col-4">			
	<a href="https://www.fiverr.com/wordpress_vip/be-google-cloud-professional" title="Hire me on Fiverr" target="_blank" class="image-link" rel="noopener noreferrer">
		<img class=" lazyload" width="770" height="515" src="data:image/svg+xml,%3Csvg%20viewBox%3D%270%200%20770%20515%27%20xmlns%3D%27http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%27%3E%3C%2Fsvg%3E" alt="Hire me on Fiverr" data-src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/04085915/Fiverr1.jpg" />			
	</a>
</article></div></li><li id="custom_html-6" class="widget_text widget column col-4 widget_custom_html"><div class="textwidget custom-html-widget"><article class="support col-4">			
	<a href="javascript:void(0)" title="Learn Google Cloud" target="_blank" class="image-link" rel="noopener noreferrer">
		<img class=" lazyload" width="770" height="515" src="data:image/svg+xml,%3Csvg%20viewBox%3D%270%200%20770%20515%27%20xmlns%3D%27http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%27%3E%3C%2Fsvg%3E" alt="Learn Google Cloud" data-src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/04090736/udemy.jpg" />			
	</a>
</article></div></li>				</ul>

			</div>
		</section>
		
				
		
				
		

				
		<section class="lower-footer cf">
			<div class="wrap">
			
				<ul class="social-icons">
					
												<li>
								<a href="https://www.facebook.com/cloudbooklet/" class="social-link" target="_blank" title="Facebook">
									<i class="fa fa-facebook"></i>
									<span class="label">Facebook</span>
								</a>
							</li>
						
												<li>
								<a href="#" class="social-link" target="_blank" title="Twitter">
									<i class="fa fa-twitter"></i>
									<span class="label">Twitter</span>
								</a>
							</li>
						
												<li>
								<a href="https://www.youtube.com/channel/UCBWNRcvVx38glmATV5vBxJg" class="social-link" target="_blank" title="YouTube">
									<i class="fa fa-youtube"></i>
									<span class="label">YouTube</span>
								</a>
							</li>
						
												<li>
								<a href="https://www.linkedin.com/company/cloudbooklet/" class="social-link" target="_blank" title="LinkedIn">
									<i class="fa fa-linkedin"></i>
									<span class="label">LinkedIn</span>
								</a>
							</li>
						
							
				</ul>

			
										
					<div class="links">					
						<div class="menu-footer-links-container"><ul id="menu-footer-links" class="menu"><li id="menu-item-838" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-838"><a href="https://www.cloudbooklet.com/about/">About</a></li>
<li id="menu-item-839" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-839"><a href="https://www.cloudbooklet.com/contact/">Contact</a></li>
<li id="menu-item-840" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-840"><a href="https://www.cloudbooklet.com/disclaimer/">Disclaimer</a></li>
<li id="menu-item-841" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-841"><a href="https://www.cloudbooklet.com/privacy-policy-2/">Privacy Policy</a></li>
</ul></div>					</div>
				
				
				
				<p class="copyright">© 2018 <a href="https://www.cloudbooklet.com">CloudBooklet</a>. All rights reserved.				</p>


				
									<div class="to-top">
						<a href="#" class="back-to-top"><i class="fa fa-angle-up"></i> Top</a>
					</div>
									
			</div>
		</section>
		
				
		
	</footer>	
	
</div> <!-- .main-wrap -->



<div class="mobile-menu-container off-canvas" id="mobile-menu">

	<a href="#" class="close"><i class="fa fa-times"></i></a>
	
	<div class="logo">
							
		<img class="mobile-logo lazyload" src="data:image/svg+xml,%3Csvg%20viewBox%3D%270%200%20326%2050%27%20xmlns%3D%27http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%27%3E%3C%2Fsvg%3E" width="326" height="50" alt="Cloudbooklet" data-src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2018/11/03053211/6130a887-logo.png" />

			</div>
	
	
		<ul id="menu-main-menu-1" class="mobile-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-833"><a href="https://www.cloudbooklet.com/articles/">Articles</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-817"><a href="https://www.cloudbooklet.com/category/google-cloud/">Google Cloud</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-821"><a href="https://www.cloudbooklet.com/category/google-cloud/compute-engine/">Compute Engine</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-819"><a href="https://www.cloudbooklet.com/category/google-cloud/cloud-sql/">Cloud SQL</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-818"><a href="https://www.cloudbooklet.com/category/google-cloud/bigquery/">BigQuery</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-822"><a href="https://www.cloudbooklet.com/category/google-cloud/network-services/cloud-dns/">Cloud DNS</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-820"><a href="https://www.cloudbooklet.com/category/google-cloud/google-cloud-storage/">Cloud Storage</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page current-post-parent menu-item-836"><a href="https://www.cloudbooklet.com/about/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-837"><a href="https://www.cloudbooklet.com/contact/">Contact</a></li>
<li class="highlight menu-item menu-item-type-custom menu-item-object-custom menu-item-834"><a href="https://www.cloudbooklet.com/tools/">Tools</a></li>
</ul>
	</div>



	<div class="search-modal-wrap">

		<div class="search-modal-box" role="dialog" aria-modal="true">
			

	<form method="get" class="search-form" action="https://www.cloudbooklet.com/">
		<input type="search" class="search-field" name="s" placeholder="Search..." value="" required />

		<button type="submit" class="search-submit visuallyhidden">Submit</button>

		<p class="message">
			Type above and press <em>Enter</em> to search. Press <em>Esc</em> to cancel.		</p>
				
	</form>

		</div>
	</div>


				<script type="text/javascript" id="modal">
					document.addEventListener("DOMContentLoaded", function(){
						startclock();
					});
					function stopclock (){
						if(timerRunning) clearTimeout(timerID);
						timerRunning = false;
						//document.cookie="time=0";
					}
					function showtime () {
						var now = new Date();
						var my = now.getTime() ;
						now = new Date(my-diffms) ;
						//document.cookie="time="+now.toLocaleString();
						timerID = setTimeout('showtime()',10000);
						timerRunning = true;
					}
					function startclock () {
						stopclock();
						showtime();
					}
					var timerID = null;
					var timerRunning = false;
					var x = new Date() ;
					var now = x.getTime() ;
					var gmt = 1562039640 * 1000 ;
					var diffms = (now - gmt) ;
				</script>
				<style type="text/css"></style>				<div data-class-id="content-5d1ad558b0150" data-referrer-domain="" data-referrer-check="hide" data-after-content-value="50" data-overlay-class = "overlay-zoomin" data-onload-delay = "1"data-onscroll-value = ""data-exit-intent = "disabled"data-add-to-cart = "0" data-closed-cookie-time="1" data-conversion-cookie-time="12"  data-modal-id="cp_id_9178d"  data-modal-style="cp_id_9178d"  data-option="smile_modal_styles"    data-custom-class = "cp-cp_id_9178d cp-modal-global"data-load-on-refresh = "enabled"data-dev-mode = "disabled"data-custom-selector = "" class="overlay-show cp-onload cp-global-load  cp-cp_id_9178d cp-modal-global" data-module-type="modal" ></div>
		
		<div data-form-layout="cp-form-layout-1" class="cp-module cp-modal-popup-container  cp_id_9178d cp-optin-to-win-container " data-style-id ="cp_id_9178d"  data-module-name ="modal" data-close-gravity = "1">
			<div class="content-5d1ad558b0150 cp-overlay   smile-3DRotateBottom  global_modal_container   "  data-scheduled="false"  data-closed-cookie-time="1" data-conversion-cookie-time="12"  data-modal-id="cp_id_9178d"  data-modal-style="cp_id_9178d"  data-option="smile_modal_styles" data-placeholder-font="inherit"data-custom-class = "cp-cp_id_9178d cp-modal-global"data-class = "content-5d1ad558b0150"data-load-on-refresh = "enabled"data-load-on-count = "" data-hide-img-on-mobile=768 data-affiliate_setting ="0"  data-overlay-animation = "smile-3DRotateBottom"       data-tz-offset = "0"data-image-position = "0"data-placeholder-color = ""data-timezonename = "wordpress"data-timezone = "0"  style=" " >
				<div class="cp-overlay-background" style=" background-color:rgba(0, 0, 0, 0.71);"></div>	<div class="cp-modal cp-modal-custom-size" style="width:100%;height:auto;max-width:650px;">
					<div class="cp-animate-container"  data-overlay-animation = "smile-3DRotateBottom"  data-exit-animation="smile-bounceOutDown">
						<div class="cp-modal-content "   style = "box-shadow:0px 0px 5px 0px rgba(86,86,131,0.6);-webkit-box-shadow:0px 0px 5px 0px rgba(86,86,131,0.6);-moz-box-shadow:0px 0px 5px 0px rgba(86,86,131,0.6);border-radius: 0px;-moz-border-radius: 0px;-webkit-border-radius: 0px;border-style: solid;border-color: #ffffff;border-width:  px;border-width:2px;" >	
								
							<div class="cp-modal-body cp-optin-to-win " style = "background-image:url(//storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/03112419/minor.jpg);background-repeat: no-repeat;background-position: right;background-size: cover;;" >
																<div class="cp-modal-body-overlay cp_cs_overlay" style="background-color:rgba(0,0,0,0.01);;;"></div>
																		<!-- BEFORE CONTENTS -->
		<div class="cp-row cp-columns-equalized">
			<div class="col-lg-7 col-md-7 col-sm-7 col-xs-12 cp-column-equalized-center cp-text-container cp-right-contain" >
				<div class="cp-title-container 
									" >
					<h2 class="cp-title cp_responsive" style="color: #000;"><span class="cp_responsive cp_font" data-font-size="18px" style="font-size:18px;"><span data-font-size="20px"><span style="color:#F0FFF0;"><span data-font-size="23px"><span data-font-size="22px"><span style="font-family:kaushan script;"><span data-font-size="20px">Like this post...</span></span></span></span></span></span></span></h2>
				</div>
				<div class="cp-sec-title-container 
									" >
					<div class="cp-sec-title cp_responsive" style="color: #FCA524;"><span style="font-family:roboto slab;"><span class="cp_responsive cp_font" data-font-size="20px" style="font-size:20px;"><span data-font-size="25px"><span data-font-size="28px"><span data-font-size="30px"><span data-font-size="40px"><span style="color:#ffffff;"><span data-font-size="55px"><span data-font-size="47px"><span data-font-size="35px"><span data-font-size="38px">Signup for</span></span></span></span></span><span style="color:#FF5252;"><span data-font-size="55px"><span data-font-size="47px"><span data-font-size="35px"><span data-font-size="38px"><span style="font-weight:bold;"><span class="cp_responsive cp_font" data-font-size="30px" style="font-size:30px;"><span data-font-size="35px"><span data-font-size="35px"><span data-font-size="33px"><span data-font-size="30px"><span data-font-size="40px"><span data-font-size="35px"><span data-font-size="50px">&nbsp;</span></span></span></span></span></span></span></span></span></span></span></span></span></span><span style="color:#00FF00;"><span data-font-size="55px"><span data-font-size="47px"><span data-font-size="35px"><span data-font-size="38px"><span style="font-weight:bold;"><span class="cp_responsive cp_font" data-font-size="30px" style="font-size:30px;"><span data-font-size="35px"><span data-font-size="35px"><span data-font-size="33px"><span data-font-size="30px"><span data-font-size="40px"><span data-font-size="35px"><span data-font-size="50px">FREE</span></span></span></span></span></span></span></span></span>&nbsp;</span></span></span></span></span><span style="color:#ffffff;"><span data-font-size="55px"><span data-font-size="47px"><span data-font-size="35px">Cloudbooklet Newsletter</span></span></span></span></span></span></span></span></span></span></div>
				</div>
				<div class="cp-desc-container 
				cp-empty					">
					<div class="cp-description cp_responsive" style="color: #555555;"></div>
				</div>
				<div class="cp-form-container cp-vertical-form-container">
					
		<style type="text/css" class="cp-form-css">.content-5d1ad558b0150 .cp-form-container label:not(.cp-label) {    display:none;}.content-5d1ad558b0150 .cp-form-container label {    color: #eeee22;   font-size: 15px;	font-family:; 	text-align: left;} .content-5d1ad558b0150 .cp-form-container .cp-form-field select {    text-align-last: left;   direction: ltr;}.content-5d1ad558b0150 .cp-form-container input:focus:not([type='radio']):not([type='checkbox']):not([type='range']), .content-5d1ad558b0150 .cp-form-container textarea:focus, .content-5d1ad558b0150 .cp-form-container .cp-form-field button, .content-5d1ad558b0150 .cp-form-container .cp-form-field input, .content-5d1ad558b0150 .cp-form-container .cp-form-field select, .content-5d1ad558b0150 .cp-form-container .cp-form-field textarea { 	text-align: left; 	font-size: 15px; 	font-family: Raleway; 	color: rgb(153, 153, 153); 	background-color: rgb(255, 255, 255); 	border-color: rgb(191, 190, 190); 	padding-top: 10px; 	padding-bottom: 10px; 	padding-left: 16px; 	padding-right: 16px; 	border-radius: 0px;}.content-5d1ad558b0150 .cp-form-container .cp-form-field  .cp-label {  	text-align: left; 	font-size: 15px; 	font-family: Raleway; 	color: rgb(153, 153, 153); 	padding-top: 10px; 	padding-bottom: 10px; 	border-radius: 0px;}.content-5d1ad558b0150 .cp-form-container .cp-submit {  	padding-top: 9px; 	padding-bottom: 9px; 	padding-left: 9px; 	padding-right: 9px;}.content-5d1ad558b0150 .cp-form-container .cp-submit.cp-btn-flat {  	background: #009e12!important;border-radius:1px;}.content-5d1ad558b0150 .cp-form-container .cp-submit.cp-btn-flat:hover {  	background: #009105!important;}.content-5d1ad558b0150 .cp-form-field.cp-enable-box-shadow > div { border-radius: 0px;}</style>
			<div class="form-main cp-form-layout-1">

				<form class="cp-form smile-optin-form  ">

							<input type="hidden" id="1064498286_wpnonce" name="_wpnonce" value="43b157f917">
		<input type="hidden" name="cp-page-url" value="https://www.cloudbooklet.com/how-to-setup-jenkins-with-ssl-with-apache-reverse-proxy-on-ubuntu" />
		<input type="hidden" name="param[user_id]" value="cp-uid-3cfdc32524e78657d4800c3cc8a4f6b6" />
		<input type="hidden" name="param[date]" value="2-7-2019" />
		<input type="hidden" name="list_parent_index" value="0" />
		<input type="hidden" name="action" value="mailchimp_add_subscriber" />
		<input type="hidden" name="list_id" value="cb3191389b" />
		<input type="hidden" name="style_id" value="cp_id_9178d" />
		<input type="hidden" name="msg_wrong_email" value='Please enter correct email address.' />
		<input type="hidden" name="message" value="Thank you." />		
		<input type="hidden" name="cp_module_name" value="Show Time" />
		<input type="hidden" name="cp_set_user" value="None" />
		<input type="hidden" name="cp_module_type" value="" />
				<input type="text" name="cp_set_hp" value="" style="display: none;"/>
			
						<div class="cp-all-inputs-wrap col-xs-12  ">

							

											<div class="cp-form-field  col-md-12 col-lg-12 col-sm-12 col-xs-12 odd-field-fallback ">
																								<label>Email</label>	
												 
												<div>
													<input class="cp-input cp-email" type="email" name="param[email]" placeholder="Email Address"  required  />									</div></div><!-- .cp-form-field -->

																</div>
					
					<div class="cp-submit-wrap  cp-submit-wrap-full col-md-12 col-lg-12 col-sm-12 col-xs-12 ">
													<div class="cp-submit btn-subscribe cp_responsive cp-btn-flat  "    rel="noopener">
								<div><span data-font-size="28px"><span style="color:#FFFFFF;"><span data-font-size="29px"><span style="font-weight:bold;"><span style="font-family:raleway;"><span class="cp_responsive cp_font" data-font-size="18px" style="font-size:18px;"><span data-font-size="20px"><span data-font-size="24px"><span data-font-size="26px"><span data-font-size="30px"><span style="font-family:roboto;">SUBSCRIBE</span></span></span></span></span></span></span></span></span></span></span></div>							</div>
													</div><!-- .cp-submit-wrap -->
					</form><!-- .smile-optin-form -->
				</div>
									</div>

				<div class="cp-info-container cp_responsive 
				cp-empty					" style="color: #838383;">
									</div>
			</div><!-- .cp-text-container -->
			<div class="col-lg-5 col-md-5 col-sm-5 col-xs-12 cp-column-equalized-center">
					
				<div class="cp-image-container">
											<img style="left:0px;top:0px;max-width:143px;" src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/03103038/download.png" class="cp-image"  >
										</div>			</div><!-- .col-lg-5 -->
		</div>

		<!-- AFTER CONTENTS -->
				<input type="hidden" class="cp-impress-nonce" name="cp-impress-nonce" value="56159f8345">

	</div><!-- .cp-modal-body -->

		
</div><!-- .cp-modal-content -->

		<div class="cp-form-processing-wrap" style="border-radius: 0px;-moz-border-radius: 0px;-webkit-border-radius: 0px;border-style: solid;border-color: #ffffff;border-width:  px;border-width:2px;;border-width: 0px;box-shadow: 0 0 3px 1px rgba(0, 0, 0, 0.71) inset;;">
	<div class="cp-form-after-submit">
		<div class ="cp-form-processing">
			<div class ="cp-form-processing" >
			<div class="smile-absolute-loader" style="visibility: visible;">
				<div class="smile-loader" style = "" >
					<div class="smile-loading-bar"></div>
					<div class="smile-loading-bar"></div>
					<div class="smile-loading-bar"></div>
					<div class="smile-loading-bar"></div>
				</div>
			</div>
		</div>		</div>
		<div class ="cp-msg-on-submit" style="color:#000000"></div>
	</div>
</div>
		
		
				<div class="cp-overlay-close cp-image-close cp-inside-close cp-adjacent-right" style="width: 18px">
						<img class="" src="https://www.cloudbooklet.com/wp-content/plugins/convertplug/modules/assets/images/white20.png" alt="close-link" />					</div>

					</div><!-- .cp-animate-container -->

		
</div><!-- .cp-modal -->

		<!-- .affiliate link for fullscreen -->

			</div><!-- .cp-overlay -->
</div><!-- .cp-modal-popup-container -->
						<script type="text/javascript" id="info-bar">
					document.addEventListener("DOMContentLoaded", function(){
						startclock();
					});
					function stopclock (){
						if(timerRunning) clearTimeout(timerID);
						timerRunning = false;
						//document.cookie="time=0";
					}
					function showtime () {
						var now = new Date();
						var my = now.getTime() ;
						now = new Date(my-diffms) ;
						//document.cookie="time="+now.toLocaleString();
						timerID = setTimeout('showtime()',10000);
						timerRunning = true;
					}
					function startclock () {
						stopclock();
						showtime();
					}
					var timerID = null;
					var timerRunning = false;
					var x = new Date() ;
					var now = x.getTime() ;
					var gmt = 1562039640 * 1000 ;
					var diffms = (now - gmt) ;
				</script>
				<link rel="stylesheet" id="image_preview-cp_id_1c24e" href="https://www.cloudbooklet.com/wp-content/plugins/convertplug/modules/info_bar/assets/demos/image_preview/image_preview.min.css" type="text/css" media="all" /><style type="text/css">.cp-image-preview-bar .cp-info-bar-body {
    padding: 0;
}.cp-info-bar.content-5d1ad558b1462 .cp-ifb-toggle-btn {
			font-family: sans-serif
		}.cp-info-bar.content-5d1ad558b1462 .cp-info-bar-body-overlay {background:-webkit-linear-gradient(top, #e00068 0%, #a000f7 125%);background:-o-linear-gradient(top, #e00068 0%, #a000f7 125%);background:-moz-linear-gradient(top, #e00068 0%, #a000f7 125%);background:linear-gradient(to top, #e00068 0%, #a000f7 125%);}.cp-info-bar.content-5d1ad558b1462 .cp-info-bar-body {
				background: rgba(255,255,255,0.01);
			}.cp-info-bar.content-5d1ad558b1462 .cp-ib-container {
			width: 1201px;
		}</style><style class="cp-toggle-btn" type="text/css">.cp-info-bar.content-5d1ad558b1462 .cp-btn-flat.cp-ifb-toggle-btn{
			font-size: 12px;
			border-radius:0px;
			border-width:0px;
			border-color:rgb(0, 0, 0);
			padding-left:15px;
			padding-right:15px;
			padding-top:10px;
			padding-bottom:10px;
			border-color:rgb(0, 0, 0);
		} .cp-info-bar.content-5d1ad558b1462 .cp-btn-flat.cp-ifb-toggle-btn{ background: rgb(0, 0, 0)!important; color:rgb(255, 255, 255); } .cp-info-bar.content-5d1ad558b1462  .cp-btn-flat.cp-ifb-toggle-btn:hover { background: rgb(0, 0, 0)!important; } </style><style class="cp-ifb-second_submit" type="text/css"></style>
		<input type="hidden" id="cp-push-down-support" value="">
		<input type="hidden" id="cp-top-offset-container" value="">

		<div data-module-type="info-bar" data-toggle = "" data-tz-offset = "0" data-dev-mode = "enabled"  data-exit-intent = "disabled" data-add-to-cart = "0"data-onscroll-value = "" data-onload-delay = "0.2" data-timezonename = "wordpress" data-timezone = "0" data-load-on-count = ""data-load-on-refresh = "enabled" data-push-down = "1" data-animate-push-page = "0" data-class = "content-5d1ad558b1462 " data-closed-cookie-time="0" data-conversion-cookie-time="0" data-info_bar-id="cp_id_1c24e" data-info_bar-style="cp_id_1c24e" data-entry-animation="smile-bounceInDown" data-exit-animation="cp-overlay-none" data-option="smile_info_bar_styles"    data-scheduled="false"            data-custom-class=" cp-cp_id_1c24e" data-referrer-domain="" data-referrer-check="hide"  data-after-content-value="50"  id = "cp-cp_id_1c24e " data-custom-selector = "" class="
			cp-module cp-info-bar-container cp-clear  cp-info-bar  cp-image-preview-bar  cp-ib-onload cp-global-load cp-pos-top  global_info_bar_container ib-fixed  smile-animated smile-bounceInDown      content-5d1ad558b1462 cp_id_1c24e  cp-cp_id_1c24e 		" style="min-height:30px;" data-style-id ="cp_id_1c24e" data-module-name ="infobar" data-close-gravity = "1">
			<div class="cp-info-bar-wrapper cp-clear">
				<div class="cp-info-bar-body-overlay"></div>
				<div class="cp-flex cp-info-bar-body ib-close-outside" style="min-height:30px;" data-height=''>
					<div class="cp-flex cp-ib-container">
												<input type="hidden" class="cp-impress-nonce" name="cp-impress-nonce" value="56159f8345">

										<div class="cp-msg-container  ">
			<span class="cp-info-bar-msg cp_responsive"><div><span class="cp_responsive cp_line_height" data-line-height="12px" style="line-height:12px;"><span data-line-height="8px"><span class="cp_responsive cp_font" data-font-size="17px" style="font-size:17px;"><span data-font-size="12px"><span style="font-family:roboto;"><font color="#ffffff">Please help us get 1000 likes in Facebook. Thank You!</font></span></span></span></span></span></div>
</span>
		</div>
		<div class="cp-button-field ib-form-container" id ="smile-ib-optin-form">
			<div class="cp-form-container">
				
		<style type="text/css" class="cp-form-css">.content-5d1ad558b1462 .cp-form-container label:not(.cp-label) {    display:none;}.content-5d1ad558b1462 .cp-form-container label {    color: rgb(153, 153, 153);   font-size: 15px;	font-family:; 	text-align: left;} .content-5d1ad558b1462 .cp-form-container .cp-form-field select {    text-align-last: left;   direction: ltr;}.content-5d1ad558b1462 .cp-form-container input:focus:not([type='radio']):not([type='checkbox']):not([type='range']), .content-5d1ad558b1462 .cp-form-container textarea:focus, .content-5d1ad558b1462 .cp-form-container .cp-form-field button, .content-5d1ad558b1462 .cp-form-container .cp-form-field input, .content-5d1ad558b1462 .cp-form-container .cp-form-field select, .content-5d1ad558b1462 .cp-form-container .cp-form-field textarea { 	text-align: left; 	font-size: 13px; 	font-family: ; 	color: #999999; 	background-color: ; 	border-color: ; 	padding-top: 6px; 	padding-bottom: 6px; 	padding-left: 10px; 	padding-right: 10px; 	border-radius: 3px;}.content-5d1ad558b1462 .cp-form-container .cp-form-field  .cp-label {  	text-align: left; 	font-size: 13px; 	font-family: ; 	color: #999999; 	padding-top: 6px; 	padding-bottom: 6px; 	border-radius: 3px;}.content-5d1ad558b1462 .cp-form-container .cp-submit {  	padding-top: 6px; 	padding-bottom: 6px; 	padding-left: 15px; 	padding-right: 15px;}.content-5d1ad558b1462 .cp-form-container .cp-submit.cp-btn-flat {  	background: #ffffff!important;border-radius:2px;}.content-5d1ad558b1462 .cp-form-container .cp-submit.cp-btn-flat:hover {  	background: #f2f2f2!important;}.content-5d1ad558b1462 .cp-form-field.cp-enable-box-shadow > div { border-radius: 3px;}</style>
			<div class="form-main cp-form-layout-4">

				<form class="cp-form smile-optin-form  ">

							<input type="hidden" id="1599854835_wpnonce" name="_wpnonce" value="326a0e6673">
		<input type="hidden" name="cp-page-url" value="https://www.cloudbooklet.com/how-to-setup-jenkins-with-ssl-with-apache-reverse-proxy-on-ubuntu" />
		<input type="hidden" name="param[user_id]" value="cp-uid-21bb540848510601b3fd321b4f3fec66" />
		<input type="hidden" name="param[date]" value="2-7-2019" />
		<input type="hidden" name="list_parent_index" value="0" />
		<input type="hidden" name="action" value="mailchimp_add_subscriber" />
		<input type="hidden" name="list_id" value="cb3191389b" />
		<input type="hidden" name="style_id" value="cp_id_1c24e" />
		<input type="hidden" name="msg_wrong_email" value='Please enter correct email address.' />
		<input type="hidden" name="message" value="Thank you." />		
		<input type="hidden" name="cp_module_name" value="Top Bar Promo" />
		<input type="hidden" name="cp_set_user" value="None" />
		<input type="hidden" name="cp_module_type" value="" />
				<input type="text" name="cp_set_hp" value="" style="display: none;"/>
			<input type="hidden" name="only_conversion" value="true" />
					<div class="cp-submit-wrap  cp-submit-wrap-left col-md-12 col-lg-12 col-sm-12 col-xs-12  ">
													<div class="cp-submit btn-subscribe cp_responsive cp-btn-flat  "  data-redirect-link="https://www.facebook.com/cloudbooklet/"  data-redirect-link-target="_blank"    rel="noopener">
								<span style="color:#4267b2;"><span class="cp_responsive cp_font" data-font-size="13px" style="font-size:13px;"><span style="font-family:roboto;"><span data-font-size="14px"><span data-font-size="16px"><span data-font-size="17px"><span data-font-size="18px"><span style="font-weight:bold;"><span data-font-size="16px"><span data-font-size="18px"><span data-font-size="25px"><span data-font-size="16px"><span data-font-size="14px"><span data-font-size="18px"><span data-font-size="12px">LIKE NOW</span></span></span></span></span></span></span></span></span></span></span></span></span></span></span>							</div>
													</div><!-- .cp-submit-wrap -->
					</form><!-- .smile-optin-form -->
				</div>
									</div>
			</div>
				</div><!-- cp-ib-container -->
			</div><!-- cp-info-bar-body -->

		
</div>
<!--toggle button-->
					<div class="ib-close  ib-img-close  cp-adjacent-right" style=" width:16px;"><img src="//storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/03103039/button_close.png" class="" close-link ></div>
	
		</div>
						<script type="text/javascript" id="slidein">
					document.addEventListener("DOMContentLoaded", function(){
						startclock();
					});
					function stopclock (){
						if(timerRunning) clearTimeout(timerID);
						timerRunning = false;
						//document.cookie="time=0";
					}

					function showtime () {
						var now = new Date();
						var my = now.getTime() ;
						now = new Date(my-diffms) ;
						//document.cookie="time="+now.toLocaleString();
						timerID = setTimeout('showtime()',10000);
						timerRunning = true;
					}

					function startclock () {
						stopclock();
						showtime();
					}
					var timerID = null;
					var timerRunning = false;
					var x = new Date() ;
					var now = x.getTime() ;
					var gmt = 1562039640 * 1000 ;
					var diffms = (now - gmt) ;
				</script>
				<link rel="stylesheet" id="optin-cp_id_bc43f" href="https://www.cloudbooklet.com/wp-content/plugins/convertplug/modules/slide_in/assets/demos/optin/optin.min.css" type="text/css" media="all" /><!-- slide_in Shortcode --><style class="cp-slidebg-color" type="text/css">.slidein-overlay.content-5d1ad558b1a1c .cp-slidein-body-overlay {
					background: #e5e5e5;
				}</style><style class="cp-slidebtn-submit" type="text/css">.slidein-overlay.content-5d1ad558b1a1c .cp-btn-flat.cp-slide-edit-btn{ background: rgb(0, 0, 0)!important;;; color:rgb(255, 255, 255); } .slidein-overlay.content-5d1ad558b1a1c  .cp-btn-flat.cp-slide-edit-btn:hover { background: rgb(0, 0, 0)!important; } </style>			<div data-dev-mode="disabled" data-load-on-refresh="enabled" data-custom-class="cp-cp_id_bc43f cp-slidein-global" data-exit-intent="disabled" data-add-to-cart = "0"data-onscroll-value="" data-onload-delay ="6" data-overlay-class = "overlay-zoomin" data-class-id = "content-5d1ad558b1a1c"  data-closed-cookie-time="1" data-conversion-cookie-time="18"  data-slidein-id="cp_id_bc43f"  data-slidein-style="cp_id_bc43f"  data-option="smile_slide_in_styles"     data-after-content-value="50" data-referrer-domain="" data-referrer-check="hide" data-custom-selector = "" class=" si-onload cp-global-load  overlay-show cp-cp_id_bc43f cp-slidein-global"  data-module-type="slide_in" ></div>
						<div class="cp-module cp-slidein-popup-container cp_id_bc43f cp-optin-container overlay-show " data-style-id ="cp_id_bc43f" data-module-name ="slidein" data-close-gravity = "1" >
				<div class="
				slidein-overlay  global_slidein_container    content-5d1ad558b1a1c   				" data-image-position="" data-placeholder-color ="" data-timezonename ="wordpress" data-timezone ="0" data-load-on-refresh ="enabled" data-custom-class ="cp-cp_id_bc43f cp-slidein-global" data-class ="content-5d1ad558b1a1c" data-placeholder-font ="" data-load-on-count =""  data-closed-cookie-time="1" data-conversion-cookie-time="18"  data-slidein-id="cp_id_bc43f"  data-slidein-style="cp_id_bc43f"  data-option="smile_slide_in_styles"    data-scheduled="false"    data-overlay-animation = "smile-slideInUp"       >
					<div class="cp-slidein slidein-bottom-right" style="max-width:300px;">
						<div class="cp-animate-container "  data-overlay-animation = "smile-slideInUp"  data-exit-animation="smile-slideOutDown">
							<div class="cp-slidein-content" id="slide-in-animate-cp_id_bc43f" style="border-radius: 0px;-moz-border-radius: 0px;-webkit-border-radius: 0px;border-style: none;border-color: #003fff;border-width:  px;border-width:0px;;">
								<div class="cp-slidein-body cp-optin  cp-no-padding  " style = "" >
									<div class="cp-slidein-body-overlay cp_cs_overlay" style=";"></div>
											<div class="cp-row">
			<div class="col-lg-12 col-md-12 col-sm-12 col-xs-12 cp-text-container " >

				<div class="cp-title-container 
									">
					<h2 class="cp-title cp_responsive"><span class="cp_responsive cp_font" data-font-size="20px" style="font-size:20px;"><span data-font-size="12px">Stay Connected!</span></span></h2>
				</div>
				<div class="cp-desc-container 
									">
					<div class="cp-description cp_responsive" ><span class="cp_responsive cp_font" data-font-size="12px" style="font-size:12px;"><span data-font-size="11px"><span data-font-size="9px">Get latest tutorials on Google Cloud and Open Source topics </span></span></span></div>
				</div>
			</div><!-- end of text container-->

			<div class="col-lg-12 col-md-12 col-sm-12 col-xs-12 cp-form-container">
				
		<style type="text/css" class="cp-form-css">.content-5d1ad558b1a1c .cp-form-container label:not(.cp-label) {    display:none;}.content-5d1ad558b1a1c .cp-form-container label {    color: rgb(153, 153, 153);   font-size: 14px;	font-family:; 	text-align: left;} .content-5d1ad558b1a1c .cp-form-container .cp-form-field select {    text-align-last: left;   direction: ltr;}.content-5d1ad558b1a1c .cp-form-container input:focus:not([type='radio']):not([type='checkbox']):not([type='range']), .content-5d1ad558b1a1c .cp-form-container textarea:focus, .content-5d1ad558b1a1c .cp-form-container .cp-form-field button, .content-5d1ad558b1a1c .cp-form-container .cp-form-field input, .content-5d1ad558b1a1c .cp-form-container .cp-form-field select, .content-5d1ad558b1a1c .cp-form-container .cp-form-field textarea { 	text-align: left; 	font-size: 13px; 	font-family: Roboto; 	color: #7a7a7a; 	background-color: rgb(255, 255, 255); 	border-color: rgb(191, 190, 190); 	padding-top: 6px; 	padding-bottom: 6px; 	padding-left: 7px; 	padding-right: 7px; 	border-radius: 0px;}.content-5d1ad558b1a1c .cp-form-container .cp-form-field  .cp-label {  	text-align: left; 	font-size: 13px; 	font-family: Roboto; 	color: #7a7a7a; 	padding-top: 6px; 	padding-bottom: 6px; 	border-radius: 0px;}.content-5d1ad558b1a1c .cp-form-container .cp-submit {  	padding-top: 5px; 	padding-bottom: 5px; 	padding-left: 7px; 	padding-right: 7px;}.content-5d1ad558b1a1c .cp-form-container .cp-submit.cp-btn-flat {  	background: #2d53fe!important;border-radius:3px;}.content-5d1ad558b1a1c .cp-form-container .cp-submit.cp-btn-flat:hover {  	background: #2046f1!important;}.content-5d1ad558b1a1c .cp-form-field.cp-enable-box-shadow > div { border-radius: 0px;}</style>
			<div class="form-main cp-form-layout-3">

				<form class="cp-form smile-optin-form  ">

							<input type="hidden" id="513666001_wpnonce" name="_wpnonce" value="786132f0a7">
		<input type="hidden" name="cp-page-url" value="https://www.cloudbooklet.com/how-to-setup-jenkins-with-ssl-with-apache-reverse-proxy-on-ubuntu" />
		<input type="hidden" name="param[user_id]" value="cp-uid-9b8d53e8826e211257d96d5c50a43778" />
		<input type="hidden" name="param[date]" value="2-7-2019" />
		<input type="hidden" name="list_parent_index" value="0" />
		<input type="hidden" name="action" value="mailchimp_add_subscriber" />
		<input type="hidden" name="list_id" value="cb3191389b" />
		<input type="hidden" name="style_id" value="cp_id_bc43f" />
		<input type="hidden" name="msg_wrong_email" value='Please enter correct email address.' />
		<input type="hidden" name="message" value="Thank you." />		
		<input type="hidden" name="cp_module_name" value="Right Slide In" />
		<input type="hidden" name="cp_set_user" value="None" />
		<input type="hidden" name="cp_module_type" value="" />
				<input type="text" name="cp_set_hp" value="" style="display: none;"/>
			
						<div class="cp-all-inputs-wrap col-xs-12  col-xs-12 col-sm-8 col-md-8 col-lg-8  ">

							

											<div class="cp-form-field  col-md-12 col-lg-12 col-sm-12 col-xs-12 enable-field-attached">
																								<label>Email</label>	
												 
												<div>
													<input class="cp-input cp-email" type="email" name="param[email]" placeholder="Enter Your Email Address"  required  />									</div></div><!-- .cp-form-field -->

																</div>
					
					<div class="cp-submit-wrap  cp-submit-wrap-full col-xs-12 col-sm-4 col-md-4 col-lg-4  enable-field-attached">
													<div class="cp-submit btn-subscribe cp_responsive cp-btn-flat smile-animated  "   data-animation ="smile-slideInUp"; rel="noopener">
								<span class="cp_responsive cp_font" data-font-size="12px" style="font-size:12px;"><span data-font-size="11px"><span data-font-size="9px">SUBSCRIBE</span></span></span>							</div>
													</div><!-- .cp-submit-wrap -->
					</form><!-- .smile-optin-form -->
				</div>
								</div>
			<div class="cp-info-container 
			cp-empty				" >
							</div>
		</div><!--row-->
						<input type="hidden" class="cp-impress-nonce" name="cp-impress-nonce" value="56159f8345">

	</div><!-- .cp-slidein-body -->
</div><!-- .cp-slidein-content -->

		<div class="cp-form-processing-wrap" style="border-radius: 0px 0px 0px 0px;-moz-border-radius: 0px 0px 0px 0px;-webkit-border-radius: 0px 0px 0px 0px;;">
	<div class="cp-form-after-submit">
		<div class ="cp-form-processing" style="">
			<div class ="cp-form-processing" >
			<div class="smile-absolute-loader" style="visibility: visible;">
				<div class="smile-loader" style = "width: 100px" >
					<div class="smile-loading-bar"></div>
					<div class="smile-loading-bar"></div>
					<div class="smile-loading-bar"></div>
					<div class="smile-loading-bar"></div>
				</div>
			</div>
		</div>		</div>
		<div class ="cp-msg-on-submit" style="color:#000000;"></div>
	</div>
</div>
		
			<div class="slidein-overlay-close cp-image-close cp-inside-close cp-adjacent-right" style="width: 23px">
						<img class="cp-default-close" src="https://www.cloudbooklet.com/wp-content/plugins/convertplug/modules/slide_in/assets/img/cross.png" alt="close-link"/>					</div>
					</div><!-- .cp-animate-container -->
		</div><!-- .cp-slidein -->

		

		
</div><!-- .slidein-overlay -->
</div><!-- .cp-slidein-popup-container -->
		<link rel='stylesheet' id='gglcptch-css'  href='https://www.cloudbooklet.com/wp-content/plugins/google-captcha/css/gglcptch.css' type='text/css' media='all' />
<link rel='stylesheet' id='optin_to_win-cp_id_9178d-css'  href='https://www.cloudbooklet.com/wp-content/plugins/convertplug/modules/modal/assets/demos/optin_to_win/optin_to_win.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='gglcptch_hide-css'  href='https://www.cloudbooklet.com/wp-content/plugins/google-captcha/css/hide_badge.css' type='text/css' media='all' />
<script type='text/javascript' src='https://www.cloudbooklet.com/wp-content/themes/contentberg/js/magnific-popup.js'></script>
<script type='text/javascript' src='https://www.cloudbooklet.com/wp-content/themes/contentberg/js/jquery.fitvids.js'></script>
<script type='text/javascript' src='https://www.cloudbooklet.com/wp-includes/js/imagesloaded.min.js'></script>
<script type='text/javascript' src='https://www.cloudbooklet.com/wp-content/themes/contentberg/js/object-fit-images.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var Bunyad = {"custom_ajax_url":"\/how-to-setup-jenkins-with-ssl-with-apache-reverse-proxy-on-ubuntu\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.cloudbooklet.com/wp-content/themes/contentberg/js/theme.js'></script>
<script type='text/javascript' src='https://www.cloudbooklet.com/wp-content/themes/contentberg/js/theia-sticky-sidebar.js'></script>
<script type='text/javascript' src='https://www.cloudbooklet.com/wp-content/themes/contentberg/js/jquery.slick.js'></script>
<script type='text/javascript' src='https://www.cloudbooklet.com/wp-content/themes/contentberg/js/jarallax.js'></script>
<script type='text/javascript' src='https://www.cloudbooklet.com/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://www.cloudbooklet.com/wp-includes/js/wp-embed.min.js'></script>
<script async="async" type='text/javascript' src='https://www.cloudbooklet.com/wp-content/plugins/akismet/_inc/form.js'></script>
<script type='text/javascript' defer="defer" src='https://www.cloudbooklet.com/wp-content/plugins/convertplug/modules/assets/js/cp-module-main.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var smile_ajax = {"url":"https:\/\/www.cloudbooklet.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' defer="defer" src='https://www.cloudbooklet.com/wp-content/plugins/convertplug/modules/modal/assets/js/modal.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var smile_ajax = {"url":"https:\/\/www.cloudbooklet.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' defer="defer" src='https://www.cloudbooklet.com/wp-content/plugins/convertplug/modules/info_bar/assets/js/info_bar.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var smile_ajax = {"url":"https:\/\/www.cloudbooklet.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' defer="defer" src='https://www.cloudbooklet.com/wp-content/plugins/convertplug/modules/slide_in/assets/js/slide_in.min.js'></script>
<script type='text/javascript' data-cfasync="false" async="async" defer="defer" src='https://www.google.com/recaptcha/api.js?render=explicit'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var gglcptch = {"options":{"version":"invisible","sitekey":"6LcRq3oUAAAAAMgQwu9M_Xl_YfqYhB1JdQFlM0J9","theme":"red","error":"<strong>Warning<\/strong>:&nbsp;More than one reCAPTCHA has been found in the current form. Please remove all unnecessary reCAPTCHA fields to make it work properly.","disable":0},"vars":{"visibility":false}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.cloudbooklet.com/wp-content/plugins/google-captcha/js/script.js'></script>

</body>
</html>