<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8" /><meta http-equiv="x-ua-compatible" content="ie=edge" /><meta name="viewport" content="width=device-width, initial-scale=1" /><link rel="profile" href="http://gmpg.org/xfn/11" /><title>Install Grafana on Ubuntu 18.04 with Nginx - Google Cloud</title><link rel="stylesheet" href="https://www.cloudbooklet.com/wp-content/cache/min/1/3026508f53fde444de8052c87394d6a3.css" data-minify="1" /><meta name="description" content="Install Grafana on Ubuntu 18.04 with Nginx reverse proxy on Google Cloud platform and connect to Cloud SQL. Learn to install Grafana with Nginx on linux"/><link rel="canonical" href="https://www.cloudbooklet.com/install-grafana-on-ubuntu-18-04-with-nginx-google-cloud/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Install Grafana on Ubuntu 18.04 with Nginx - Google Cloud" /><meta property="og:description" content="Install Grafana on Ubuntu 18.04 with Nginx reverse proxy on Google Cloud platform and connect to Cloud SQL. Learn to install Grafana with Nginx on linux" /><meta property="og:url" content="https://www.cloudbooklet.com/install-grafana-on-ubuntu-18-04-with-nginx-google-cloud/" /><meta property="og:site_name" content="Cloudbooklet" /><meta property="article:tag" content="Google Cloud Platform" /><meta property="article:tag" content="Nginx" /><meta property="article:tag" content="Ubuntu 18.04" /><meta property="article:section" content="Google Cloud" /><meta property="article:published_time" content="2019-07-30T14:50:35+00:00" /><meta property="article:modified_time" content="2019-07-30T14:50:38+00:00" /><meta property="og:updated_time" content="2019-07-30T14:50:38+00:00" /><meta property="og:image" content="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30132434/Install-Grafana-on-Ubuntu-18.04-with-Nginx-Google-Cloud.jpg" /><meta property="og:image:secure_url" content="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30132434/Install-Grafana-on-Ubuntu-18.04-with-Nginx-Google-Cloud.jpg" /><meta property="og:image:width" content="1920" /><meta property="og:image:height" content="1080" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Install Grafana on Ubuntu 18.04 with Nginx reverse proxy on Google Cloud platform and connect to Cloud SQL. Learn to install Grafana with Nginx on linux" /><meta name="twitter:title" content="Install Grafana on Ubuntu 18.04 with Nginx - Google Cloud" /><meta name="twitter:image" content="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30132434/Install-Grafana-on-Ubuntu-18.04-with-Nginx-Google-Cloud.jpg" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.cloudbooklet.com/#website","url":"https://www.cloudbooklet.com/","name":"Cloudbooklet","potentialAction":{"@type":"SearchAction","target":"https://www.cloudbooklet.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.cloudbooklet.com/install-grafana-on-ubuntu-18-04-with-nginx-google-cloud/#primaryimage","url":"https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30132434/Install-Grafana-on-Ubuntu-18.04-with-Nginx-Google-Cloud.jpg","width":1920,"height":1080,"caption":"Install Grafana on Ubuntu 18.04 with Nginx - Google Cloud"},{"@type":"WebPage","@id":"https://www.cloudbooklet.com/install-grafana-on-ubuntu-18-04-with-nginx-google-cloud/#webpage","url":"https://www.cloudbooklet.com/install-grafana-on-ubuntu-18-04-with-nginx-google-cloud/","inLanguage":"en-US","name":"Install Grafana on Ubuntu 18.04 with Nginx - Google Cloud","isPartOf":{"@id":"https://www.cloudbooklet.com/#website"},"primaryImageOfPage":{"@id":"https://www.cloudbooklet.com/install-grafana-on-ubuntu-18-04-with-nginx-google-cloud/#primaryimage"},"datePublished":"2019-07-30T14:50:35+00:00","dateModified":"2019-07-30T14:50:38+00:00","author":{"@id":"https://www.cloudbooklet.com/#/schema/person/b895618ef766a19d0976cbbdeb3631d0"},"description":"Install Grafana on Ubuntu 18.04 with Nginx reverse proxy on Google Cloud platform and connect to Cloud SQL. Learn to install Grafana with Nginx on linux"},{"@type":["Person"],"@id":"https://www.cloudbooklet.com/#/schema/person/b895618ef766a19d0976cbbdeb3631d0","name":"Cloudbooklet","image":{"@type":"ImageObject","@id":"https://www.cloudbooklet.com/#authorlogo","url":"https://secure.gravatar.com/avatar/ebf9d20bc990a9eaa2c392f3194974c2?s=96&d=mm&r=g","caption":"Cloudbooklet"},"sameAs":[]}]}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel="alternate" type="application/rss+xml" title="Cloudbooklet &raquo; Feed" href="https://www.cloudbooklet.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Cloudbooklet &raquo; Comments Feed" href="https://www.cloudbooklet.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Cloudbooklet &raquo; Install Grafana on Ubuntu 18.04 with Nginx &#8211; Google Cloud Comments Feed" href="https://www.cloudbooklet.com/install-grafana-on-ubuntu-18-04-with-nginx-google-cloud/feed/" /><link crossorigin="anonymous" rel='stylesheet' id='contentberg-fonts-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A400%2C500%2C700%7CPT+Serif%3A400%2C400i%2C600%7CIBM+Plex+Serif%3A500' type='text/css' media='all' /><style id='contentberg-child-inline-css' type='text/css'>.post-content,.entry-content{color:#000}.entry-content{color:#000}.navigation .menu>li:not(:hover)>a,.navigation.dark .menu>li:not(:hover)>a{color:#000}.navigation .menu>li li a{color:#000000!important}</style><style id='rocket-lazyload-inline-css' type='text/css'>.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://www.cloudbooklet.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}</style> <script type='text/javascript' src='https://www.cloudbooklet.com/wp-includes/js/jquery/jquery.js'></script> <!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://www.cloudbooklet.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><link rel="amphtml" href="https://www.cloudbooklet.com/install-grafana-on-ubuntu-18-04-with-nginx-google-cloud/?amp"><link rel="icon" href="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2018/11/03061204/cropped-fc7de09d-favicon-1-32x32.png" sizes="32x32" /><link rel="icon" href="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2018/11/03061204/cropped-fc7de09d-favicon-1-192x192.png" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2018/11/03061204/cropped-fc7de09d-favicon-1-180x180.png" /><meta name="msapplication-TileImage" content="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2018/11/03061204/cropped-fc7de09d-favicon-1-270x270.png" /> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-102617346-3', 'auto', {'useAmpClientId': true});
  ga('send', 'pageview');</script>  <noscript><style type="text/css">.wpb_animate_when_almost_visible{opacity:1}</style></noscript><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript></head><body class="post-template-default single single-post postid-964 single-format-standard  lazy-smart no-sidebar has-lb wpb-js-composer js-comp-ver-5.7 vc_responsive"><div class="main-wrap"><header id="main-head" class="main-head head-nav-below has-search-modal simple simple-boxed"><div class="inner inner-head" data-sticky-bar="smart"><div class="wrap cf wrap-head"><div class="left-contain"> <span class="mobile-nav"><i class="fa fa-bars"></i></span><div class="title"> <a href="https://www.cloudbooklet.com/" title="Cloudbooklet" rel="home"> <img class="mobile-logo" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20326%2050'%3E%3C/svg%3E" width="326" height="50"
alt="Cloudbooklet" data-lazy-src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2018/11/03053211/6130a887-logo.png" /><noscript><img class="mobile-logo" src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2018/11/03053211/6130a887-logo.png" width="326" height="50"
alt="Cloudbooklet" /></noscript> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="logo-image" alt="Cloudbooklet" data-lazy-src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2018/11/03053211/6130a887-logo.png" /><noscript><img src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2018/11/03053211/6130a887-logo.png" class="logo-image" alt="Cloudbooklet" /></noscript> </a></div></div><div class="navigation-wrap inline"><nav class="navigation inline simple light" data-sticky-bar="smart"><div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-833" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-833"><a href="https://www.cloudbooklet.com/articles/"><span>Articles</span></a></li><li id="menu-item-817" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-cat-3 menu-item-817"><a href="https://www.cloudbooklet.com/category/google-cloud/"><span>Google Cloud</span></a><ul class="sub-menu"><li id="menu-item-821" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-cat-11 menu-item-821"><a href="https://www.cloudbooklet.com/category/google-cloud/compute-engine/"><span>Compute Engine</span></a></li><li id="menu-item-819" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-9 menu-item-819"><a href="https://www.cloudbooklet.com/category/google-cloud/cloud-sql/"><span>Cloud SQL</span></a></li><li id="menu-item-818" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-7 menu-item-818"><a href="https://www.cloudbooklet.com/category/google-cloud/bigquery/"><span>BigQuery</span></a></li><li id="menu-item-822" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-8 menu-item-822"><a href="https://www.cloudbooklet.com/category/google-cloud/network-services/cloud-dns/"><span>Cloud DNS</span></a></li><li id="menu-item-820" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-10 menu-item-820"><a href="https://www.cloudbooklet.com/category/google-cloud/google-cloud-storage/"><span>Cloud Storage</span></a></li></ul></li><li id="menu-item-836" class="menu-item menu-item-type-post_type menu-item-object-page current-post-parent menu-item-836"><a href="https://www.cloudbooklet.com/about/"><span>About</span></a></li><li id="menu-item-837" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-837"><a href="https://www.cloudbooklet.com/contact/"><span>Contact</span></a></li><li id="menu-item-834" class="highlight menu-item menu-item-type-custom menu-item-object-custom menu-item-834"><a href="https://www.cloudbooklet.com/tools/"><span>Tools</span></a></li></ul></div></nav></div><div class="actions"><ul class="social-icons cf"><li><a href="https://www.facebook.com/cloudbooklet/" class="fa fa-facebook" target="_blank"><span class="visuallyhidden">Facebook</span></a></li><li><a href="https://www.youtube.com/channel/UCBWNRcvVx38glmATV5vBxJg" class="fa fa-youtube" target="_blank"><span class="visuallyhidden">YouTube</span></a></li><li><a href="https://www.linkedin.com/company/cloudbooklet/" class="fa fa-linkedin" target="_blank"><span class="visuallyhidden">LinkedIn</span></a></li></ul> <a href="#" title="Search" class="search-link"><i class="fa fa-search"></i></a></div></div></div></header><div class="main wrap"><div class="ts-row cf"><div class="col-8 main-content cf"><article id="post-964" class="the-post-modern the-post post-964 post type-post status-publish format-standard has-post-thumbnail category-compute-engine category-google-cloud tag-google-cloud tag-nginx tag-ubuntu-18-04"><header class="post-header the-post-header cf"><div class="post-meta post-meta-b the-post-meta"> <span class="post-cat"> <span class="text-in">In</span> <a href="https://www.cloudbooklet.com/category/google-cloud/compute-engine/" class="category">Compute Engine</a></span><h1 class="post-title-alt"> Install Grafana on Ubuntu 18.04 with Nginx &#8211; Google Cloud</h1><div class="below"> <span class="meta-item read-time">3 Mins Read</span></div></div><div class="featured"> <a href="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30132434/Install-Grafana-on-Ubuntu-18.04-with-Nginx-Google-Cloud.jpg" class="image-link"><img width="1024" height="576" src="data:image/svg+xml,%3Csvg%20viewBox%3D%270%200%201024%20576%27%20xmlns%3D%27http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%27%3E%3C%2Fsvg%3E" class="attachment-large size-large lazyload wp-post-image" alt="Install Grafana on Ubuntu 18.04 with Nginx - Google Cloud" title="Install Grafana on Ubuntu 18.04 with Nginx &#8211; Google Cloud" data-srcset="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30132434/Install-Grafana-on-Ubuntu-18.04-with-Nginx-Google-Cloud-1024x576.jpg 1024w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30132434/Install-Grafana-on-Ubuntu-18.04-with-Nginx-Google-Cloud-300x169.jpg 300w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30132434/Install-Grafana-on-Ubuntu-18.04-with-Nginx-Google-Cloud-768x432.jpg 768w" data-src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30132434/Install-Grafana-on-Ubuntu-18.04-with-Nginx-Google-Cloud-1024x576.jpg" data-sizes="(max-width: 1024px) 100vw, 1024px" /> </a></div></header><div><div class="post-share-float share-float-a is-hidden cf"> <span class="share-text">Share</span><div class="services"> <a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.cloudbooklet.com%2Finstall-grafana-on-ubuntu-18-04-with-nginx-google-cloud%2F" class="cf service facebook" target="_blank" title="Share on Facebook"> <i class="fa fa-facebook"></i> <span class="label">Share on Facebook</span> </a> <a href="http://twitter.com/home?status=https%3A%2F%2Fwww.cloudbooklet.com%2Finstall-grafana-on-ubuntu-18-04-with-nginx-google-cloud%2F" class="cf service twitter" target="_blank" title="Share on Twitter"> <i class="fa fa-twitter"></i> <span class="label">Share on Twitter</span> </a> <a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.cloudbooklet.com%2Finstall-grafana-on-ubuntu-18-04-with-nginx-google-cloud%2F&#038;media=https%3A%2F%2Fstorage.googleapis.com%2Fcloudbooklet-new%2Fwp-content%2Fuploads%2F2019%2F07%2F30132434%2FInstall-Grafana-on-Ubuntu-18.04-with-Nginx-Google-Cloud.jpg&#038;description=Install+Grafana+on+Ubuntu+18.04+with+Nginx+%26%238211%3B+Google+Cloud" class="cf service pinterest" target="_blank" title="Pinterest"> <i class="fa fa-pinterest-p"></i> <span class="label">Pinterest</span> </a> <a href="mailto:?subject=Install%2BGrafana%2Bon%2BUbuntu%2B18.04%2Bwith%2BNginx%2B%2526%25238211%253B%2BGoogle%2BCloud&#038;body=https%3A%2F%2Fwww.cloudbooklet.com%2Finstall-grafana-on-ubuntu-18-04-with-nginx-google-cloud%2F" class="cf service email" target="_blank" title="Email"> <i class="fa fa-envelope-o"></i> <span class="label">Email</span> </a></div></div></div><div class="post-content description cf entry-content has-share-float content-spacious-full"><p>Install Grafana on Ubuntu 18.04 with Nginx &#8211; Google Cloud Platform and connect it to Cloud SQL.</p><p>Grafana is a open-source platform for data-visualization and monitoring any kind of database with over 150,000 active installations. Grafana is widely used in DevOps, IIoT and AdTech.</p><p>In this guide you are going to learn how to install and setup Grafana on Google Cloud and add Cloud SQL as data source.</p><div class="wp-block-columns has-3-columns"><div class="wp-block-column"><div class="wp-block-image"><figure class="aligncenter"><a href="https://www.patreon.com/cloudbooklet" target="_blank" rel="noreferrer noopener"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" class="wp-image-887" data-lazy-srcset="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112004/patreon-promo.jpg 440w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112004/patreon-promo-300x109.jpg 300w" data-lazy-sizes="(max-width: 440px) 100vw, 440px" data-lazy-src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112004/patreon-promo.jpg" /><noscript><img src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112004/patreon-promo.jpg" alt="" class="wp-image-887" srcset="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112004/patreon-promo.jpg 440w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112004/patreon-promo-300x109.jpg 300w" sizes="(max-width: 440px) 100vw, 440px" /></noscript></a></figure></div></div><div class="wp-block-column"><div class="wp-block-image"><figure class="aligncenter"><a href="https://www.fiverr.com/wordpress_vip" target="_blank" rel="noreferrer noopener"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" class="wp-image-888" data-lazy-srcset="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112018/Fiverr-promo.jpg 440w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112018/Fiverr-promo-300x109.jpg 300w" data-lazy-sizes="(max-width: 440px) 100vw, 440px" data-lazy-src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112018/Fiverr-promo.jpg" /><noscript><img src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112018/Fiverr-promo.jpg" alt="" class="wp-image-888" srcset="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112018/Fiverr-promo.jpg 440w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112018/Fiverr-promo-300x109.jpg 300w" sizes="(max-width: 440px) 100vw, 440px" /></noscript></a></figure></div></div><div class="wp-block-column"><div class="wp-block-image"><figure class="aligncenter"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" class="wp-image-889" data-lazy-srcset="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112315/Udemy-Promo.jpg 440w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112315/Udemy-Promo-300x109.jpg 300w" data-lazy-sizes="(max-width: 440px) 100vw, 440px" data-lazy-src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112315/Udemy-Promo.jpg" /><noscript><img src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112315/Udemy-Promo.jpg" alt="" class="wp-image-889" srcset="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112315/Udemy-Promo.jpg 440w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/06112315/Udemy-Promo-300x109.jpg 300w" sizes="(max-width: 440px) 100vw, 440px" /></noscript></figure></div></div></div><h3>Prerequisites</h3><ol><li>Your Compute Engine Instance running.</li><li>For setting up Compute Engine, see the <a href="https://www.cloudbooklet.com/setting-up-google-cloud-compute-engine-instance/">Setting up Compute Engine Instance</a>.</li><li>Initial <a rel="noreferrer noopener" aria-label="Server Setup on Google Cloud (opens in a new tab)" href="https://www.cloudbooklet.com/ubuntu-server-setup-on-google-cloud-platform/" target="_blank">Server Setup on Google Cloud</a>.</li><li>Set up Cloud DNS, see the <a href="https://www.cloudbooklet.com/setting-up-google-cloud-dns-for-your-domain/">Setting up Google Cloud DNS for your domain</a>.</li><li>Google Cloud SQL Setup, see <a href="https://www.cloudbooklet.com/create-cloud-sql-instance-and-connect-to-vm-instance-in-gcp/">Setup Cloud SQL and connect with Compute Engine</a>.</li></ol><p>This setup can also be done on other Cloud hosting or any other VPS or Dedicated servers. Below are some lists to checkout</p><table class="wp-block-table is-style-stripes"><tbody><tr><td><strong>Platform</strong></td><td><strong>Machine Type</strong></td><td><strong>Cost (Monthly)</strong></td></tr><tr><td><a href="https://m.do.co/c/9440105a04ba" target="_blank" rel="noreferrer noopener" aria-label="Digitalocean (opens in a new tab)">Digitalocean</a></td><td>1 GB RAM</td><td>$5</td></tr><tr><td><a href="https://cloud.google.com" target="_blank" rel="noreferrer noopener" aria-label="Google Cloud Platform (opens in a new tab)">Google Cloud Platform</a></td><td>600 MB RAM</td><td>$4.28</td></tr><tr><td><a href="https://aws.amazon.com/" target="_blank" rel="noreferrer noopener" aria-label="Amazon Web Services (opens in a new tab)">Amazon Web Services</a></td><td>1 GB RAM</td><td>$14</td></tr></tbody></table><h3>Step 1: Update Server</h3><p>Make sure your server is upto date.</p><pre class="wp-block-preformatted">sudo apt update
sudo apt upgrade</pre><h3>Step 2: Install Grafana</h3><p>Add Grafana gpg key to install signed packages and add the repository.</p><pre class="wp-block-preformatted">curl https://packages.grafana.com/gpg.key | sudo apt-key add -
sudo add-apt-repository "deb https://packages.grafana.com/oss/deb stable main"</pre><p>Update the repository and install Grafana.</p><pre class="wp-block-preformatted">sudo apt update
sudo apt -y install grafana</pre><p>Start Grafana.</p><pre class="wp-block-preformatted">sudo systemctl start grafana-server
sudo systemctl enable grafana-server</pre><p>You can check the status of Grafana using this command</p><pre class="wp-block-preformatted">sudo systemctl status grafana-server</pre><p>You will receive an output similar to this.</p><pre class="wp-block-preformatted">● grafana-server.service - Grafana instance
    Loaded: loaded (/usr/lib/systemd/system/grafana-server.service; enabled; vendor preset: enabled)
    Active: <span class="replace">active (running)</span> since Tue 2019-07-30 09:36:47 UTC; 15s ago
      Docs: http://docs.grafana.org
  Main PID: 4399 (grafana-server)
     Tasks: 10 (limit: 667)
    CGroup: /system.slice/grafana-server.service
            └─4399 /usr/sbin/grafana-server --config=/etc/grafana/grafana.ini </pre><p>Enable it to startup on boot.</p><pre class="wp-block-preformatted">sudo systemctl enable grafana-server</pre><h3>Step 3: Install Nginx</h3><p>Once Grafana is installed you can install Nginx and configure it.</p><pre class="wp-block-preformatted">sudo apt install nginx</pre><h3>Step 4: Configure Nginx</h3><p>Remove the default Nginx configuration.</p><pre class="wp-block-preformatted">sudo rm -rf /etc/nginx/sites-available/default
sudo rm -rf /etc/nginx/sites-enabled/default</pre><p>Create a new configuration with the reverse proxy setup for Grafana</p><pre class="wp-block-preformatted">sudo nano /etc/nginx/sites-available/grafana.conf</pre><p>Paste the following in the file.</p><pre class="wp-block-preformatted">server {
     listen 80;

     server_name <span class="replace">yourdomainname.com</span>;

     location / {
         proxy_pass http://localhost:3000;
         proxy_http_version 1.1;
         proxy_set_header Upgrade $http_upgrade;
         proxy_set_header Connection 'upgrade';
         proxy_set_header Host $host;
         proxy_cache_bypass $http_upgrade;
     }
}</pre><p>Hit <code>Ctrl + X</code> followed by <code>Y</code> and <code>Enter</code> to save and exit the file.</p><p>Enable the configuration by creating a symbolic link to <code>sites-enabled</code> directory.</p><pre class="wp-block-preformatted">sudo ln -s /etc/nginx/sites-available/grafana.conf /etc/nginx/sites-enabled/grafana.conf</pre><p>Restart Nginx</p><pre class="wp-block-preformatted">sudo nginx -t
sudo service nginx restart</pre><h3>Step 5: Check the Installation</h3><p>Now check your domain name on your browser.</p><p>You will see the login page of Grafana.</p><div class="wp-block-image"><figure class="aligncenter"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Grafana Login" class="wp-image-967" data-lazy-srcset="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30143422/Grafana-Login.jpg 481w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30143422/Grafana-Login-289x300.jpg 289w" data-lazy-sizes="(max-width: 481px) 100vw, 481px" data-lazy-src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30143422/Grafana-Login.jpg" /><noscript><img src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30143422/Grafana-Login.jpg" alt="Grafana Login" class="wp-image-967" srcset="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30143422/Grafana-Login.jpg 481w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30143422/Grafana-Login-289x300.jpg 289w" sizes="(max-width: 481px) 100vw, 481px" /></noscript></figure></div><p>The default username is <strong>admin </strong>and the password is <strong>admin</strong></p><p>In the next screen you can setup a new password.</p><p>Once you setup a new password you will land at the Grafana dashboard.</p><div class="wp-block-image"><figure class="aligncenter"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Grafana Dashboard" class="wp-image-968" data-lazy-srcset="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30143645/Grafana-Dashboard.jpg 985w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30143645/Grafana-Dashboard-300x152.jpg 300w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30143645/Grafana-Dashboard-768x390.jpg 768w" data-lazy-sizes="(max-width: 985px) 100vw, 985px" data-lazy-src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30143645/Grafana-Dashboard.jpg" /><noscript><img src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30143645/Grafana-Dashboard.jpg" alt="Grafana Dashboard" class="wp-image-968" srcset="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30143645/Grafana-Dashboard.jpg 985w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30143645/Grafana-Dashboard-300x152.jpg 300w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30143645/Grafana-Dashboard-768x390.jpg 768w" sizes="(max-width: 985px) 100vw, 985px" /></noscript></figure></div><p>Next you can add the Cloud SQL as the source.</p><p>Click Add Data Source and select MySQL.</p><p>Here you can add the details of Cloud SQL.</p><p>Specify the name, Enter <strong>Cloud SQL IP</strong> address as the Host, Enter <strong>database</strong> name, Enter <strong>username</strong> and <strong>password</strong> and click <strong>Save and Test</strong>.</p><div class="wp-block-image"><figure class="aligncenter"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Cloud SQL in Grafana" class="wp-image-969" data-lazy-srcset="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30144259/Cloud-SQL-in-Grafana.jpg 969w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30144259/Cloud-SQL-in-Grafana-300x155.jpg 300w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30144259/Cloud-SQL-in-Grafana-768x396.jpg 768w" data-lazy-sizes="(max-width: 969px) 100vw, 969px" data-lazy-src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30144259/Cloud-SQL-in-Grafana.jpg" /><noscript><img src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30144259/Cloud-SQL-in-Grafana.jpg" alt="Cloud SQL in Grafana" class="wp-image-969" srcset="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30144259/Cloud-SQL-in-Grafana.jpg 969w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30144259/Cloud-SQL-in-Grafana-300x155.jpg 300w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30144259/Cloud-SQL-in-Grafana-768x396.jpg 768w" sizes="(max-width: 969px) 100vw, 969px" /></noscript></figure></div><p>Once the connection is successful you can visualize the database in Grafana.</p><div class="wp-block-image"><figure class="aligncenter"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Cloud SQL data in Grafana" class="wp-image-970" data-lazy-srcset="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30144623/Cloud-SQL-data-in-Grafana.jpg 972w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30144623/Cloud-SQL-data-in-Grafana-300x154.jpg 300w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30144623/Cloud-SQL-data-in-Grafana-768x395.jpg 768w" data-lazy-sizes="(max-width: 972px) 100vw, 972px" data-lazy-src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30144623/Cloud-SQL-data-in-Grafana.jpg" /><noscript><img src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30144623/Cloud-SQL-data-in-Grafana.jpg" alt="Cloud SQL data in Grafana" class="wp-image-970" srcset="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30144623/Cloud-SQL-data-in-Grafana.jpg 972w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30144623/Cloud-SQL-data-in-Grafana-300x154.jpg 300w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/30144623/Cloud-SQL-data-in-Grafana-768x395.jpg 768w" sizes="(max-width: 972px) 100vw, 972px" /></noscript></figure></div><h3>Conclusion</h3><p>Now you have learned how to install Grafana on Google Cloud and configure it with Nginx and access Clloud SQL database.</p> <span class="cp-load-after-post"></span></div><div class="the-post-foot cf"><div class="tag-share cf"><div class="post-tags"><a href="https://www.cloudbooklet.com/tag/google-cloud/" rel="tag">Google Cloud Platform</a><a href="https://www.cloudbooklet.com/tag/nginx/" rel="tag">Nginx</a><a href="https://www.cloudbooklet.com/tag/ubuntu-18-04/" rel="tag">Ubuntu 18.04</a></div><div class="post-share"></div></div></div><section class="related-posts grid-3"><h4 class="section-head"><span class="title">Related Posts</span></h4><div class="ts-row posts cf"><article class="post col-4"> <a href="https://www.cloudbooklet.com/install-nginx-with-google-pagespeed-on-ubuntu-18-04-google-cloud/" title="Install Nginx with Google PageSpeed on Ubuntu 18.04 &#8211; Google Cloud" class="image-link"> <img width="770" height="515" src="data:image/svg+xml,%3Csvg%20viewBox%3D%270%200%20770%20515%27%20xmlns%3D%27http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%27%3E%3C%2Fsvg%3E" class="image lazyload wp-post-image" alt="Install Nginx with Google PageSpeed on Ubuntu 18.04 - Google Cloud" title="Install Nginx with Google PageSpeed on Ubuntu 18.04 &#8211; Google Cloud" data-srcset="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/26122033/Install-Nginx-with-Google-PageSpeed-on-Ubuntu-18.04-Google-Cloud-770x515.jpg 770w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/26122033/Install-Nginx-with-Google-PageSpeed-on-Ubuntu-18.04-Google-Cloud-270x180.jpg 270w" data-src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/26122033/Install-Nginx-with-Google-PageSpeed-on-Ubuntu-18.04-Google-Cloud-770x515.jpg" data-sizes="(max-width: 770px) 100vw, 770px" /> </a><div class="content"><h3 class="post-title"><a href="https://www.cloudbooklet.com/install-nginx-with-google-pagespeed-on-ubuntu-18-04-google-cloud/" class="post-link">Install Nginx with Google PageSpeed on Ubuntu 18.04 &#8211; Google Cloud</a></h3><div class="post-meta"> <time class="post-date" datetime="2019-07-26T12:22:20+00:00">July 26, 2019</time></div></div></article ><article class="post col-4"> <a href="https://www.cloudbooklet.com/install-wordpress-with-docker-compose-using-nginx-google-cloud/" title="Install WordPress with Docker Compose using Nginx &#8211; Google Cloud" class="image-link"> <img width="770" height="515" src="data:image/svg+xml,%3Csvg%20viewBox%3D%270%200%20770%20515%27%20xmlns%3D%27http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%27%3E%3C%2Fsvg%3E" class="image lazyload wp-post-image" alt="Install WordPress with Docker Compose using Nginx Google Cloud" title="Install WordPress with Docker Compose using Nginx &#8211; Google Cloud" data-srcset="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/23113134/Install-WordPress-with-Docker-Compose-using-Nginx-Google-Cloud-770x515.jpg 770w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/23113134/Install-WordPress-with-Docker-Compose-using-Nginx-Google-Cloud-270x180.jpg 270w" data-src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/23113134/Install-WordPress-with-Docker-Compose-using-Nginx-Google-Cloud-770x515.jpg" data-sizes="(max-width: 770px) 100vw, 770px" /> </a><div class="content"><h3 class="post-title"><a href="https://www.cloudbooklet.com/install-wordpress-with-docker-compose-using-nginx-google-cloud/" class="post-link">Install WordPress with Docker Compose using Nginx &#8211; Google Cloud</a></h3><div class="post-meta"> <time class="post-date" datetime="2019-07-23T11:32:13+00:00">July 23, 2019</time></div></div></article ><article class="post col-4"> <a href="https://www.cloudbooklet.com/how-to-install-tomcat-9-on-ubuntu-18-04-google-cloud/" title="How to Install Tomcat 9 on Ubuntu 18.04 &#8211; Google Cloud" class="image-link"> <img width="770" height="515" src="data:image/svg+xml,%3Csvg%20viewBox%3D%270%200%20770%20515%27%20xmlns%3D%27http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%27%3E%3C%2Fsvg%3E" class="image lazyload wp-post-image" alt="How to Install Tomcat 9 on Ubuntu 18.04 - Google Cloud" title="How to Install Tomcat 9 on Ubuntu 18.04 &#8211; Google Cloud" data-srcset="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/17143850/How-to-Install-Tomcat-9-on-Ubuntu-18.04-Google-Cloud-770x515.jpg 770w, https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/17143850/How-to-Install-Tomcat-9-on-Ubuntu-18.04-Google-Cloud-270x180.jpg 270w" data-src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/17143850/How-to-Install-Tomcat-9-on-Ubuntu-18.04-Google-Cloud-770x515.jpg" data-sizes="(max-width: 770px) 100vw, 770px" /> </a><div class="content"><h3 class="post-title"><a href="https://www.cloudbooklet.com/how-to-install-tomcat-9-on-ubuntu-18-04-google-cloud/" class="post-link">How to Install Tomcat 9 on Ubuntu 18.04 &#8211; Google Cloud</a></h3><div class="post-meta"> <time class="post-date" datetime="2019-07-17T14:39:14+00:00">July 17, 2019</time></div></div></article ></div></section><div class="comments"><div id="comments" class="comments-area"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title"><span class="section-head"><span class="title">Write A Comment</span></span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/install-grafana-on-ubuntu-18-04-with-nginx-google-cloud/#respond" style="display:none;">Cancel Reply</a></small></h3><form action="https://www.cloudbooklet.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><div class="inline-field"> <input name="author" id="author" type="text" value="" aria-required="true" placeholder="Name" required /></div><div class="inline-field"> <input name="email" id="email" type="text" value="" aria-required="true" placeholder="Email" required /></div><div class="reply-field cf"><textarea name="comment" id="comment" cols="45" rows="7" placeholder="Enter your comment here.." aria-required="true" required></textarea></div><p class="comment-form-cookies-consent"> <input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment. </label></p><div class="gglcptch gglcptch_invisible"><div class="google-captcha-notice">This site is protected by reCAPTCHA and the Google <a href="https://policies.google.com/privacy" target="_blank">Privacy Policy</a> and <a href="https://policies.google.com/terms" target="_blank">Terms of Service</a> apply.</div><div id="gglcptch_recaptcha_1375650302" class="gglcptch_recaptcha"></div> <noscript><div style="width: 302px;"><div style="width: 302px; height: 422px; position: relative;"><div style="width: 302px; height: 422px; position: absolute;"> <iframe src="https://www.google.com/recaptcha/api/fallback?k=6LcRq3oUAAAAAMgQwu9M_Xl_YfqYhB1JdQFlM0J9" frameborder="0" scrolling="no" style="width: 302px; height:422px; border-style: none;"></iframe></div></div><div style="border-style: none; bottom: 12px; left: 25px; margin: 0px; padding: 0px; right: 25px; background: #f9f9f9; border: 1px solid #c1c1c1; border-radius: 3px; height: 60px; width: 300px;"><textarea id="g-recaptcha-response" name="g-recaptcha-response" class="g-recaptcha-response" style="width: 250px !important; height: 40px !important; border: 1px solid #c1c1c1 !important; margin: 10px 25px !important; padding: 0px !important; resize: none !important;"></textarea></div></div> </noscript></div><p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='964' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="3a640142c2" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="114"/></p></form></div></div></div></article></div></div></div><footer class="main-footer bold bold-light"><section class="upper-footer"><div class="wrap"><ul class="widgets ts-row cf"><li id="custom_html-4" class="widget_text widget column col-4 widget_custom_html"><div class="textwidget custom-html-widget"><article class="support col-4"> <a href="https://www.patreon.com/cloudbooklet" title="Support us on Patreon" target="_blank" class="image-link" rel="noopener noreferrer"> <img class=" lazyload" width="770" height="515" src="data:image/svg+xml,%3Csvg%20viewBox%3D%270%200%20770%20515%27%20xmlns%3D%27http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%27%3E%3C%2Fsvg%3E" alt="Support us on Patreon" data-src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/04083045/patreon.jpg" /> </a></article></div></li><li id="custom_html-5" class="widget_text widget column col-4 widget_custom_html"><div class="textwidget custom-html-widget"><article class="support col-4"> <a href="https://www.fiverr.com/wordpress_vip/be-google-cloud-professional" title="Hire me on Fiverr" target="_blank" class="image-link" rel="noopener noreferrer"> <img class=" lazyload" width="770" height="515" src="data:image/svg+xml,%3Csvg%20viewBox%3D%270%200%20770%20515%27%20xmlns%3D%27http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%27%3E%3C%2Fsvg%3E" alt="Hire me on Fiverr" data-src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/04085915/Fiverr1.jpg" /> </a></article></div></li><li id="custom_html-6" class="widget_text widget column col-4 widget_custom_html"><div class="textwidget custom-html-widget"><article class="support col-4"> <a href="javascript:void(0)" title="Learn Google Cloud" target="_blank" class="image-link" rel="noopener noreferrer"> <img class=" lazyload" width="770" height="515" src="data:image/svg+xml,%3Csvg%20viewBox%3D%270%200%20770%20515%27%20xmlns%3D%27http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%27%3E%3C%2Fsvg%3E" alt="Learn Google Cloud" data-src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/04090736/udemy.jpg" /> </a></article></div></li></ul></div></section><section class="lower-footer cf"><div class="wrap"><ul class="social-icons"><li> <a href="https://www.facebook.com/cloudbooklet/" class="social-link" target="_blank" title="Facebook"> <i class="fa fa-facebook"></i> <span class="label">Facebook</span> </a></li><li> <a href="#" class="social-link" target="_blank" title="Twitter"> <i class="fa fa-twitter"></i> <span class="label">Twitter</span> </a></li><li> <a href="https://www.youtube.com/channel/UCBWNRcvVx38glmATV5vBxJg" class="social-link" target="_blank" title="YouTube"> <i class="fa fa-youtube"></i> <span class="label">YouTube</span> </a></li><li> <a href="https://www.linkedin.com/company/cloudbooklet/" class="social-link" target="_blank" title="LinkedIn"> <i class="fa fa-linkedin"></i> <span class="label">LinkedIn</span> </a></li></ul><div class="links"><div class="menu-footer-links-container"><ul id="menu-footer-links" class="menu"><li id="menu-item-838" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-838"><a href="https://www.cloudbooklet.com/about/">About</a></li><li id="menu-item-839" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-839"><a href="https://www.cloudbooklet.com/contact/">Contact</a></li><li id="menu-item-840" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-840"><a href="https://www.cloudbooklet.com/disclaimer/">Disclaimer</a></li><li id="menu-item-841" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-841"><a href="https://www.cloudbooklet.com/privacy-policy-2/">Privacy Policy</a></li></ul></div></div><p class="copyright">© 2018 <a href="https://www.cloudbooklet.com">CloudBooklet</a>. All rights reserved.</p><div class="to-top"> <a href="#" class="back-to-top"><i class="fa fa-angle-up"></i> Top</a></div></div></section></footer></div><div class="mobile-menu-container off-canvas" id="mobile-menu"><a href="#" class="close"><i class="fa fa-times"></i></a><div class="logo"> <img class="mobile-logo lazyload" src="data:image/svg+xml,%3Csvg%20viewBox%3D%270%200%20326%2050%27%20xmlns%3D%27http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%27%3E%3C%2Fsvg%3E" width="326" height="50" alt="Cloudbooklet" data-src="https://storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2018/11/03053211/6130a887-logo.png" /></div><ul id="menu-main-menu-1" class="mobile-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-833"><a href="https://www.cloudbooklet.com/articles/">Articles</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-817"><a href="https://www.cloudbooklet.com/category/google-cloud/">Google Cloud</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-821"><a href="https://www.cloudbooklet.com/category/google-cloud/compute-engine/">Compute Engine</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-819"><a href="https://www.cloudbooklet.com/category/google-cloud/cloud-sql/">Cloud SQL</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-818"><a href="https://www.cloudbooklet.com/category/google-cloud/bigquery/">BigQuery</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-822"><a href="https://www.cloudbooklet.com/category/google-cloud/network-services/cloud-dns/">Cloud DNS</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-820"><a href="https://www.cloudbooklet.com/category/google-cloud/google-cloud-storage/">Cloud Storage</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page current-post-parent menu-item-836"><a href="https://www.cloudbooklet.com/about/">About</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-837"><a href="https://www.cloudbooklet.com/contact/">Contact</a></li><li class="highlight menu-item menu-item-type-custom menu-item-object-custom menu-item-834"><a href="https://www.cloudbooklet.com/tools/">Tools</a></li></ul></div><div class="search-modal-wrap"><div class="search-modal-box" role="dialog" aria-modal="true"><form method="get" class="search-form" action="https://www.cloudbooklet.com/"> <input type="search" class="search-field" name="s" placeholder="Search..." value="" required /><button type="submit" class="search-submit visuallyhidden">Submit</button><p class="message"> Type above and press <em>Enter</em> to search. Press <em>Esc</em> to cancel.</p></form></div></div><style type="text/css"></style><div data-class-id="content-5d405be47f5b4" data-referrer-domain="" data-referrer-check="hide" data-after-content-value="50" data-overlay-class = "overlay-zoomin" data-onload-delay = "5"data-onscroll-value = ""data-exit-intent = "disabled"data-add-to-cart = "0" data-closed-cookie-time="1" data-conversion-cookie-time="15"  data-modal-id="cp_id_4e2ff"  data-modal-style="cp_id_4e2ff"  data-option="smile_modal_styles"    data-custom-class = "cp-cp_id_4e2ff cp-modal-global"data-load-on-refresh = "enabled"data-dev-mode = "disabled"data-custom-selector = "" class="overlay-show cp-onload cp-global-load  cp-cp_id_4e2ff cp-modal-global" data-module-type="modal" ></div><div data-form-layout="cp-form-layout-1" class="cp-module cp-modal-popup-container  cp_id_4e2ff cp-first-order-container " data-style-id ="cp_id_4e2ff"  data-module-name ="modal" data-close-gravity = "1"><div class="content-5d405be47f5b4 cp-overlay   smile-pulse  global_modal_container   "  data-scheduled="false"  data-closed-cookie-time="1" data-conversion-cookie-time="15"  data-modal-id="cp_id_4e2ff"  data-modal-style="cp_id_4e2ff"  data-option="smile_modal_styles" data-placeholder-font="inherit"data-custom-class = "cp-cp_id_4e2ff cp-modal-global"data-class = "content-5d405be47f5b4"data-load-on-refresh = "enabled"data-load-on-count = "" data-affiliate_setting ="0"  data-overlay-animation = "smile-pulse"       data-tz-offset = "0"data-image-position = ""data-placeholder-color = ""data-timezonename = "wordpress"data-timezone = "0"  style=" " ><div class="cp-overlay-background" style=" background-color:rgba(0,0,0,0.71);"></div><div class="cp-modal cp-modal-custom-size" style="width:100%;height:auto;max-width:612px;"><div class="cp-animate-container"  data-overlay-animation = "smile-pulse"  data-exit-animation="smile-bounceOutDown"><div class="cp-modal-content "   style = "border-radius: 0px;-moz-border-radius: 0px;-webkit-border-radius: 0px;border-style: solid;border-color: #ffffff;border-width:  px;border-width:5px;" ><div data-bg="url(//storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/08020522/preset_newsletter.jpg)" class="cp-modal-body cp-first-order  rocket-lazyload" style = "background-repeat: no-repeat;background-position: center;background-size: cover;;" ><div class="cp-modal-body-overlay cp_cs_overlay" style="background-color:rgba(255,255,255,0.01);;;"></div><div class="cp-row"><div class="col-lg-12 col-md-12 col-sm-12 col-xs-12 cp-text-container"><div class=""><div class="cp-image-container"> <img style="left:0px;top:0px;max-width:105px;" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="cp-image"  data-lazy-src="//storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/08020525/note.png" ><noscript><img style="left:0px;top:0px;max-width:105px;" src="//storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/07/08020525/note.png" class="cp-image"  ></noscript></div></div><div class="cp-title-container
"><h2 class="cp-title cp_responsive" ><span style="color:#FFFFFF;"><span class="cp_responsive cp_font" data-font-size="37px" style="font-size:37px;"><span style="font-family:oregano;">Where Writing Meets Entrepreneurship!</span></span></span></h2></div><div class="cp-short-desc-container cp-clear
"><div class="cp-short-description cp_responsive cp-clear " ><span class="cp_responsive cp_font" data-font-size="18px" style="font-size:18px;"><span style="color:#FFFFFF;"><span style="font-family:roboto;">Get FREE Google Cloud Tutorials.</span></span></span></div></div><div class="cp-form-container"><style type="text/css" class="cp-form-css">.content-5d405be47f5b4 .cp-form-container label:not(.cp-label){display:none}.content-5d405be47f5b4 .cp-form-container label{color:rgb(153,153,153);font-size:15px;font-family:;text-align:left}.content-5d405be47f5b4 .cp-form-container .cp-form-field select{text-align-last:left;direction:ltr}.content-5d405be47f5b4 .cp-form-container input:focus:not([type='radio']):not([type='checkbox']):not([type='range']),.content-5d405be47f5b4 .cp-form-container textarea:focus,.content-5d405be47f5b4 .cp-form-container .cp-form-field button,.content-5d405be47f5b4 .cp-form-container .cp-form-field input,.content-5d405be47f5b4 .cp-form-container .cp-form-field select,.content-5d405be47f5b4 .cp-form-container .cp-form-field textarea{text-align:left;font-size:15px;font-family:;color:rgb(153,153,153);background-color:rgb(255,255,255);border-color:rgb(191,190,190);padding-top:13px;padding-bottom:13px;padding-left:15px;padding-right:15px;border-radius:0}.content-5d405be47f5b4 .cp-form-container .cp-form-field .cp-label{text-align:left;font-size:15px;font-family:;color:rgb(153,153,153);padding-top:13px;padding-bottom:13px;border-radius:0}.content-5d405be47f5b4 .cp-form-container .cp-submit{padding-top:10px;padding-bottom:10px;padding-left:15px;padding-right:15px}.content-5d405be47f5b4 .cp-form-container .cp-submit.cp-btn-flat{background:#00b8d4!important;border-radius:0}.content-5d405be47f5b4 .cp-form-container .cp-submit.cp-btn-flat:hover{background:#00abc7!important}.content-5d405be47f5b4 .cp-form-field.cp-enable-box-shadow>div{border-radius:0}</style><div class="form-main cp-form-layout-1"><form class="cp-form smile-optin-form  "><input type="hidden" id="1285511274_wpnonce" name="_wpnonce" value="6849cc50cc"> <input type="hidden" name="cp-page-url" value="https://www.cloudbooklet.com/install-grafana-on-ubuntu-18-04-with-nginx-google-cloud" /> <input type="hidden" name="param[user_id]" value="cp-uid-2e4ef09d4dd34f9b9b988b00d8074d1f" /> <input type="hidden" name="param[date]" value="30-7-2019" /> <input type="hidden" name="list_parent_index" value="0" /> <input type="hidden" name="action" value="mailchimp_add_subscriber" /> <input type="hidden" name="list_id" value="cb3191389b" /> <input type="hidden" name="style_id" value="cp_id_4e2ff" /> <input type="hidden" name="msg_wrong_email" value='Please enter correct email address.' /> <input type="hidden" name="message" value="Thank you." /> <input type="hidden" name="cp_module_name" value="Popup" /> <input type="hidden" name="cp_module_type" value="" /> <input type="text" name="cp_set_hp" value="" style="display: none;"/><div class="cp-all-inputs-wrap col-xs-12  "><div class="cp-form-field  col-md-12 col-lg-12 col-sm-12 col-xs-12 odd-field-fallback "> <label>Email</label><div> <input class="cp-input cp-email" type="email" name="param[email]" placeholder="Enter Your Email Address"  required  /></div></div></div><div class="cp-submit-wrap  cp-submit-wrap-full col-md-12 col-lg-12 col-sm-12 col-xs-12 "><div class="cp-submit btn-subscribe cp_responsive cp-btn-flat  "    rel="noopener"> <span style="font-family:oregano;">GET NOW</span></div></div></form></div></div><div class="cp-info-container cp_responsive
cp-empty					" ></div></div></div> <input type="hidden" class="cp-impress-nonce" name="cp-impress-nonce" value="5916cf2a8d"></div></div><div class="cp-form-processing-wrap" style="border-radius: 0px;-moz-border-radius: 0px;-webkit-border-radius: 0px;border-style: solid;border-color: #ffffff;border-width:  px;border-width:5px;;border-width: 0px;box-shadow: 0 0 3px 1px rgba(0,0,0,0.71) inset;;"><div class="cp-form-after-submit"><div class ="cp-form-processing"><div class ="cp-form-processing" ><div class="smile-absolute-loader" style="visibility: visible;"><div class="smile-loader" style = "" ><div class="smile-loading-bar"></div><div class="smile-loading-bar"></div><div class="smile-loading-bar"></div><div class="smile-loading-bar"></div></div></div></div></div><div class ="cp-msg-on-submit" style="color:#000000"></div></div></div><div class="cp-overlay-close cp-image-close cp-adjacent-close cp-adjacent-right" style="width: 32px"> <img class="" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="close-link" data-lazy-src="https://www.cloudbooklet.com/wp-content/plugins/convertplug/modules/assets/images/default.png" /><noscript><img class="" src="https://www.cloudbooklet.com/wp-content/plugins/convertplug/modules/assets/images/default.png" alt="close-link" /></noscript></div></div></div></div></div><style type="text/css">.cp-image-preview-bar .cp-info-bar-body{padding:0}.cp-info-bar.content-5d405be47fd03 .cp-ifb-toggle-btn{font-family:sans-serif}.cp-info-bar.content-5d405be47fd03 .cp-info-bar-body-overlay{background:-webkit-linear-gradient(top,#e00068 0%,#a000f7 125%);background:-o-linear-gradient(top,#e00068 0%,#a000f7 125%);background:-moz-linear-gradient(top,#e00068 0%,#a000f7 125%);background:linear-gradient(to top,#e00068 0%,#a000f7 125%)}.cp-info-bar.content-5d405be47fd03 .cp-info-bar-body{background:rgba(255,255,255,.01)}.cp-info-bar.content-5d405be47fd03 .cp-ib-container{width:1201px}</style><style class="cp-toggle-btn" type="text/css">.cp-info-bar.content-5d405be47fd03 .cp-btn-flat.cp-ifb-toggle-btn{font-size:12px;border-radius:0;border-width:0;border-color:rgb(0,0,0);padding-left:15px;padding-right:15px;padding-top:10px;padding-bottom:10px;border-color:rgb(0,0,0)}.cp-info-bar.content-5d405be47fd03 .cp-btn-flat.cp-ifb-toggle-btn{background:rgb(0,0,0)!important;color:rgb(255,255,255)}.cp-info-bar.content-5d405be47fd03 .cp-btn-flat.cp-ifb-toggle-btn:hover{background:rgb(0,0,0)!important}</style><style class="cp-ifb-second_submit" type="text/css"></style><input type="hidden" id="cp-push-down-support" value=""> <input type="hidden" id="cp-top-offset-container" value=""><div data-module-type="info-bar" data-toggle = "" data-tz-offset = "0" data-dev-mode = "enabled"  data-exit-intent = "disabled" data-add-to-cart = "0"data-onscroll-value = "" data-onload-delay = "0.2" data-timezonename = "wordpress" data-timezone = "0" data-load-on-count = ""data-load-on-refresh = "enabled" data-push-down = "1" data-animate-push-page = "0" data-class = "content-5d405be47fd03 " data-closed-cookie-time="0" data-conversion-cookie-time="0" data-info_bar-id="cp_id_1c24e" data-info_bar-style="cp_id_1c24e" data-entry-animation="smile-bounceInDown" data-exit-animation="cp-overlay-none" data-option="smile_info_bar_styles"    data-scheduled="false"            data-custom-class=" cp-cp_id_1c24e" data-referrer-domain="" data-referrer-check="hide"  data-after-content-value="50"  id = "cp-cp_id_1c24e " data-custom-selector = "" class="
cp-module cp-info-bar-container cp-clear  cp-info-bar  cp-image-preview-bar  cp-ib-onload cp-global-load cp-pos-top  global_info_bar_container ib-fixed  smile-animated smile-bounceInDown      content-5d405be47fd03 cp_id_1c24e  cp-cp_id_1c24e 		" style="min-height:30px;" data-style-id ="cp_id_1c24e" data-module-name ="infobar" data-close-gravity = "1"><div class="cp-info-bar-wrapper cp-clear"><div class="cp-info-bar-body-overlay"></div><div class="cp-flex cp-info-bar-body ib-close-outside" style="min-height:30px;" data-height=''><div class="cp-flex cp-ib-container"> <input type="hidden" class="cp-impress-nonce" name="cp-impress-nonce" value="5916cf2a8d"><div class="cp-msg-container  "> <span class="cp-info-bar-msg cp_responsive"><div><span class="cp_responsive cp_line_height" data-line-height="12px" style="line-height:12px;"><span data-line-height="8px"><span class="cp_responsive cp_font" data-font-size="17px" style="font-size:17px;"><span data-font-size="12px"><span style="font-family:roboto;"><font color="#ffffff">Please help us get 1000 likes in Facebook. Thank You!</font></span></span></span></span></span></div> </span></div><div class="cp-button-field ib-form-container" id ="smile-ib-optin-form"><div class="cp-form-container"><style type="text/css" class="cp-form-css">.content-5d405be47fd03 .cp-form-container label:not(.cp-label){display:none}.content-5d405be47fd03 .cp-form-container label{color:rgb(153,153,153);font-size:15px;font-family:;text-align:left}.content-5d405be47fd03 .cp-form-container .cp-form-field select{text-align-last:left;direction:ltr}.content-5d405be47fd03 .cp-form-container input:focus:not([type='radio']):not([type='checkbox']):not([type='range']),.content-5d405be47fd03 .cp-form-container textarea:focus,.content-5d405be47fd03 .cp-form-container .cp-form-field button,.content-5d405be47fd03 .cp-form-container .cp-form-field input,.content-5d405be47fd03 .cp-form-container .cp-form-field select,.content-5d405be47fd03 .cp-form-container .cp-form-field textarea{text-align:left;font-size:13px;font-family:;color:#999;background-color:;border-color:;padding-top:6px;padding-bottom:6px;padding-left:10px;padding-right:10px;border-radius:3px}.content-5d405be47fd03 .cp-form-container .cp-form-field .cp-label{text-align:left;font-size:13px;font-family:;color:#999;padding-top:6px;padding-bottom:6px;border-radius:3px}.content-5d405be47fd03 .cp-form-container .cp-submit{padding-top:6px;padding-bottom:6px;padding-left:15px;padding-right:15px}.content-5d405be47fd03 .cp-form-container .cp-submit.cp-btn-flat{background:#ffffff!important;border-radius:2px}.content-5d405be47fd03 .cp-form-container .cp-submit.cp-btn-flat:hover{background:#f2f2f2!important}.content-5d405be47fd03 .cp-form-field.cp-enable-box-shadow>div{border-radius:3px}</style><div class="form-main cp-form-layout-4"><form class="cp-form smile-optin-form  "><input type="hidden" id="1481396303_wpnonce" name="_wpnonce" value="e1d506b6e5"> <input type="hidden" name="cp-page-url" value="https://www.cloudbooklet.com/install-grafana-on-ubuntu-18-04-with-nginx-google-cloud" /> <input type="hidden" name="param[user_id]" value="cp-uid-80c67c846b026640fdb3e537a5ab0e3a" /> <input type="hidden" name="param[date]" value="30-7-2019" /> <input type="hidden" name="list_parent_index" value="0" /> <input type="hidden" name="action" value="mailchimp_add_subscriber" /> <input type="hidden" name="list_id" value="cb3191389b" /> <input type="hidden" name="style_id" value="cp_id_1c24e" /> <input type="hidden" name="msg_wrong_email" value='Please enter correct email address.' /> <input type="hidden" name="message" value="Thank you." /> <input type="hidden" name="cp_module_name" value="Top Bar Promo" /> <input type="hidden" name="cp_module_type" value="" /> <input type="text" name="cp_set_hp" value="" style="display: none;"/> <input type="hidden" name="only_conversion" value="true" /><div class="cp-submit-wrap  cp-submit-wrap-left col-md-12 col-lg-12 col-sm-12 col-xs-12  "><div class="cp-submit btn-subscribe cp_responsive cp-btn-flat  "  data-redirect-link="https://www.facebook.com/cloudbooklet/"  data-redirect-link-target="_blank"    rel="noopener"> <span style="color:#4267b2;"><span class="cp_responsive cp_font" data-font-size="13px" style="font-size:13px;"><span style="font-family:roboto;"><span data-font-size="14px"><span data-font-size="16px"><span data-font-size="17px"><span data-font-size="18px"><span style="font-weight:bold;"><span data-font-size="16px"><span data-font-size="18px"><span data-font-size="25px"><span data-font-size="16px"><span data-font-size="14px"><span data-font-size="18px"><span data-font-size="12px">LIKE NOW</span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></div></div></form></div></div></div></div></div></div><div class="ib-close  ib-img-close  cp-adjacent-right" style=" width:16px;"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="" close-link data-lazy-src="//storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/03103039/button_close.png" ><noscript><img src="//storage.googleapis.com/cloudbooklet-new/wp-content/uploads/2019/06/03103039/button_close.png" class="" close-link ></noscript></div></div> <style class="cp-slidebg-color" type="text/css">.slidein-overlay.content-5d405be4802e6 .cp-slidein-body-overlay{background:#e5e5e5}</style><style class="cp-slidebtn-submit" type="text/css">.slidein-overlay.content-5d405be4802e6 .cp-btn-flat.cp-slide-edit-btn{background:rgb(0,0,0)!important;;;color:rgb(255,255,255)}.slidein-overlay.content-5d405be4802e6 .cp-btn-flat.cp-slide-edit-btn:hover{background:rgb(0,0,0)!important}</style><div data-dev-mode="disabled" data-load-on-refresh="enabled" data-custom-class="cp-cp_id_bc43f cp-slidein-global" data-exit-intent="disabled" data-add-to-cart = "0"data-onscroll-value="" data-onload-delay ="6" data-overlay-class = "overlay-zoomin" data-class-id = "content-5d405be4802e6"  data-closed-cookie-time="1" data-conversion-cookie-time="18"  data-slidein-id="cp_id_bc43f"  data-slidein-style="cp_id_bc43f"  data-option="smile_slide_in_styles"     data-after-content-value="50" data-referrer-domain="" data-referrer-check="hide" data-custom-selector = "" class=" si-onload cp-global-load  overlay-show cp-cp_id_bc43f cp-slidein-global"  data-module-type="slide_in" ></div><div class="cp-module cp-slidein-popup-container cp_id_bc43f cp-optin-container overlay-show " data-style-id ="cp_id_bc43f" data-module-name ="slidein" data-close-gravity = "1" ><div class="
slidein-overlay  global_slidein_container    content-5d405be4802e6   				" data-image-position="" data-placeholder-color ="" data-timezonename ="wordpress" data-timezone ="0" data-load-on-refresh ="enabled" data-custom-class ="cp-cp_id_bc43f cp-slidein-global" data-class ="content-5d405be4802e6" data-placeholder-font ="" data-load-on-count =""  data-closed-cookie-time="1" data-conversion-cookie-time="18"  data-slidein-id="cp_id_bc43f"  data-slidein-style="cp_id_bc43f"  data-option="smile_slide_in_styles"    data-scheduled="false"    data-overlay-animation = "smile-slideInUp"       ><div class="cp-slidein slidein-bottom-right" style="max-width:300px;"><div class="cp-animate-container "  data-overlay-animation = "smile-slideInUp"  data-exit-animation="smile-slideOutDown"><div class="cp-slidein-content" id="slide-in-animate-cp_id_bc43f" style="border-radius: 0px;-moz-border-radius: 0px;-webkit-border-radius: 0px;border-style: none;border-color: #003fff;border-width:  px;border-width:0px;;"><div class="cp-slidein-body cp-optin  cp-no-padding  " style = "" ><div class="cp-slidein-body-overlay cp_cs_overlay" style=";"></div><div class="cp-row"><div class="col-lg-12 col-md-12 col-sm-12 col-xs-12 cp-text-container " ><div class="cp-title-container
"><h2 class="cp-title cp_responsive"><span class="cp_responsive cp_font" data-font-size="20px" style="font-size:20px;"><span data-font-size="12px">Stay Connected!</span></span></h2></div><div class="cp-desc-container
"><div class="cp-description cp_responsive" ><span class="cp_responsive cp_font" data-font-size="12px" style="font-size:12px;"><span data-font-size="11px"><span data-font-size="9px">Get latest tutorials on Google Cloud and Open Source topics </span></span></span></div></div></div><div class="col-lg-12 col-md-12 col-sm-12 col-xs-12 cp-form-container"><style type="text/css" class="cp-form-css">.content-5d405be4802e6 .cp-form-container label:not(.cp-label){display:none}.content-5d405be4802e6 .cp-form-container label{color:rgb(153,153,153);font-size:14px;font-family:;text-align:left}.content-5d405be4802e6 .cp-form-container .cp-form-field select{text-align-last:left;direction:ltr}.content-5d405be4802e6 .cp-form-container input:focus:not([type='radio']):not([type='checkbox']):not([type='range']),.content-5d405be4802e6 .cp-form-container textarea:focus,.content-5d405be4802e6 .cp-form-container .cp-form-field button,.content-5d405be4802e6 .cp-form-container .cp-form-field input,.content-5d405be4802e6 .cp-form-container .cp-form-field select,.content-5d405be4802e6 .cp-form-container .cp-form-field textarea{text-align:left;font-size:13px;font-family:Roboto;color:#7a7a7a;background-color:rgb(255,255,255);border-color:rgb(191,190,190);padding-top:6px;padding-bottom:6px;padding-left:7px;padding-right:7px;border-radius:0}.content-5d405be4802e6 .cp-form-container .cp-form-field .cp-label{text-align:left;font-size:13px;font-family:Roboto;color:#7a7a7a;padding-top:6px;padding-bottom:6px;border-radius:0}.content-5d405be4802e6 .cp-form-container .cp-submit{padding-top:5px;padding-bottom:5px;padding-left:7px;padding-right:7px}.content-5d405be4802e6 .cp-form-container .cp-submit.cp-btn-flat{background:#2d53fe!important;border-radius:3px}.content-5d405be4802e6 .cp-form-container .cp-submit.cp-btn-flat:hover{background:#2046f1!important}.content-5d405be4802e6 .cp-form-field.cp-enable-box-shadow>div{border-radius:0}</style><div class="form-main cp-form-layout-3"><form class="cp-form smile-optin-form  "><input type="hidden" id="335073504_wpnonce" name="_wpnonce" value="9018908b4e"> <input type="hidden" name="cp-page-url" value="https://www.cloudbooklet.com/install-grafana-on-ubuntu-18-04-with-nginx-google-cloud" /> <input type="hidden" name="param[user_id]" value="cp-uid-a0401087a6ae07affbebe9afd3906432" /> <input type="hidden" name="param[date]" value="30-7-2019" /> <input type="hidden" name="list_parent_index" value="0" /> <input type="hidden" name="action" value="mailchimp_add_subscriber" /> <input type="hidden" name="list_id" value="cb3191389b" /> <input type="hidden" name="style_id" value="cp_id_bc43f" /> <input type="hidden" name="msg_wrong_email" value='Please enter correct email address.' /> <input type="hidden" name="message" value="Thank you." /> <input type="hidden" name="cp_module_name" value="Right Slide In" /> <input type="hidden" name="cp_module_type" value="" /> <input type="text" name="cp_set_hp" value="" style="display: none;"/><div class="cp-all-inputs-wrap col-xs-12  col-xs-12 col-sm-8 col-md-8 col-lg-8  "><div class="cp-form-field  col-md-12 col-lg-12 col-sm-12 col-xs-12 enable-field-attached"> <label>Email</label><div> <input class="cp-input cp-email" type="email" name="param[email]" placeholder="Enter Your Email Address"  required  /></div></div></div><div class="cp-submit-wrap  cp-submit-wrap-full col-xs-12 col-sm-4 col-md-4 col-lg-4  enable-field-attached"><div class="cp-submit btn-subscribe cp_responsive cp-btn-flat smile-animated  "   data-animation ="smile-slideInUp"; rel="noopener"> <span class="cp_responsive cp_font" data-font-size="12px" style="font-size:12px;"><span data-font-size="11px"><span data-font-size="9px">SUBSCRIBE</span></span></span></div></div></form></div></div><div class="cp-info-container
cp-empty				" ></div></div> <input type="hidden" class="cp-impress-nonce" name="cp-impress-nonce" value="5916cf2a8d"></div></div><div class="cp-form-processing-wrap" style="border-radius: 0px 0px 0px 0px;-moz-border-radius: 0px 0px 0px 0px;-webkit-border-radius: 0px 0px 0px 0px;;"><div class="cp-form-after-submit"><div class ="cp-form-processing" style=""><div class ="cp-form-processing" ><div class="smile-absolute-loader" style="visibility: visible;"><div class="smile-loader" style = "width: 100px" ><div class="smile-loading-bar"></div><div class="smile-loading-bar"></div><div class="smile-loading-bar"></div><div class="smile-loading-bar"></div></div></div></div></div><div class ="cp-msg-on-submit" style="color:#000000;"></div></div></div><div class="slidein-overlay-close cp-image-close cp-inside-close cp-adjacent-right" style="width: 23px"> <img class="cp-default-close" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="close-link" data-lazy-src="https://www.cloudbooklet.com/wp-content/plugins/convertplug/modules/slide_in/assets/img/cross.png"/><noscript><img class="cp-default-close" src="https://www.cloudbooklet.com/wp-content/plugins/convertplug/modules/slide_in/assets/img/cross.png" alt="close-link"/></noscript></div></div></div></div></div> <script type='text/javascript'>/* <![CDATA[ */ var Bunyad = {"custom_ajax_url":"\/install-grafana-on-ubuntu-18-04-with-nginx-google-cloud\/"}; /* ]]> */</script> <script type='text/javascript'>/* <![CDATA[ */ var smile_ajax = {"url":"https:\/\/www.cloudbooklet.com\/wp-admin\/admin-ajax.php"}; /* ]]> */</script> <script type='text/javascript'>/* <![CDATA[ */ var smile_ajax = {"url":"https:\/\/www.cloudbooklet.com\/wp-admin\/admin-ajax.php"}; /* ]]> */</script> <script type='text/javascript'>/* <![CDATA[ */ var smile_ajax = {"url":"https:\/\/www.cloudbooklet.com\/wp-admin\/admin-ajax.php"}; /* ]]> */</script> <script type='text/javascript' data-cfasync="false" async="async" defer="defer" src='https://www.google.com/recaptcha/api.js?render=explicit'></script> <script type='text/javascript'>/* <![CDATA[ */ var gglcptch = {"options":{"version":"invisible","sitekey":"6LcRq3oUAAAAAMgQwu9M_Xl_YfqYhB1JdQFlM0J9","theme":"red","error":"<strong>Warning<\/strong>:&nbsp;More than one reCAPTCHA has been found in the current form. Please remove all unnecessary reCAPTCHA fields to make it work properly.","disable":0},"vars":{"visibility":false}}; /* ]]> */</script> <script>window.lazyLoadOptions = {
                elements_selector: "img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",
                data_src: "lazy-src",
                data_srcset: "lazy-srcset",
                data_sizes: "lazy-sizes",
                class_loading: "lazyloading",
                class_loaded: "lazyloaded",
                threshold: 300,
                callback_loaded: function(element) {
                    if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
                        if (element.classList.contains("lazyloaded") ) {
                            if (typeof window.jQuery != "undefined") {
                                if (jQuery.fn.fitVids) {
                                    jQuery(element).parent().fitVids();
                                }
                            }
                        }
                    }
                }};
        window.addEventListener('LazyLoad::Initialized', function (e) {
            var lazyLoadInstance = e.detail.instance;
        
            if (window.MutationObserver) {
                var observer = new MutationObserver(function(mutations) {
                    var image_count = 0;
                    var iframe_count = 0;
                    var rocketlazy_count = 0;

                    mutations.forEach(function(mutation) {
                        for (i = 0; i < mutation.addedNodes.length; i++) {
                            if (typeof mutation.addedNodes[i].getElementsByTagName !== 'function') {
                                return;
                            }

                           if (typeof mutation.addedNodes[i].getElementsByClassName !== 'function') {
                                return;
                            }

                            images = mutation.addedNodes[i].getElementsByTagName('img');
                            is_image = mutation.addedNodes[i].tagName == "IMG";
                            iframes = mutation.addedNodes[i].getElementsByTagName('iframe');
                            is_iframe = mutation.addedNodes[i].tagName == "IFRAME";
                            rocket_lazy = mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');

                            image_count += images.length;
			                iframe_count += iframes.length;
			                rocketlazy_count += rocket_lazy.length;
                            
                            if(is_image){
                                image_count += 1;
                            }

                            if(is_iframe){
                                iframe_count += 1;
                            }
                        }
                    } );

                    if(image_count > 0 || iframe_count > 0 || rocketlazy_count > 0){
                        lazyLoadInstance.update();
                    }
                } );
                
                var b      = document.getElementsByTagName("body")[0];
                var config = { childList: true, subtree: true };
                
                observer.observe(b, config);
            }
        }, false);</script><script data-no-minify="1" async src="https://www.cloudbooklet.com/wp-content/plugins/wp-rocket/assets/js/lazyload/11.0.6/lazyload.min.js"></script> <script src="https://www.cloudbooklet.com/wp-content/cache/min/1/b9cf1af9472c1a4f90769873a3833961.js" data-minify="1" defer></script><script type="text/javascript" id="modal">document.addEventListener("DOMContentLoaded", function(){
						startclock();
					});
					function stopclock (){
						if(timerRunning) clearTimeout(timerID);
						timerRunning = false;
						//document.cookie="time=0";
					}
					function showtime () {
						var now = new Date();
						var my = now.getTime() ;
						now = new Date(my-diffms) ;
						//document.cookie="time="+now.toLocaleString();
						timerID = setTimeout('showtime()',10000);
						timerRunning = true;
					}
					function startclock () {
						stopclock();
						showtime();
					}
					var timerID = null;
					var timerRunning = false;
					var x = new Date() ;
					var now = x.getTime() ;
					var gmt = 1564498916 * 1000 ;
					var diffms = (now - gmt) ;</script><script type="text/javascript" id="info-bar">document.addEventListener("DOMContentLoaded", function(){
						startclock();
					});
					function stopclock (){
						if(timerRunning) clearTimeout(timerID);
						timerRunning = false;
						//document.cookie="time=0";
					}
					function showtime () {
						var now = new Date();
						var my = now.getTime() ;
						now = new Date(my-diffms) ;
						//document.cookie="time="+now.toLocaleString();
						timerID = setTimeout('showtime()',10000);
						timerRunning = true;
					}
					function startclock () {
						stopclock();
						showtime();
					}
					var timerID = null;
					var timerRunning = false;
					var x = new Date() ;
					var now = x.getTime() ;
					var gmt = 1564498916 * 1000 ;
					var diffms = (now - gmt) ;</script><script type="text/javascript" id="slidein">document.addEventListener("DOMContentLoaded", function(){
						startclock();
					});
					function stopclock (){
						if(timerRunning) clearTimeout(timerID);
						timerRunning = false;
						//document.cookie="time=0";
					}

					function showtime () {
						var now = new Date();
						var my = now.getTime() ;
						now = new Date(my-diffms) ;
						//document.cookie="time="+now.toLocaleString();
						timerID = setTimeout('showtime()',10000);
						timerRunning = true;
					}

					function startclock () {
						stopclock();
						showtime();
					}
					var timerID = null;
					var timerRunning = false;
					var x = new Date() ;
					var now = x.getTime() ;
					var gmt = 1564498916 * 1000 ;
					var diffms = (now - gmt) ;</script></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1564498916 -->